New member

So I learnt one fun thing about MMC in the process, there is a way to get it to show you some debug info (sorry ATI if this was "hidden stuff")

Create the following:

[HKEY_LOCAL_MACHINE\SOFTWARE\ATI Technologies\Multimedia\ErrorLog]

I DONT KNOW if min, max, and window are appropriate values, but this will make MMC, upon startup, open debug/log windows you can look at for info...


A "bad" codec, audio, that I had...

!!!!!!!!!OGG VORBIS!!!!!!!!!!!!!!!!!!

[I should've guessed, since showshifter for me was giving me trouble too related to some vorbis file]

My solution was:

I installed that (I tried removing my "bad" ogg vorbig but it wouldnt remove via device manager (Audio Codecs/properties)) and IT IS ALL SOLVED!!

A tip: I determined it was audio related by doing this:
DISABLE in device manager your sound card
run MMC (no need to reboot)
if it DOES NOT CRASH, its audio/audio codec related.

Please let me know if you have been having the conexc.dll error, and now no longer have it thanks to the above..

- Eddie
Glad you managed to get this fixed. I tweaked my registry as you have to find the source of the same error in my set-up, but don't have a clue where to look to uncover the issue. Could you tell us how you determined it was an audio codec that caused the conexc.dll hang? I don't have the codec that was causing you problems, so the downloadable fix you provided does nothing to help me.
Thanks eddie. I added the reg entry and fixed my CONEXC.DLL error! :D I had a fugged up "InterVideo Audio Encoder" codec. So I deleted the related files and any reg entries I could find and it works! I uninstalled all my intervideo stuff a long time ago and I guess it left some crap behind like everything seems to do. But it works now!

dshorthouse: After you add the entry that eddie described, open up the TV app and wait for the error to pop up. Find the log window that says "Found Filter:" a bunch of times and "Loading Filter:" at least once. The very last filter on the "Loading Filter:" lines is probably the one giving you trouble. Of course it could be something else, but I'm sure it'll be a codec more often than not.

One more thing, I installed the DVD-7-6.EXE right before installing mmc-8-1-0-0.exe, and now my DVD app is coming up version "8.1". I don't know why, but I'm not complaining.

And yes, this is my first post, thanks for the great forum.
SOB!! I too had a lot of InterVideo crap left behind in the registry. Must have been that WinDVR crap with a lousy uninstall. You were right, it was hanging on a reference to an InterVideo codec, which was no longer on my machine. I'm happy my brainwave about this having been a codec issue led to Eddie's discoveries. Thanks for the work, Eddie!
Glad I could help :) Yeah, I guess it is true that the way to "fix this" is to look at the LAST filter that loads (mine was indeed ogg vorbis) and remove/reinstall/fix whatever codec that refers to.
Thanks, I got it fixed too.

First it was the ogg-vorbis encoder. Installed the new Nimo codec pack. Still crashed, but now it was the lame mp3 codec. So install the newest lame codec and now it works.
So I learnt one fun thing about MMC in the process, there is a way to get it to show you some debug info (sorry ATI if this was "hidden stuff")

It wasn't hidden, just not published. If we wanted it hidden we would have compiled it OUT of release code. If it helped you guys resolve the problem it served its purpose.

The end result here is that there are a class of "badly behaving" DShow codec out there which may negatively effect (okay crash) MMC. We may be able to put some defensive code in place to prevent the crash from happening a second time (detect and avoid the "bad" codec. We shall see.

At least this isn't an actuall MMC bug we are talking about. PC are such complex beasts.

Nice debug options but steven will we in a next MMC finally se a new teletext enginr the old one really doesn´t work well and is there a way to fix the TV on demand bug some of us have been having (specially people with AIW Radeon DDRs) - Is it a WDM driver bug or a software flaw and sorry to bug u again about teh PAL AIW RADEON 9700PRO but its been a month since the press release and the "large quantities" are nowere to be found. If u can could ask someone from the sales departemnt tp get some info in on the state of this product from Sphire or HSI (who are supposed to be selling this product here in Europe and Asia and don´t anser to product inqueries and questions on there support :() and if they could know why the PAL version is almost 5 months late?

Other then the bug on TV on demand MMC works well (gotta love video soup:) but the audio sync on avi files is really bad .What can we do to rid ourselfs of that problem? Also another problem is the recording of more then one file. If I for example record something and stop it and then wanna record something else (vidthout having to restart windows it doesnt happen! When I puch the recording button again it strats to record but stays at 00 seconds and then there is no output file its odd really.

On the other side the File Player suddently has trubble with VCD compliant MPEG1 and the DVD player is unable to play SuperVCDs (the VCD player also doesnt play those) now it there a way to force the DVD palyer to play cDVDs or SVCDs and if so how.

hmmmmm thats all (damn this sounds more like a bug report i should stop playing the beta tests of mmorpgs i already soundlike someone from quality assurence :) Well at lest I hope the descriptions of the bugs help to sort them out:) and that in the NEAR (not distand as it seems now) future i will be able to replace my old AIW Radeon whit a AIW 9700PRO PAL!
It worked!

It worked!


Dude, you rock!! It worked great. In my case it was bad registry entries related to Intervideo MPEG Audio Encoder. I deleted the codec files but the errors continued. But a quick search through the registry found two entries that I deleted. Hope it doesn't prevent WinDVD from running though - gotta test that soon - I suspect it's a leftover from the WinDVR trial.

Thanks again!!
A million thanks to you Eddie. Your instructions helped greatly. I replaced my ogg vorbis codec and presto!, no more errors. YOU DA MAN!!

System: KR7A RAID
Maxtor 80G & 2x20G
Athlonxp 1600
512MB PC2100
Lite-on 48x CDRW
Lite-on 16xDVD
Radeon AIW(7200)
Soundblaster Live!
Dual boot XPSP1 & wIN98
I have the same problem, But I don't know how to solve it...

I have the same problem, But I don't know how to solve it...

well, after disabling the "sound blaster live (wdm)" at device manager, the tv has no problem.
but after I get back the driver it still has the problem, even though I disabled ALL the audio codecs.
what should I do?
is there another method to remove/disabling codecs?
help me....

I assume you went through all the messages above? Did you enable the registry "hack" to view the log? This is very important and will allow you to find the codec which causes the error. Merely disabling/uninstalling codecs does not help - you have to eliminate the registry entries of (ONLY) the offending codecs as well. Chances are it's the Intervideo MPEG Audio Encoder :D
InterVideo was the culprit for me. It seems that WinProducer has a crappy uninstall. It had left behind close to 100 registry keys. It was probably only the InterVideo audio encoder/decoder keys that were problematic, but I cleaned everything while I was at it.
Hehe, funny thing, as the original "solver" of all this, I recently had another "MMC pops up an error dialog upon startup" ...

tried "debugging" it the way I desribed, but nope, couldn't find anything... gspot would crash, sysenum.exe would crash enumerating "Video Compressors"...

To cut it short, once again regmon came to the rescue. I traced all registry calls from gspot, and looked at the last registry call before it crashed (when a program crashes, it will start calling up registry keys referring to things like AEDebugger, Dr Watson, etc).

It was looking up HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32\VIDC.DRAW
when it crashed.
I went to the registry, and it said "DVIDEO.DLL"... but wait, it looked funny.

It actually said " DVIDEO.DLL" .... if you're not good at noticing subtle things, THERE WAS A SPACE IN FRONT OF THE STRING!!!!!!

Removed the space.

Problem Solved.

No more MMC dialog error, no more gspot crash, all codecs and related stuff fixed. Perhaps this may help someone, someday...

- Eddie
please help. i have been searching for ever and found this post it was helpful because it should that it is a audio problem. now the problem is i dont know how to fix it. i made the log file but not sure wat codec is causing the problem. here is the list if i made the log file correctly, of audio filters. you guys said it is probably the last filter, so i assume you mean the one that is loading, if it is im not sure how i would fix that filter. "wm speech encoder" any suggestions would be greatly apperciated.

[14:12:22] EnumGraph:: *************** Complete *************
[14:12:36] Found Filter: WMVideo Encoder DMO
[14:12:36] Found Filter: MSScreen encoder DMO
[14:12:36] Found Filter: WMVideo9 Encoder DMO
[14:12:36] Found Filter: WMVideo8 Encoder DMO
[14:12:36] Found Filter: MSScreen 9 encoder DMO
[14:12:36] Found Filter: DV Video Encoder
[14:12:36] Found Filter: DVMpeg Cmp Filter
[14:12:36] Found Filter: Indeo® video 5.04 Compression Filter
[14:12:36] Found Filter: Indeo® video 5.10 Compression Filter
[14:12:36] Found Filter: Indeo® video 5.11 Compression Filter
[14:12:36] Found Filter: InterVideo MPEG Video Encoder
[14:12:36] Found Filter: MJPEG Compressor
[14:12:36] Found Filter: Morgan MJPEG Compressor
[14:12:36] Found Filter: PICVideo Lossless JPEG Compressor
[14:12:36] Found Filter: PICVideo MJPEG Compressor
[14:12:36] Found Filter: PICVideo Wavelet 2000 Compressor
[14:12:36] Found Filter: DivX ;-) MPEG-4 Low-Motion
[14:12:36] Found Filter: DivX ;-) MPEG-4 Fast-Motion
[14:12:36] Found Filter: DivX Codec 4.12
[14:12:36] Found Filter: DivX Pro 5.0.2 Codec
[14:12:36] Found Filter: Huffyuv v2.1.1
[14:12:36] Found Filter: Intel 4:2:0 Video V2.50
[14:12:36] Found Filter: Indeo® video 5.04
[14:12:36] Found Filter: Intel IYUV codec
[14:12:36] Found Filter: PICVideo MJPEG Codec
[14:12:36] Found Filter: MS MPEG-4 3688 V2
[14:12:36] Found Filter: MS MPEG-4 3688 V3
[14:12:36] Found Filter: MS MPEG-4 3688 V1
[14:12:36] Found Filter: PICVideo Lossless JPEG Codec
[14:12:36] Found Filter: PICVideo Wavelet 2000 Codec
[14:12:36] Found Filter: VFAPI Reader Codec 1.03
[14:12:36] Found Filter: XviD MPEG-4 Codec
[14:12:36] Found Filter: ATI YUV12 Format Codec
[14:12:36] Found Filter: ATI YUV12 Format Codec
[14:12:36] Found Filter: WM Speech Encoder DMO
[14:12:36] Found Filter: WMAudio Encoder DMO
[14:12:36] Found Filter: ATI MPEG Audio Encoder
[14:12:36] Found Filter: Indeo(R) audio software
[14:12:36] Found Filter: InterVideo MPEG Audio Encoder
[14:12:36] Found Filter: Vorbis Encoder
[14:12:36] Found Filter: IAC2
[14:12:36] Found Filter: Voxware v1.1.8 Bitstream-Mode Codecs
[14:12:36] Found Filter: Voxware MetaVoice
[14:12:36] Found Filter: Voxware MetaSound
[14:12:36] Found Filter: PCM
[14:12:36] Found Filter: Ogg Vorbis (mode1)
[14:12:36] Found Filter: Ogg Vorbis (mode2)
[14:12:36] Found Filter: Ogg Vorbis (mode3)
[14:12:36] Found Filter: Ogg Vorbis (mode1+)
[14:12:36] Found Filter: Ogg Vorbis (mode2+)
[14:12:36] Found Filter: Ogg Vorbis (mode3+)
[14:12:36] Found Filter:
[14:12:36] Found Filter: DivX WMA Audio V1
[14:12:36] Found Filter: DivX WMA Audio V2
[14:12:36] Found Filter: MPEG Layer-3
[14:12:36] Found Filter: Voxware v1.1.6/1.1.8 File-Mode Codecs
[14:12:36] Loading Filter: WM Speech Encoder DMO
Looks to me like a Windows Media speech encoder codec. Maybe someone else might know where this would have come from, but my guess is something like the text-to-specch utility in Office XP. Maybe a dumb guess, but thought I'd try anyway.
Thanks a bundle!

Thanks a bundle!

Thanks a lot for that tip about oggvorbis , I installed it and voila no more error when launching TV tuner!
Yippee.... i was stating to go nuts!
Thanks a lot!!!, I was going nuts with the error at the start, I thought I had to reinstall windows again!!!

The problem was a DIVX audio codec.

Thanks again