ATI IS TEH PIMP DADDY!!! (8500 & Linux)

Not open for further replies.
did anyone tried RtCW SP-Demo ?

did anyone tried RtCW SP-Demo ?

If I run it with max details, it becomes very slow on a 64 MB card. This could be some problems with the AGP-textureing. Anyone tried it ith a 128 MB card?

Why is anyone even arguing with LukaR ??

Oh btw, don't confuse the word 'Linux' with GUI layer and the apps and the etc.. that stuff almost always in beta, and like any beta product it's got problems... if you want to talk about stability, once all the optimizations are compiled into the kernel you can't beat it, there's really no point in arguing that, it's and industry fact I didn't make it up. Now the fact that you say going to Linux puts you 10 years behind the game means one of the following : you don't know how to run Linux : You don't have the brain power to comprehend what a 'shell' is and therefore you hate Linux : You have no need what so ever to run Linux because, well you just don't need it : You have no programming skills what so ever and you hate the idea of being able to compile on the fly and write scripts etc... etc...

so pick one, but don't come out talking like you're a leeding authority on the subject, in short if you don't know what you're takling about and are bashing it based on one bad experience that you probably had once installing linux (what's that swap partition for ? why doesn't this look and feel like windows?? Why can't I seem to eject my CD's) then please don't respond to the thread, it's better for all of us this way.

And ever here of StarOffice ? Look it up and tell me that you still 'love' MS Office, especially at 400$ cdn.


LukaR said:

I didn't say anything about hackers, anyway everybody today calls themselves hackers, honestly they're so far away from to be 'letter H of word hacker'

tell me Are you hacker? lol

As I said going to linux (for home OS) is going 10 years in past.
I'm using my windows XP, running games, adobe photoshop, Microsoft Word, Macromedia Programs, watching movies, listening music, surfing internet...
OS is kick ass. Well I'm not server admin and I don't keep some importand inf on my computer.
Smart man would never use computer to store important inf documents etc. no matter how much secured OS is running.

Anybody else run into a dependancy problem with I've got Mandrake 8.2 and I only seem to have loaded. Any suggestions would be helpful. I apologize ahead of time for the linux n00bness I will likly extrude in great quantities. Please watch your step. :p

(note: I already tried making a copy of named in the hopes it would use the later version ok, but it still cannot find it at all.)
You can find libpng2 in Mandrake 8.1. If you do not have the CDs, you can find it in official and mirroring ftp servers.
BTW, for your copy of libpng file, it was a good idea but : you should better do a symbolic link ln -s and then run ldconfig.

I still have a problem with 3D acceleration : the GL drivers loaded are the Mesa ones, when I run frglxinfo. Should I keep the Mesa package ?
Last edited:
Actually linux and windows both have there good bad and evil points

Linux's main failing imo is acronyms too many and having to compile things (blatently stupid ideas and no instructions on how the hell to do it :E oh and the boot time is crap. Other than that its great KDE is a cool desktop system and it all works nice all the time :)

and u know whats even better OPENGL ON MY RADEON8500 RAHHHHHHHHHHHHHHH

What is Linux? Is it something to do with little animals that live in areas with ice caps?

You guys should congratualte me I went to apple store and asked the representatives if they sell Windows XP or 2000, and asked one of them why this expensive desklamp costs $950 and displays what appears to be internet info while providing great luminescence....I got kicked out of the store...Kinda cool, always wanted to do that. I apologize for all the apple fans out there. hehehe I don't care if it can do movies but can you tweak it? (apples)

Tweaking is yet another reason why Linux is here, it just allows the users not only tweak their hardware but also their software. Yeah I know Os X is running Unix.


Let's move onto apple vs Pc debate. HEHEHEH Jk disregard this post.
As many people have said.. Linux and Windows both have their good points.

I do like Linux a lot.. but I dont use it as my main desktop OS as it really doesn't make too much sense for me.. I do some web browsing, I play some games, I listen to music. If it wasn't for the lack of game support, I would use Linux more often at home - so for now I stick with Windows XP.

But at work its a different story.. my main system is a Sun Solaris box, and I setup & configure all of my servers on Linux - it gets the job done, you dont have to worry about stupid Windows quirks.. it does the job and it does it well.


Do these work in freebsd as well? I run xfree86 4.2.0 im forced to use the rage drivers for my radeon 8500 to work in X, but i dont have 3d support I NEED 3d SUPPORT!! heh. ok please some find out thanks!! ive been waiting months for this
@tempnexus and some others :
Could we please avoid the Windows vs OSX vs Linux debate? We are supposed to talk about the ATi Linux drivers here. If you want to discuss about Linux, there is another area called "OSes" here. Thank you.
I don't know what your problem is with Windows. Did you know screensavers are customizable?? Ive had Windows 2000 Pro running for 2 weeks straight on my system without a single crash. Maybe if you have ME or 98 you'll get the BSOD but not with Windows 2000

EDIT: Sorry, didn't see the above post
Last edited:
Installing the FireGL DRI driver under Linux

Installing the FireGL DRI driver under Linux

The driver itself is distributed as an RPM, so you install the RPM appropriate for your X first. Then you run the fireglxrcfg file (which makes the appropriate changes in your XF86Config or XF86Config-4 file). Restart X, and you're done.

The entire procedure is in the Release Notes for the driver.

Two nitpicks: UT and Q3A won't work with this driver.
travbrad1001 said:
I don't know what your problem is with Windows. Did you know screensavers are customizable?? Ive had Windows 2000 Pro running for 2 weeks straight on my system without a single crash. Maybe if you have ME or 98 you'll get the BSOD but not with Windows 2000

EDIT: Sorry, didn't see the above post

I do not have any problem with Windows XP or 2000, I do not have them, I do not use them. Now I would just be able to use freely the system I want and without to know what problem the Windows fanboys have with Linux. Linux does not prevent anyone to use Windows. Anyone is free to spend their money where they want, and is free to speak, isn't it ? So let's keep freedom of everyone by respecting everyone : Mac users, Linux users, Anything users and Windows users.

Let's come back to the discussion about these drivers please.
FGL DRI drivers and RH 7.3: YES!!!

FGL DRI drivers and RH 7.3: YES!!!

ruppe said:
Has anyone succesfully installed this driver on RH 7.3 ?
In that case, pls give me some pointers on how you did it.

When I try to run the in /lib/modules/fglr200/build_mod it says that it can't find some version.h file and that I should check my symlinks.(it's a fresh install of RH 7.3 im using so I haven't had time to screw anything up yet...i hope :) ).

I have the drivers installed on the UNserver's Linux half (RH 7.3, AKA *Valhalla*) glxgears flat-out *smokes* (2000 fps at the standard window size!) and I'm running at the *same* resolution I had the R8500 2D drivers set for (1280x1024@24-bit color); however, I installed all the updates to 7.3 first (including the new 2.4.18-4 kernel and the source thereof).

For some reason Q3A and UT hate the OGL driver, though.
How I did it...:)

How I did it...:)

Elysian said:
i'm having quite the number of issues... i got the 2d drivers to work flawlessly... i installed mesa3d 4.0.2... i made sure i had DRM compiled in my kernel(2.4.18)... i ran fglrxconfig and did all that.... startx.... go to a xterm.... run glxinfo.... direct rendering: no.... what am i doing wrong? i loaded the module and all... it loads with my kernel... so now what? i even got the "bleeding edge" tcl support dri modules for the radeon... no luck with those either... any ideas? maybe someone figured this problem out already?

Here are my steps:

Installed RH 7.3 (Valhalla).

Run rhn_register, enable the profile for this box.

Run up2date, downloading all available updates (including kernel 2.4.18-4 and the source). Reboot.

After rebooting, go to ATI Support page, download/install the FireGL 8800 driver RPM for XFree 4.2.0, install, run fglxrcfg, restart X.

glxinfo shows DRI is loaded and enabled, glxgears is charging right along at 2000 fps (!!!), TuxRacer runs to solve the Q3A/UT problems...

(pasted from /var/log/XFree86.0.log)
(II) fglr200(0): [agp] enable AGP protocoll: 0x1f000302
(II) fglr200(0): [agp] AGP protocoll is enabled for grafics board. (cmd=0x1f000302)
(II) fglr200(0): [DRM] register handle = 0xe1100000
(II) fglr200(0): [DRM] ringbuffer size = 0x00100000 bytes
(II) fglr200(0): [DRM] DRM buffer queue setup: nbufs = 100 bufsize = 65536
(II) fglr200(0): [DRM] texture shared area handle = 0xfd0c3000
(II) fglr200(0): before VisualConfigs initialized
(II) fglr200(0): VisualConfigs initialized
(II) fglr200(0): DRI initialization successfull!
(II) fglr200(0): front buffer: 0xd8000000
(II) fglr200(0): offscreen: 0xd8500000
(II) fglr200(0): back buffer: 0xd8700000
(II) fglr200(0): depth buffer: 0xdbb00000
(II) fglr200(0): FBADPhys: 0xd8000000 FBMappedSize: 0x00700000
(II) fglr200(0): FBMM initialized for area (0,0)-(1280,1433)
(II) fglr200(0): FBMM auto alloc for area (0,0)-(1280,1024) (front color buffer - assumption)
(==) fglr200(0): Backing store disabled
(==) fglr200(0): Silken mouse enabled
(II) fglr200(0): Using hardware cursor (scanline 1024)
(II) fglr200(0): Largest offscreen area available: 1280 x 401
(II) fglr200(0): Using XFree86 Acceleration Architecture (XAA)
Screen to screen bit blits
Solid filled rectangles
Solid Lines
Dashed Lines
Offscreen Pixmaps
Setting up tile and stipple cache:
30 128x128 slots
(II) fglr200(0): Acceleration enabled
(II) fglr200(0): X context handle = 0x00000001
(II) fglr200(0): [DRI] installation complete
(II) fglr200(0): Direct rendering enabled
(II) Loading extension FGLRXEXTENSION
(II) Setting vga for screen 0.
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(**) Option "Protocol" "ImPS/2"
(**) Mouse1: Protocol: "ImPS/2"
(**) Option "CorePointer"
(**) Mouse1: Core Pointer
(**) Option "Device" "/dev/mouse"
(==) Mouse1: Buttons: 3
(II) Keyboard "Keyboard1" handled by legacy driver
(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo/, removing from list!
SetKbdSettings - type: 2 rate: 30 delay: 500 snumlk: 0
SetKbdSettings - Succeeded

RH 7.3 (Valhalla) is now DRI DRIven!
Last edited:
Anyone got this to work in bsd ?
And please NO linux vs. bsd debating.
I just want to know if anyone has attempted it.
Tisual said:
Anyone got this to work in bsd ?
And please NO linux vs. bsd debating.
I just want to know if anyone has attempted it.
Hey it's bad enough with the Linux vs Windows trolls in this thread. I would say almost 100% guarntee this would fail because the drm portion is for the Linux kernel.
terracon said:

Hey it's bad enough with the Linux vs Windows trolls in this thread. I would say almost 100% guarntee this would fail because the drm portion is for the Linux kernel.

acctually, i bet if you followed steps for making the Linux Matrox drivers work in FreeBSD you would probably come across some measure of success... dunno tho...
slow compaired to the windows drivers...

slow compaired to the windows drivers...

I got them running pretty nice, without very much effort, but they are quite a bit slower than the windows drivers, its pretty strange

I only get like 67fps in quake3, while in windows i get closer to 120fps, must not be very optimized yet
Grrr... still no luck with the dependancy issue. I've tried the symbolic link, Ive tried to find any package, anywhere, that has in it, with no luck(even ones that where supposed to, didn't), and I even discovered on the Mandrake forum there is a thread about and how it is NOT compatable with, and that they cannot even be used at the same time! Grrr...

Any insight on this would be GREATLY appreciated! Also, if someone with Linux could see if they have and make it available to me... ;)

[EDIT] Nevermind! I got it from the redhat site and it did the job. Now that the driver is installed however, I can't run the config because it overwrites THE WHOLE DAMN x86config FILE!!! USB mouse isn't even a choice??? Anyone know how I cn get around THIS?

[EDIT 2] Once again, nevermind. Got it installed. They still don't work of course...
Last edited:
Not open for further replies.