Remote Wonder Working

Why for the love of all that is holy is this still a problem? I just upgraded my htpc and now once again I am in remote wonder land of hell...

I just gave up and installed drivers grom cd 2.54 that actually work.

Even with all the fixes I had the atiSserv.dll fail to register so it would never work.
Heres what I did. I uninstalled the software from the 'add/remove programs' Then I had to goto the device manager. Under USB, I removed the remote wonder that was in there.

Reinstalled software, rebooted.

This thing is a real pain. I have the Remote Wonder I and my system is very picky on which driver it will work with. I have to use 3.03. If I use any other version it doesnt work.
Last edited:
Hi, all
I just wanted to say thanks for all the help guys have posted about trying to get the remote wonder to work. I have tired everything posted here for a day now. Still no luck x10net.dll problem :(..... Funny thing is the remote installs fine on my older systems... 2 dell's and one system based on an intellchip set.... I am trying to get it to work on a via chipset system.. I just sent in 10 truble tickets all on diffrent email acounts to ATI... I hope fully they will send me something back.. I am not counting on it..
I want to apologize in advance for the spelling mistakes I make in this post. The wounds from the hot pokers are still fresh in my eye sockets! I've been struggling mightily with the Remote Wonder Plus install on a fresh copy of MCE. I completely understand the frustration put forth in this thread. I get the same errors about DLLs not being registered and this happens to me after a fresh install of MCE. How, in 2006, can the installer be this hosed? It's unforgiveable, really.

Fortunately, I believe I've found a fix that requires no registry editing, no DLL copying (and re-registering) and no hot pokers in your eyes.

I believe ATI has somehow screwed up the English only version of the 3.03 Remote Wonder installer. I had problems (off a fresh install of MCE) with the file 3-03_rw_enu.exe. This version gave me the errors everyone has been getting. But, when I downloaded and installed the multilanguage version 3-03_rw.exe the installer worked as expected. No errors upon reboot. I was left with a fully functional Remote Wonder Plus after plugging in the USB receiver.

I even tested this by wiping my drive and doing another reinstall of MCE. It worked perfectly. If someone else could confirm I'm sure we'd all appreciate it.