PowerDVD 4 plug-in now available

princi, let's see if we can find more info from the plugin...

Please install this - zptest.zip - and overwrite the files you currently have now. Just delete the DLL later since this will take over all of RW's events.

Open PowerDVD, then push forward, rewind, A, B (in that order). Write down everything it says.
 
Aiiyah - Write down everything? There was a lot to write down. I thought it was being written to a log file (went through and pushed every button).

They all seemed to comeback with unique responses.

I'll try it with the real plugin this time - maybe it'll work.

(just re-installed again and install the new xpsp1 build 1079)

If that doesn't work, I'll write it all down for you.

Thanks for your help, and providing that testing .dll
 
All the other buttons seem to be ok. It's just the programmable ones (and the FF and REW I think)

So, here you go, the info you asked for:

A

[Received [42][1][1000048][Class of Cyberlink Universal Player][PowerDVD]

(click OK)

Received [42][0][1000048][five chars of garbage]square box



B

[Received [43][1][100004B][Cyberlink Video Windows Class][PowerDVD]

(click OK)

Received [43][0][100004B][same five chars of garbage]square
box

(the garbage looks like foreign language characters - maybe it's chinese - although my PowerDVD is in english)



C

44 and 55

OK

same


D

45 and 41

OK

proper message this time


(did it again - response was the garbage again)


I think that's enough. There's obviously some data corruption taking place here. It seemed to work properly once, but all the other attempts have produced those same five garbage characters with the square box at the end.

At a guess, I'd say the signal is being received properly, but whatever happens after I click OK is failing.


Thanks for your help,

Scott...
 
I think I've found the problem (but have no idea what the solution is)


The buttons that don't work for me when using PowerDVD and your PlugIn - are precisely those buttons that come back with those five garbled characters.

I tried your testing util with other buttons (Stop, Play etc.) and they all came back with proper responses (after clicking OK).


This is clearly the key to solving this, but I don't know where to go from here.
 
Also, I noticed if I change the assignments - they don't actually work.

Eg: Change Mute to L/R Audio select

But Mute still worked as Mute.
 
Okay, I think I got it. What's happening basically is that it can't find the PowerDVD window and makes Remote Wonder take over. When that happens, A-F pops up that message, fforward stops, etc. I'm guessing you're playing a file? But not in the test below, right? When it's playing a file, it looks like it changes its window title to the filename. I think when I test PowerDVD, it was always VCD or DVD so I missed that.

At least I hope that's it. :D

Let's see... download test plugin
 
Well done, Holmes!

You solved the case!


It's a shame though that PowerDVD only let's you switch between languages (L/R) when it's been burnt to a CD. If I play it as a file, I can't switch languages....but that's not your fault!


Thanks again!!!
 
Excellent! :)

About the audio - Yup, Hollywood+ does the same thing also. I've been watching dual-language HK movies lately and it's a pain...
 
I noticed that when I installed ShowShifter, after everything was working fine with PowerDVD, it killed the PowerDVD plugin!!

It's gone back to the old problem. FF & REW don't work, programmable buttons don't work.

ShowShifter uses it's own Remote Wonder system tray applet (you can't use ATI's one at the same time). But of course it's not running now, and I even re-booted.

If you want to try and replicate this, you can download ShowShifter at www.showshifter.com


What a shame! It was working so well.....
 
I'll give it a try this weekend if I can...

But do other plugins like Winamp still work?
 
I've been playing with ShowShifter 1.7, running the "X10 RF Anywhere" software, unloading it, then running the ATI software, etc... I wasn't able to duplicate the problem. PDVD plugin still works at least under VCD and AVI playback that I tested. Are you playing something else by chance? Maybe I missed something else.

Could you also verify that the PDVD plugin is version 1.04? Open the PDVD plugin's config window and look at the lower-left side. I believe the one shown by the ATI software is cached.
 
Hi,

Thanks for going to this trouble.

I checked the version number: 1.04

So, I fired it up again and tested it once more.

And it worked.

What have I done since the last time?

- Updated to XP SP1 build 1086
- Applied the latest CyberLink patch (1811) to PowerDVD4

Maybe one of those fixed it.

Thanks again for going to all the trouble,

Scott...
 
Back
Top