WinAmp plug-in won't "stick"


New member
I have installed Remote Wonder 1.4 software and everything works well except when I import either the included WinAmp 2x plug-in version 1.0, or NiDan's version 2.0 modified WinAmp plug-in they will not reappear in the plug-in tab after I reboot. They both work well when I first import them, and put a check by them, and I can configure NiDan's WinAmp plug-in, but after restarting my computer they are gone and I have to re-import them. The DivX Player 2x, Microsoft Power Point, and Multimedia Center Library, plug-ins will remain in the plug-in tab though. Both WinAmp plug-ins are listed in my registry under: HKEY_CURRENT_USER\Software\ATI Technologies\Multimedia\Remote Control\Plug-ins\Winamp (and Winamp 2x) along with my other plugins. Both WinAmp plug-ins appear to be enabled in the registry. I have tried to register the original "Winamp.dll" (Which I had to rename it "Winamp original.dll" to avoid a naming conflict) with RegSvr32 the window comes up;

DllRegisterServerinE:\PROGRA~1\ATIREM~1.4\Plug-ins\WINAMP~1.DLL succeeded.

This looks, as it should as this is where on my computer I have the Winamp.dll file located. I then tried to register NiDan's Winamp.dll and the window comes up after this stating;

E:\PROGRA~1\ATIREM~1.4\Plug-ins\Winamp.dll was loaded, but the DllRegisterServer entry point was not found. This file can not be registered.

I have tried un-installing the Remote Wonder 1.4 software making sure all the registry references to this software are removed. I then when through the whole procedure of installing the original Remote Wonder version 1.1 software, then I installed the Remote Wonder version 1.2 software that supports plug-ins. I then tried to see if the WinAmp plug-in would remain in the Plug-ins tab after I rebooted, it did not. Then I installed the Remote Wonder 1.4 software again, the WinAmp plug-in problem remains. All this to just get a plug-in to "stick" with the Remote Wonder software. This computer is a dual boot with Win 98se on the C:\ partition, and Win XP on the E:\ partition, and I do not have this problem with the Remote Wonder using Win 98se. NiDan, or anybody have any ideas as to why I am having this problem. Sorry for the long post.
that's pretty messed up... i'll look at my system tonight after i get home from work and i'll see if i can see any reason why that is happening.

it's probably my half-assed coding style that the 1.4 drivers don't like.
NiDan: I would not be quick to blame your plug-in, (I really like it!) and the Remote Wonder 1.4 software. On the Win 98se partition of my dual boot your plug-in does "stick". It is only on the Win XP partition it does not. Also when I had re-installed the Remote Wonder 1.2 software on the XP your plug-in, and the Ati Winamp 2x plug-in both do not "stick". So I do not blame ATI either, it must be that I have some how messed up my registry, but I sure can't find out where. Thanks for your looking into this, and I would be interested in any ideas to fix this you may have.
I'm having the same problem but with all my plug-ins and all the programmable buttons. If I reboot or close the remote app I lose all my settings and it all goes back to an empty default window. I've tried 1.1, 1.2 and now 1.4 but they all do the same.

I've tried cleaning out my registry and reinstalling but that hasn't worked either. I'm running XP. Any ideas please let me know.
sorry it took me so long to get this to you guys hope i can help.

navigate to this key in the registry and see if it looks like i describe it below: HKEY_CURRENT_USER\Software\ATI Technologies\Multimedia\Remote Control

there are 7 folders 1 for each letter button + 1 plugins folder with a folder for each plugin below it that has a listing for each letter and the directory location of the plugin.

if you do not see the keys i can attempt to export and upload them but i am on w2k not XP so things may act strange.
NiDan: Ya, this is what is strange, I have all the correct registry keys, and they are pointing to the correct plug-in locations. That is why I can't see why your plug-in, and the original WinAmp plug-in, are not "sticking"?
My registry must be doesn't contain any of the settings for the buttons even after i have set them. The only things I have in the ati remote folder are...

confirm power off multimedia 1
confirm power off windows 1
program per feature 0
task bar icon 1

It won't let me change program per feature to 1. Any ideas or can someone export their reg settings? (and tell me how to import :))
Plugins won't stick - Waaah! I'm pulling my hair out!

Plugins won't stick - Waaah! I'm pulling my hair out!

Hi! I've had this problem for three years now - and on my second machine with the same ATI Remote. It's driving me nuts! Every time I want to use the remote, I have to reload Nidan's plugin. I've tried deleting the entire registry key:
HKEY_CURRENT_USER\Software\ATI Technologies\Multimedia\Remote Control
The key is rebuilt when I reload the remote, but every time I reboot or quit then reload the remote, the plugins are forgotten. :confused:


I wish this thing would actually work. Why does ATI build such good hardware but such crappy software and documentation?

Anyone that can solve this would be my hero for the month!!