SOF 2 Radeon 8500 problem?


New member
Well, I just installed Sof 2, put all detail maxed. The game is working fast and smooth for 15 minutes, than frames drop below 20.
Then I exit from games load again, everything is cool and than after 10-15 minutes playing frames drops, it's unplayable.

I tried to turn off details, the same happen, i guess that's not problem.

Does anybody have this patience is on the end with Ati.

I'm using winxp 6071 i also tried with opengl patch...doesn't help

Intel Pentium IV 1.8 GHz
Radeon 8500 64mb ram
640 mb RDRAM

p.s. if I don't fix this, i'm gonna take that doomed ****ing card and put in trash...
I dont think its the card causing the problems.....could be the game itself but I dont have that problem so ......

Tricky....I really dont know how to help :\
I found out problem, I change shadow option to blob (complex is too much, 128mb version card shouldn't have problem) now everything is cool...all other detail maxed.
Also filtering is now 16x :)
I had the same problem, but it wasnt shadows for me.
The problem lies in the "longitivity" switches for Graphics, Sound and whatsoever ;).
I had to switch all three to "none", then everything ran smooth all the time, even after 3 hours of playing and all other switches are turned to the max (even shadows :)) !
I think I have the longevity set to short or whatever the lowest is before none and it works fine here. I played for several hours last night with no probs.
When I start up SOF2 and I get to the main menu, I hit ALT+ENTER to put the game in a Window. Then I hit ALT+CTRL+DEL to bring up the Windows Task Manager. I then right-click on the SOF2.EXE file and select Set Priority and choose Above Normal. Close the task manager, go to SOF2, and hit ALT-ENTER again. This seems to help a little bit, too.
hey at least you all could try it out.

I couldnt even get it to load a game!! It went to the loading screen, and hung at 3 bullets(one hidden by the clip)

tryed it 3 or four times, and uninstalled the bugger.
Well I turned on projection shadows...the problem was very high text, limitations to 64mb ram is problem :)
So I setup high text and that's it, everything other is maxed including filtering 16x :)