Remote Wonder install issues


New member
Right here's the deal. I bought the sapphire remote control bob for my new HTPC i'm setting up. Initial install went fine and worked no problem. I have now installed a quiet hard drive in there and bam the remote will absolutley refuse to work. I've tried the driver cleaner route as well as the X10 driver route but with no luck.

Everything seems to install fine and when i reboot and plug in the receiver a box pops up asking for the file x10ufx2.sys I have tried copying this file from another pc(on which the remote works fine) to the drivers file in the ati folder as well as specifying the location of the file to be in system32/drivers folder.

I never seem to be able to get the little remote icon to appear in the task bar. I'm asking this here as this was the only place i've found on the net so far for this remote and i'm really starting to wish I never bought the damn thing!:mad:

As an absolute last resort do you knowledgeable chaps on here think that a complete rebuild of windows would solve the problem??

Any help greatly appreciated as i'm rapidly starting to lose hair here!!!!
Just a side-note; I ran into this issue trying to downgrade another system here. It's due to the fact that the 3.0.2 RW uninstaller AND Driver Cleaner Pro miss quite a bit in their uninstall/cleanings.

Even after running both of these to 100% completion, the system will try to boot up with the x10ufx2.sys prompt.. every time. You can't even install the 3.0.1 RW drivers anymore without doing some serious cleaning.

The best/easiest way to deal with this is to simply re-download and re-install the 3.0.2 drivers. This has that particular file it's looking for. Any system that has crossed the 3.0.2 version line is stuck there unless you do manual registry and inf/file hacking to lose all traces. Some others have found the latest x10 drivers (3rd party) can also clear this error.

Unfortunately, the ATI uninstaller and Driver Cleaner Pro will not 'clean' a system properly that has ever had the 3.0.2 drivers installed upon it. The top level ATI Uninstaller also misses these pieces as well. You're left to sticking with 3.0.2, or manually scrubbing your system.
Thanks for the info
There are newer drivers out than the ones i installed off my cd. Any idea how to go about "safely" upgrading without the issues i had above?? It seems for me the only drivers that work are the ones from the cd. I might just leave things as they are as i really dont want to go through it all again.