Remote Wonder II- Poor Quality, Fluke or issue?


New member
Greetings folks,

I recently purchased an AIW X800 XT, which came with the RW-II.

Initial install, drivers, everything worked like a charm. Desktop mouse pointer, EasyLook/buttons... the remote worked like a champ.

Well, I rebooted today.. and upon hitting buttons on the remote- NOTHING works. The icon is in the systray, remote buttons light up when pressed, etc.etc.. but nothing happens. Even using the thumb-pad on the remote no longer moves the mouse.

Looking over at the little round receiver- I noticed when I press buttons on the remote, the little clouded red LED no longer "blinks" as I press things. I recall in the past, when using the remote- the LED on that unit would blink to indicate it was receiving signal. All devices in the Device Manager are there, working and indicate no problem. It's as if the receiver is just no longer receiving from the remote!

I also noticed when I reboot, the red light on the receiver blinks 3 times. After that, it's on solid no matter what I do with the remote. This leads me to believe that the receiver (.. or remote) just isn't working. Both have been totally pampered and rarely gotten ANY use as it's a new card, only a couple weeks old, and have only used the remote like 4 times total.

Is there some driver/configuration that would cause the receiver to just stop receiving or is it a bad unit? Are these things really this cheap/fragile to just burn-out sitting idle over a week or two? Anyone else have a good experience with the RW-II? Any insights would be greatly appreciated!
If you haven't had any luck yet you'll notice I believe four aux button in the upper left part of the controller. when any of those aux buttons are pressed the remaining buttons on the remote take on seperate functions that are linked to that aux button(kind of like a universal remote). you should also notice a button with an ATI logo located above the thumb directional pad. above the ati button is the PC button which is the default control button for MMC easylook. As long as the PC button lights up when all other buttons are pressed then you should be ok. If the PC button lights up, for example when you press the TV button, and nothing happens then there could be something wrong. You also want to make sure that the remote icon is loaded on startup or in the systray. Hope this helps.
Thanks verbals..

Yuppers, the PC button lights-up when I press buttons.. I also can hit the TV button first and still nada happens whatever I push.

I also just yanked the receiver, uninstalled the rw-3.0.x software.. safe-mode/driver cleaner, reboot, re-install.. then plugged it back in. Still have the icon and all the devices in the device manager- but nothing happens.

As the receiver still isn't blinking the red light when I hit buttons, my only guess is the receiver is bad. Kinda sucks for a brand new unit :(
I suppose it's possible that you accidentally changed your remote control's unique id...try the below to change and test the id:

By the way, if you don't have the Options Tab with the Set Remote ID button (as described below), then it is most likely a driver issue and not related to the hardware. Although if you are not getting any response at all from the LED on the receiver, then I would tend to think it is a hardware issue.

From ATI's online support knowledgebase:

To change the unit code ID for the REMOTE WONDER II in Windows:

1. Right click on the REMOTE WONDER II system tray icon.
2. Select PROPERTIES from the pop-up menu.
3. Select the OPTIONS tab and then click the "Set Remote ID" button. A "Remote Control ID" window should appear.
4. Press and hold the PC button on your REMOTE WONDER II. The button will begin to flash rapidly. Continue to hold the button until the LED begins to flash slowly. The number of slow flashes is the current remote ID.
5. Use the numeric keys on the remote to enter a new ID. Valid ID numbers are 1-16. After the new ID has been entered press the PC button.
6. The PC button will begin to flash. The number of flashes is equal to your new ID.
7. Select a new ID from the list of remote IDs, changing the selection from "Accept commands from all remotes" to a value between 1 and 16.
8. The REMOTE WONDER II software will now respond only to REMOTE WONDER IIs with the new ID. Select test to test the new settings using test button on the page.

By the way, I do not like my Remote Wonder II. Strangely enough, it seems to be directional (like an IR remote where you have to point at the receiver), and doesn't have the responsiveness of the original Remote Wonder. I can have the remote in the same location less than 10 ft away from the receiver, and in order to get it to work, sometimes I have to orient it horizontally, sometimes vertically, and sometimes I have to orient it at a 45 degree angle to work properly. Very annoying! I thought this was an RF remote???

I guess it's possible that I have too much RF interference, but I don't see why this should be an issue - especially if the old Remote Wonder worked like a charm in the same location!
Thanks for the tip schlatt. I went through ID's 1, 5, 8 and 9 in the RW systray program (as well as carefully counting blinks on the remote after setting) none of them get any response from the base unit. I also tried "Accept commands from all remotes" and still no dice. It really looks like the base/receiver just isn't receiving anymore.

I just ordered up a brand new RW-II on NewEgg since they have it for $39. This seems a much saner deal than having to struggle with ATI's RMA process, shipping costs and probably 2-5 weeks waiting for a new one. It'll be on my doorstep in a couple days.

I'm REALLY bummed with ATI as of late- it looks like the lower QC level we've been seeing in drivers/other products is now hitting their latest hardware. I should also mention my roomie also bought a AIW card about the same time I did, and his didn't even come with the receiver unit! (just the remote). We had to return the whole card/retail box in order to get one with the receiver. His is a RW-I, so I can't really test my II out with his parts.. :(
I also have a Remote Wonder II and the receiver for it stopped working a couple of days ago (coincidence? :bleh: ). For mine, it doesn't even light up at all anymore. I don't really want to buy a different type of one as a replacement, because I like those AUX buttons.
NewEgg has the Remote Wonder II, brand new for $39 + $3 air saver shipping. From the pics, it appears to be the exact same one that shipped with my AIW X800. They also have the RW-I for $29.. same as my roomies older AIW card.

RW-II @ NewEgg:

It may seem like a waste of $$, but this is a much better solution to me than wasting countless hours going through ATI's support, then rma, then shipping, waiting, etc.etc.
I got my new unit from NewEgg delivered today. Plugged in the replacement base-unit and it works like a champ.

Also, the new one when you move it around, it doesn't have a the feel like something springy is inside. I have a feeling the one that was enclosed with the card (full retail box ATI AIW X800 XT) was a blem/refurb or some other lower quality unit as this one is much tighter feeling inside.

Crossing my fingers that this one lasts for more than a few weeks!
Springy? Do you mean something metal inside the receiver that seemed loose? Mine is like that... I got mine from NewEgg 4.5 months ago.
Kinda loose... I wouldn't say totally loose as in broken loose- it doesnt rattle around inside like it's rolling around freely... it's more like there is some sort of spring inside that bounces around when the unit is lightly jostled.

The new unit doesn't do this at all. It's rock-solid inside and has no feeling of anything loose or springy inside at all.

As the old unit is toast, I may open it up if I can find the screws (might be glued ugh). It's garbage bound anyways, might as well see if there is something inside that has come loose (maybe the spring is some sort of coil antenna that just has poor contact? It would seem like that..)
Yep, that sounds just like mine.

I hadn't really been using it for a whole lot recently, but I had been using it to test a plug-in I was writing. Now that the receiver isn't working, I can't test it, however. I can probably still test the configuration part, though. That's the most important part of the plug-in I'm writing.

I don't have time to give the exact details right now (that would require LOTS of typing...), but I will say that it will be a great general-purpose plug-in that most likely everyone with a Remote Wonder control will want to use when it is finished. :)
Last edited:
Awesome stuff. I hope I can try out your plug-in once it's ready. :)

If I can get this old one apart, I'll see if this 'springy' action is related to the failure. I'm betting there is some typical coil-spring antenna that has a couple beads of epoxy holding it down.. and the epoxy for one reason or another has given way, and somewhere in the spring coil where it can now flex, it's broken.

It makes sense. This would at least yield some sort of easy repair for others encountering this. It looks like the sucker is glued together though as I cant find any screws. heh.