Rage fury MAXX help/bios?


New member
I have an older rage fury maxx, that when I was overclocking my computer one time, the video just went wakko. It'll turn on, and you can tell the card is still getting the signal by the screen flashes when it starts loading windows(by sound of HD), but all you can see are random colored characters on screen. I don't know what happened.
But recently I found out about "radedit", and that u can reload a different or retrieve the bios. I got it off of my maxx, but I couldn't load it with a radeons(different version). So does anyone have a rage fury maxx, or at least a copy of the bios?


Considering all the trouble you, and whomever might help you, might have to go through, why not just get another card? Those Maxx cards cannot be going for much these days, $15-20 on eBay, if you are patient. For that matter, some of the early Radeons are really hitting bottom too! I know cash flow almost always dictates things, but you could find a deal pretty easily.

But trying to fix it is fun too! (sometimes) I add this, because I have a Maxx card. It sits in a drawer these days, but I might be able to pull a bios from it. I have so many projects, that getting to it might be the only drawback - but who knows. Thought I'd post a reply, just to see if you were following up on this, or just posting out of frustration - biosylum
If there's still a chance of getting the ROM images for a MAXX, I'd be happy to have them. See, I got one of those that someone mistakenly tried to convert to use on a Mac. The end result, the card doesn't work for PC or Mac, and ATIFlash reports the flash as "Parallel" (and refuses to read the contents), so I can't even see what's on the card. Nice, huh.

Sure, it's an old card, and I have faster cards available. I'd just like to fix this up so it works as a "just in case" thing.

Edit: Was using too new of an ATIFlash. I grabbed v1.3 and now the flash type is seen correctly. Just need a valid 128KB image for the Rage Fury Maxx now.
Last edited:
Rage Fury Maxx ROM flashing

Rage Fury Maxx ROM flashing

While I still need the correct contents of the 2x AT49F511's, I discovered that the FLASHROM.EXE (only tested with v2.40) util is needed to flash the 2nd adapter. Every ATIFLASH.EXE version that I tried was only working for adapter 0, but was causing a hard lockup when trying to write a test image to adapter 1.

So, what I'm looking for should be the 64KB images of adapters 0 and 1 (BIOS P/Ns 113-67303-10x & 113-67305-10x, I believe).