Official ATI MCE configuration for RW in 3.03 drivers


New member
OK, a little heads up for select T550P users. More specifically, ATI TV Wonder Elite + MCE users or any Remote Wonder + MCE users.

The latest Remote Wonder drivers AKA 3.03 has something that many of the above have been waiting for in earnest.

Namely, official ATI support (button assignment profiles) for MCE!!!!

That’s right lads and lasses, there is no more need to use quirky key mapping utilities or plug-ins that only half work. Simply select the “Media Center” tab in the RW utility and enable the functionality. Once done, press the red ATI logo button which is analogous to the infamous ”Green Button” on official MCE Remotes to start MCE. Pressing the red button in MCE will take you to the home screen and most other buttons are also logically defined. For example, pressing the TV button (TV number one on the RWP) will take you to “Live TV” and pressing DVD will logically take you to the DVD menu. Again, the “Info” and “Guide” buttons are all reasonable assigned.

This is really great and has been a long time coming! I was on the lookout for something like this since the AIW X1800XL press release mentioned that there were enhancements for the RW.

Anyway, good job ATI. This was something done right albeit somewhat late. There is no standby button association but there is probably a way to configure one of the programmable buttons to such a task.

Now all we need is a hardware mechanism to act as an “IR Blaster” and the RW line will be just as functional as official MCE remotes in MCE. Perhaps ATI will enable the ports on the Remote Wonder II,….!?! In anycase something is needed to control STB and as it stands ATI has no solution for this.
Ya it is great, and works perfectly with MCE05 but it CRASHES all the time when using remote wonder plus that came with my HDTV wonder. I wish there was a fix for this. The only remote wonder driver that works for me is the one that shipped on the cd for the HDTV wonder, any other will crash all the time for no dam reason.
I have an original Remote Wonder, Remote Wonder II and two Remote Wonder Plus Remotes.

Thus far I have tested the 3.03 RW drivers on two different MCE 2K5 systems. One system had a Remote Wonder Plus and the other had a Remote Wonder II. In these two independent test beds I haven’t had so much as one problem with respect to these drivers.

If you are having a problems, my guess is that I am extremely lucky or you have some unique problem on your end.
No, enter is not alone in having ATIRW.EXE crash all the time. Not only that, it seems to be randomly opening Media Center and going to My Videos.

I'm having the same problem, and the only RW software that has ever been stable with my RW+ is the special version that came on the HDTV Wonder CD.

Enter, are you running anything that might be conflicting? Here's what I have running, aside from Media Center:

Motherboard Monitor
MS Antispyware
Last edited:
Hey Arc,
I don't have anything running with it at all, and it still does it. I think I might have fixed it though after spending the last 4 hours trying to find a work around but not sure enough to say I have a complete fix yet. If I don't get some error from ATIRW then I will post the fix for ya.
I really like the new remote wonder software that supports the MCE05 it works great but I have no tolerance for stupid errors from Ati's software. The only reason I'm wasting my time with fixing the new driver is JUST for the support of MCE05 if that wasn't the case I just flat out wouldn't care kinda like the last remote wonder driver that ATI released it gave me the same problems so it got **** canned......didn't you have the same issues also ARC???
Now I’m wondering what is different about my systems with respect to yours.

Do you two have MMC installed?

I don’t have any version of MMC installed on my MCE 2K5 systems. Just ATI drivers for the given hardware.

BTW, i have a third MCE system that i can test my second RWP on.
I don't have MMC installed either, I only have the drivers needed for the TV tuner, video card and remote nothing more thats ATI related. I'm not sure why yours is working and many others are not, I have all the updates for MCE05 installed and of coarse SP2. Ya try your other MCE system and see what happens, turn the channels alot and use the remote as much as possible if its gonna happen you should see a problem within a hour or so max. I only have the HDTV wonder installed and I am using both analog and HD for MCE, actually have MCE seeing both and using both which was a challenge all in its self to make happen. Thats one thing that may be different from our systems.

I believe I have fixed the problem with ATIRW crashing, I haven't had a crash or error in 2-3 hours now which is amazing since I would get one within 30 minutes before and sometimes within 10 minutes. So far ATIRW has been completely stable and working as it should. <-----crosses fingers,lol.
Last edited:
What's really bizarre is that I just watched MCE open and jump into Live TV, with the batteries out of the remote

Yesterday, My Videos kept opening, and MCE started rewinding while I was watching TV, and the RW was untouched in the other room. If I unplug the receiver, the crashes and random actions seem to stop.

And yes, I'm sure no one else around here has a RW. Not that it matters, the RW+ barely has the range to work 10' away from the other room. Right now I have a task running that kills and restarts ATIRW.EXE every hour, which works around the crashes, but that won't do a thing about the random activity problem.
Last edited:
I'll post my fix for this when I get home tonight, don't have time right now. But after fixing it I have not had the ATIRW crash at all and its been 12 hours, so thats good news anyways. Arc sounds like you might have some other activity going on that might be on the same freq as the remote or something that has a signal the same as the remote, Try giving the remote a different ID through the software.
Enter, that's exactly what I did. I'd still like to know what you did to stop the ATIRW crashes.

By default the RW software listens to any remote, and I think that might be the source of my problem. It could also be the remote itself spits out RF garbage on occasion, because if I don't get a crash, I get phantom button presses causing MCE to start up.

The RW+ defaults to ID 16 and will go back to 16 whenever the batteries are removed. I changed my RW+ to ID 1 and set the software to only listen to ID 1.

So far no more crashes or freaky stuff.
OK, I finally setup the third Remote Wonder device (one Remote wonder II and two Remote Wonder Plus so far).

Since they are all in close proximity I had to change the ID on the two RWP based MCE systems. I haven’t experienced any odd control issues like unexpected application launches. However, the third system did experience a crash within minutes (crash of the ATI applet). System three actually experienced a number of crashes (three or so) in a short time span and I quickly came to the conclusion that it only occurred when the mouse function of the remote was used.

No mousey, no crashy!!!

So it looks like I found a work around (of sorts) that works for me.

I’m actually used to using official MCE remotes rather then the RW so using the mouse on the RW isn’t something I’m used to doing inside MCE.
OK here's my fix for this problem, its not perfect by any means I guess I'm just doing the same thing ATI does and fix one thing to break another,lol. What doesn't work is the setting for the RW+ BUT if you follow the directions it shouldn't bother you at all not having it, you'll just set everything up first.

OK here we go... First off install the newest RW+ software and drivers (3.03) and follow the directions like normal. Now once installed set up everything you want from the icon in the tray ie: MCE support, mouse speed, remote ID and so on<if you don't do this you won't be able to again.
Now go to C: Program files and copy the ATI Mulimedia folder and paste it somewhere (I used another drive or partition) open regedit and go to HKEY_CURRENT_USER\SOFTWARE\ATI Technology and right click on the ATI Technologies and choose export save it to where ever as long as you remember it.
Now uninstall the RW+ from the add and remove in the control panel don't reboot, once thats done now install the RW+ software from the shipping CD (the ones that are stable)but DO NOT REBOOT go back to program files and open the ATI Multimedia folder and delete the ATIRW.exe its the one with the remote icon you will most likely have to kill the ATIRW process from the task manager to be able to delete it.
Now go to the ATI Multimedia folder that you saved(3.03) and copy the ATIRW.exe and replace the one you just trashed so you should now have all the drivers and x10 drivers from the CD but the newest ATIRW.exe in that folder (alittle cross breeding) now find the registry entry that you saved and double click it once thats done REBOOT and enjoy a RW+ that works with MCE05 but doesn't crash all the time.

Now this has worked great for me and hopefully should work for everyone else.
Agustus said:
OK, I finally setup the third Remote Wonder device (one Remote wonder II and two Remote Wonder Plus so far).

Since they are all in close proximity I had to change the ID on the two RWP based MCE systems. I haven’t experienced any odd control issues like unexpected application launches. However, the third system did experience a crash within minutes (crash of the ATI applet). System three actually experienced a number of crashes (three or so) in a short time span and I quickly came to the conclusion that it only occurred when the mouse function of the remote was used.

No mousey, no crashy!!!

So it looks like I found a work around (of sorts) that works for me.

I’m actually used to using official MCE remotes rather then the RW so using the mouse on the RW isn’t something I’m used to doing inside MCE.

I don't have the same issue with the mouse causing the crashes, I don't have to do anything and it will crash, but not anymore.

Thanks for testing with the other systems though, way cool of you.
enter said:
Thanks for testing with the other systems though, way cool of you.

No problem man, I would have done it anyway. I actually have one more RW I need to install :D

Back to the subject:

After using the new 3.03 drivers in MCE for a while I have gotten a better feel for how well ATI did their job in this respect. They did a good job but some oddities have indeed cropped up.

For example:

When the “play” button on an official MCE remote is pressed in “Live TV” it will display the given time and place within the given show (DVD or whatever). Fortunately, the RW does this the with 3.03 drivers. This is good because it’s a useful feature and some key mapping utilities don’t get this right, rather pausing “Live TV” instead of yielding the desired info.

When the “OK” button on an official MCE remote is pressed in “Live TV”, the channel will “go back” to the previously viewed channel from the currently viewed channel. Pressing the “OK” button essentially toggles between two TV channels. Unfortunately, this rather useful feature does not work with the RW with 3.03 drivers. Too bad because it’s a feature I use and like a lot.

When performing a search in “My TV” using an official MCE remote, one can easily use the number pad to input “letters” to spell out the words in said search. Again, this is a very useful function. Sadly, this does not work with the RW line with 3.03 drivers. Instead the RW will input actual numbers when the number pad is used,….most unfortunate and utterly useless.

The “clear” button didn’t seem to work as expected because it wouldn’t clear the numbers entered into the search field by the number pad when letters were expected. However it does work in other respects.

There is also no key assigned to go into standby mode. On official MCE remotes (the single power button non-learning type) pressing the power button will send the MCE PC into standby mode but the power button on the RW will simple shutdown the MCE DVR application.

There are no buttons assigned to fast-forward or rewind so if you use this function a lot you must assign two programmable keys to do so.

One Key not found on an official MCE but can be fond on the RW with 3.03 drivers is the “Cycle Aspect Ratio” button. This button comes in handy for those who have a HDTV tuner and want to quickly get rid of the ubiquitous black bars at the top and bottom or sides. With an official MCE remote users would have to press the info button and select zoom. Then they would need to cycle through the zoom modes. This is one thing that is actually easier with the RW (works with DVDs too).

The left and right mouse buttons have been reassigned as “OK” and “Goes to Previous Page AKA Back”. So although the mouse pad works on the RW in MCE there is no way to actually select anything once pointed to with the pointer. There’s also no obvious way to reassign these two buttons but again any one of the remaining programmable keys can be used for this.

There are also a few duplicate keys. For example, the left mouse button serves the same purpose as the “OK” button in the center of the directional pad keys.

In the 3.03 utility, the Media Center tab gives you three choices: Enable when Media Center is in focus (default), Enable always (my preference), and Disabled. If you go with the default setting you cannot launch MCE using the ATI red logo button (for RWII and RWP) however once MCE has started and is in focus the ATI red logo button will take you to the home screen. Using the “Enable always” option will allow the user to launch MCE with the ATI Red logo button however the left and right button assignment would make the mouse function useless all the time.

There are also stability issues on one of the three systems I have installed the 3.03 driver on.

So yes, ATI did a good job here but there is room for improvement. Hopefully we will see an update soon.


Two other things to add:

The forward and back buttons on the RW don’t exactly work as expected either. Sure enough, they do go forward and back respectively. However, when they are pressed and held they should move to the beginning of a file or the end of a file (or the buffer in the case of “Live TV”) and unfortunately they do not do this. Again, this is a vary useful function of official MCE remotes and its just not supported in the 3.03 RW drivers.

Press the guide button on an official MCE remote and you are taken to the guide. Press the guide button again and you are given special guide sort features at the bottom of the screen such as “all on now”, “movies”, “kids”, “sports”, “news” and “special”. Pressing the guide button a third time results in the removal of this special sort subcategory bisecting the screen. Pressing the guide button on the RW once will pull up the guide. Pressing it again will pull up the sort subcategory but pressing it a third time does not remove it with the RW.
Last edited:
I built a nice setup with a RW1 (1.4 drivers) and Girder to control the music player Foobar 2000 with keyboard shortcuts.

It works like a charm and, thank to Girder, I've even being able to create a "multipage shift" button that lets me assign as many different function to any key I like.

I also automatically show a OSD telling me which keys page I'm in.

Now, I needed to add another remote device so I bought a RW2 through Ebay.

I have updated the driver to the 3.03 because the 1.4 seemed not to see the new receiver (when I plugged it in I got the "new hardware detected, please install its drivers" window).

Everything seems to work but the odd thing is that each button of the RW1 sends its channel number too but the RW2 doesn't.

As I'm planning to add another RW2 in the future and use it with different functions then the existing one, it seems that the same button on two remotes will forcefully trigger the same Girder function due the lack of the channel info in the string sent to Girder.

The RW1 worked also as a generic X10 device but the RW2 doesn't.

Do you think it's a driver problem?
Do you think that reverting to some older driver I could get the RW2 work as an X10 too?
Do you know if the RW2 (or better, the 3.0x driver) will start sending channel info only when I will install the second RW2?
Would anybody owing two RW2s mind doing a test with Girder 3.3 and let me know what they get, please?
I found the same problem others have had. Installed the driver, and all was well.. until a few hours later when the .EXE crashed. It's been running now for around 2 days, and has crashed 5 times.

I'm thinking about trying out KeyMaster to replace this exe ( )

Frustrating that ATI makes good hardware and crappy software.

:up: On the RW Keymaster / Keyfactory combo.

On an RW1 with 3.03 I get unintentional double key executions, odd crashes, lack of configuration, etc... All cured with the third party apps.
Remote Wonder and 3.03

Remote Wonder and 3.03

Have spent days (and days) trying to get stability with ATI Remote Wonder (I) – ATIRW.exe crashing. Have tried 3.03, 3.02 and 1.4, but to get any form of stability with 3.03, I found using 2.3 Remote Receiver driver helped but required X10 driver instal – though I still expect a crash and am always waiting for the Remote control to stop working any time soon. Here’s what I need to do (though I ask myself how much I value my time and whether I should just fork out for a proper MCE2005 remote control ;)

If you don’t have any other ATI or X10 product/software installed other than a Remote Wonder remote control, then complete all the following, otherwise as best you can:
You may want to export HKCU\software\ATI Technology to keep any preferences already setup in version 3.03.
Clean out all X10 drivers and ATI Remote Wonder entries using add/remove in control panel first and then manualy delete the possible five directories:- C:\ATI, C:\Program Files\ATI Multimedia, c:\Programe Files\X10, c:\Program Files\Common Files\X10 and c:\Program Files\Common Files\ATI.
Remove X10*.sys files from C:\WINDOWS\system32\drivers. Also remove registry enteries found in hklm and hkcu under services and software (looking out for xuif, x10 and ati).
Disconnect ATI receiver from USB port and re-boot.
Install RW 3.03 software (downloaded from re-boot when asked once complete. (Don't reconnect remote receiver yet!)
The next step did not delete atirw.exe (ver 3.3) from C:\Program Files\ATI Multimedia\RemCtrl, but you may want to copy to another location just in case, as you may need to copy it back later.
Remove 3.03 using M$ add/remove in control panel - this does not appear to delete the software from the directories!
Do NOT delete any of the above mentioned directories!
Still do NOT re-boot.
Instal RW 2.3 (downloaded from Check version of ATIRW.exe in C:\Program Files\ATI Multimedia\RemCtrl and copy over version 3.3 if needed (I found instal of 2.3 didn't overwrite the later version).
Import HKCU\software\ATI Technology if required from earlier.
Install x10 drivers (X10drivers.exe version from or
Reboot now!
Re-connect remote receiver to USB port.
Check that x10nets.exe and ATIRW.exe are running in Task Manager and ATIRW icon (version 3.3!) is in system tray.
Using Device Manger select the Remote Wonder receiver's driver, there should be three: ATI latest, X10 (same version as ATI's latest) and ATI’s early version. Select ATI's early version: ATI Wireless Remote Receiver V2.36 (
Because I noted some peculiarities with the plug-in's (not taking deleting a plug-in first time, requiring a second delete) and am sure ATIRW.exe still crashed when using ATI RW gui whilst switching to the plug-in tab, so I also did the following (note: this will limit the plug-ins somewhat!):
Using the RW gui - plug-ins - disable all plug-ins and delete all - click OK. Re-launch gui to check if there are no plug-ins showing, if there are repeat until re-launching gui consistently shows no plug-ins!
Now re-name all plug-in's in C:\Program Files\ATI Multimedia\RemCtrl\plugins to what ever the file name is but change .dll to .old
That's about it - phew...
Note: Some funny's with RW 3.3: mouse buttons don't work the way you might be used to - though is probably correct for a remote on a 10' gui! On mouse movement in MCE2005, a 'non-remote' display appears - which has some handy selections not least minimise in the top right hand corner of screen - but if you use the 'mouse' button on remote to say minimise window you may find something else happen that you're not expecting! Instead press the mouse button twice in quick succession and this works!
I guess one should get used to using the remote control as a remote control and not a mouse… :(

The morlal - maybe spend the time more wisely using 3rd party app such as RW Keymaster / Keyfactory or X10Commander :confused:

I like ATi software - you can frig around in reg without bsod's or other funnys! Apart from that though....

Didn't have to wait too long for an atirw.exe CRASH - next day!
So decided to look at using x10Commander.exe and it has a useful tool - logging codes received by Remote Wonder Receiver. Got me thinking and using this I determined the atirw.exe crashing is directly after receiving a MTTV keyword from an unknown address (j1)!
So after setting the remotes ID (to 16) it no longer crashes when an MTTV is received from j1 - fingers crossed, it maybe fixed (but don't hold your breath!)
Last edited: