More insight towards RW-II/3.0.X and no systray icon and inoperable remote..


New member

I installed something recently that made my RW stop functioning, and could not get it functioning properly regardless of what I did. It's the same thing expressed here so many times and I've isolated it to something very strange/wierd.

Newer Jungo WinDriver versions will render the RW/systray application USELESS. If you hit Windows Update and look in the hardware, you'll see an entry for WinDriver update. DON'T INSTALL IT. Also, check any new USB/PCI devices to make SURE they do not bundle their drivers with ANY version of WinDriver.

Installing a newer/incompatible version of this will render the RW devices still functioning in the device manager, a red-light on the tranceiver and all.. but the systray icon will not load and the device will NOT work. You'll have to roll back to the bundled WinDriver version, which wont un-update once the version on the PC has been upgraded.

Ugh.. This has been a source of grief without knowing it in the past for me. Now I have a simple thing to check/work on. Any insights or people knowing specific revert versions to help others, I'd love to hear it. :)

This may be the insight why the X10 older driver works for some people. Does it bundle/force an older WinDriver install? Strange stuff..
Hey there Sharkfood,

I installed the update from MS that you're talking of and I believe I found the instructions here on how to fix it. I must say though that the RWII is an EXTREME pain in the ass and even NOW it's not working for me.

Course I still haven't even gotten the MMC TV to work either so it's really kind of moot :confused:

Hope you get yours going

Thanks Dan,

I got mine to work by rolling back.. but spent about 2 hours trying to figure out a better solution in case I do get something that updates the WinDriver version.

I also agree this thing is a royal pain in the keister. I wouldn't think a NEWER version of something it needs would be so incompatible.
RW/2/+, x10, and WinDriver

RW/2/+, x10, and WinDriver

Oh, the joys of WinDriver.

Back when Win2k first came out, I wanted to use it to write a win2k driver for an unsupported USB device (Toshiba InTouch Module - ever seen one? Puts most modern PC remotes to shame) and even with my limited programming skills, I could tell WinDriver was a POS.

This is and isn't ATI's fault. Yes, they coded the RW app to recognize an old, renamed version of the WinDriver core (ATIRWVD.SYS, which gets wiped out when WU updates WinDriver). They should have upgraded to the standard WinDriver 6 long ago. On the other hand, Jungo/Powerware would charge ATI out the wazoo for a new license, and the RW2 is soon to be EOL. ATI has already gone back to x10 for the RW+ and is phasing the RW2 out as they never made much use of the IR-blasters or AUX modes of the remote.

Did you know the RW2 receiver also has an IR sensor in it? It can learn remote codes. Those AUX buttons on the RW2 were supposed to let you control other devices thru IR-blasters from anywhere in your house.

Never happened, never will, and all this untapped potential doesn't help to explain why the RW+ is more expensive than the RW2! :nuts:

I have to admit, I like the RW+ :p Oddly enough, my HDTV Wonder came with one! It has great range and a usable thumb-mouse. I don't use MMC, so I have the RW+ mapped to always control iTunes.

By the way, installing the RW software installs the WinDriver/ATIRWVD.SYS file and the "ATI Remote Wonder" device, which is actually the WD service. Plugging in the RW2 and pointing it to the drivers installs two other devices, which are the actual USB drivers that talk to the WD service. If that WD service gets tampered with, you have to uninstall the RW software, reboot, reinstall it, and reboot again. The RW2 doesn't use x10 at all, which is why no 3rd-party apps know how to listen to it.

The x10 based remotes, by comparison, have one USB driver (x10uif2.sys) and the x10net.dll, which you can regsvr32 to use the remote with any x10 remote app. You don't even need to install the ATI software.
Last edited:
hey guys i just recently installed remote wonder II and i have that problem.

How do you rollback WinDriver? or fix the problem
Please post instructions

Please post instructions

Same thing just happened to me after I let Windows install some updates. At first I thought the X10 update caused my problems....then I ran into these threads talking about the WinDriver update which took place at the same time the X10 got loaded.

Tried reinstalling the Remote Wonder software, even uninstalling my USB HW/drivers in Device Manager with no such luck. I hear there is a way to uninstall the updated WinDriver and somehow revert back to the old version that would let my Remote Wonder work....Please, who ever has this knowledge....please post the instructions....I'm running WinXP SP2 and use my Remote to watch cable TV in my room as well as control WinAmp/WMPlayer....w/o the remote the whole ATI card is useless to me....Crap!!!

Some other guy said he reloaded the OS....that's bunk if I need to go that route.....Please help....I opened a ticket with ATI, but I am not expecting them to help by the sound of things....I have the basic Remote Wonder and not the Plus or II version.

Thanks in advance to the Hero!!!

Pissed Off!:mad:
Solved my RemoteWonder Problem

Solved my RemoteWonder Problem

After many calls to ATI CS, they gave me good ideas in the beginning but nothing solved the issue. They told me to reinstall my Chipset-USB drivers with no luck, they told me to reinstall the x10 drivers from x10's website with no luck. At the end, 2 reps told me I had tried everything and that I was basically SOL'd.

Little do they know that the issue is much simpler than any of their suggestions and they are basically clueless of what is going on here.

I was able to reproduce the problem on a different PC clone and the culprit was the X10 driver update from Windows update! Please do not update your hardware from SATAN :evil:. They will screw you up and the manufacturer (ATI) has no clue as to how to fix it!!!

If you do update your driver and renders your Remote useless. You can go back into the driver location on your PC (Assuming you are in XP-Pro like me), this will reside in C:\Windows\system32\Drivers. Look for the only 2 files that start with filename as X10xxxx.sys. Look at the dates of the files. The oldest one is the driver that worked, while the newer one is the crappy driver - throw it in the trash!

Now in my case, before I updated the X10 driver, under USB controllers in Device MGR, I had an entry named "ATI Wireless Remote Reciever V2.36"; after the update, that name changed to "ATI Remote Wonder". From here I right-clicked on "ATI Remote Wonder", clicked on Properties, under the Driver tab, I chose "Update Driver".....Go through the next screens where you tell it where to look for that Old X10 driver....thats it!

I noticed that once or twice it crashed my PC...but eventually it took and all was well...Remember i had 2 PCs with the problem....maybe thats why that little error tid-bit sounds excessive...My Remote Wonder Icon reappeared in System Tray and my Remote Wonder was back to its own self!!!

Hope this helps someone else!!! :D
How I fixed mine...

How I fixed mine...

My spec:
ATI AIW 9600 Pro with Remote Wonder II. I did update the WinDriver thing from Windows/Microsoft Update, which renders my remote wonder useless (no systray icon, etc.)

Here is what I did to fix this:

1. Uninstall ATI Remote Wonder from "Add or Remobe Applications" in control panel.
2. Goto Device Manager and uninstall (rigth-click, uninstall) the two ATI Remote devices under USB
3. Shutdown computer. Then unplug your remote wonder receiver.
4. Boot into Windows and install the Remote Wonder 3.2 app.
5. Don't restart. Shutdown instead. Then plug in your remote wonder receiver.
6. Boot into Windows and it should work now.

Hope this helps somebody,

ati rw fixed

ati rw fixed

FYI: I fixed my Remote Wonder I. After I installed the remote wonder 3.2 drivers from ati, my machine would boot and have no system tray icon for the remote but atirw.exe would be running. My remote was unresponsive, and the remote wonder control panel wouldn't even detect it. After goggle'ing for help, I came accross something that helped me fix it. It seems as though ati doesn't know how to create a proper installer *shocked*. What you need to do to correct its mistakes is the following:

- Click Start menu then Run
- Type regedit, hit enter
- Hit Ctrl+F (find)
- Type in "RemCtrl" without quotes, uncheck all boxes except for "Data", hit find
- Keep hitting F3 (find next occurrence) until you come accross something like:

c:\windows\system32\rundll32.exe C:\Program Files\ATI Multimedia\RemCtrl\(some file name).dll,EntryPoint

- Place the second target in quotes:

c:\windows\system32\rundll32.exe C:\Program Files\ATI Multimedia\RemCtrl\(some file name).dll,EntryPoint


c:\windows\system32\rundll32.exe "C:\Program Files\ATI Multimedia\RemCtrl\(some file name).dll",EntryPoint

- You will need to repeat this several times throughout the registry
- Also, towards the end of the registry, I started noticing values like:

C?\Program Files\ATI Multimedia\(some file name)

So correct all "?" with ":"

C:\Program Files\ATI Multimedia\(some file name)

- Reboot, and everything should be perfect

FYI: The help I found from google'ing was this thread