Missing systray Icon - Best Solution Yet!!!

Bilar Crais

New member

I have had my RW for many years now. I probably reinstall my OS about 15-20 times a year (it's a hobby). I've come to the conclusion that if the RW drivers are not installed almost immediately after a clean Windows install, the systray icon almost certainly will not appear as it should later. Inevitably, if I wait until such time as the computer is nearly or completely setup, the systray icon will be a no show. However, if I follow the tried and true method of leaving the receiver unplugged during the entire OS install, immediately followed up by RW drivers, reboot, and plugin the receiver, the systray icon will be there.

A few days ago I reinstalled my OS. I remembered to pull the receiver plug before hand, but I forgot to install the drivers on the fresh OS. So, no icon.
None of the methods in this forum worked except the x10 driver install, which I eventually resorted to. That gave me the icon back, but also gave me an unstable remote control. If I push certain buttons on the remote after using that repair method, the RW application will crash.

Did you ever notice that the ATI RW driver package installs a Windows service that never runs, and points to an executable that is MISSING?!? Well tonight, I did a search of my computer for that missing file, "X10nets.exe". The X10 install package puts one on the hard drive, so I copied it and kept it for safe keeping. Then I uninstalled the X10 drivers, followed by uninstalling the ATI RW drivers. I wiped the registry and hard drive of X10 and RW entries, unplugged the receiver, then started the RW 3.04 driver install. BEFORE I REBOOTED as prompted, I copied the X10nets.exe file to C:\Program Files\ATI Multimedia\RemCtrl\. Rebooted, then plugged in the receiver. Voila! Systray applet! Working remote. In addition, this method does not seem to have the instability of the "X10 driver install method". In fact, if I push the same sequence of buttons that unfailingly crashed the ATIRW executable before, it doesn't crash.:) I suppose your mileage may vary, but I'm grinning ear to ear.

Below is a link to a small install package that I put together, that will simply extract the file "x10nets.dll" to your RW driver install. I have it defaulted to extract to C:\program files\ati multimedia\remctrl, but there is an option to change the path if you need to. I suggest you reboot before using your remote wonder, as the "X10 Device Network Service" will need to start.

Download Remote Wonder fix (94kb)
Last edited: