How to speed boot-up time?


New member
My PIII 1 GHz PC can take up to 2 minutes to boot up. I did all the Windows tweaks that were posted on this site, but I see little difference. Are there any other tweaks I can make? Thanks.
Uninstall your ethernet card and try again.Is it ISA or PCI?I have an ISA ethernet card and when I install it,my comp needs more than 2 minutes to boot up.But I get the same problem as yours with 2k,and I haven't figured out what is the problem.
Aha, I figured out it's my ethernet card. I have a Davicom 10/100 PCI and right after I put it in and installed drivers, Windows slowed down the boot-up time. Does anyone know the cause of this?
I'm not sure ,in my case it was an IRQ problem.The ethernet card was sharing an IRQ with another device(I don't remember witch one).I changed the IRQ and the boot-up speed improved.See if there is an IRQ sharing or maybe a confict with another device.Check the resources from the device manager or use a program like windows utilities (if you are still using Win98se):)
OOOOPS!!!:( Well if everything else fails(I can't think of anything else right now)Try changing the IRQ anyway;)
Had the same issue a while back...I ended up getting a different card. I purchased a netgear and all is well.
NIC cards are common slowdowns for bootup. Especially those "pause" type of delays where nothing occurs, ie no disk activity, etc. This is especially true for some NICs that are not physically connected to anything.

I only use my net card when I bring my PC over friends for LAN games, so I just disable the NIC in device manager and re-enable it when needed. You could also create a second hardware profile that has the NIC disabled if you want the option of using it, or not, at bootup
The reason why your NIC is slowing you down on bootup is probably because it is searching for a DHCP server. If you need your NIC to get an IP address when you boot up, and your ISP's DHCP server is just too slow, you can try assigning a static IP address. This will generally only work if you're given the same static IP every single time. If you're using the NIC to network it in your house, you can try using static IPs among all the computers in the network. If you just have the NIC and only use it once in a while, you can disable it all together until you need to use it.



I'm running a netgear FS311, buying this card will not likely eliminate the delay problem. I would try disabling it or creating a second hardware profile first... IMHO

Even with a static IP, this card will delay the bootup unless disabled
Thanks, that saved me some time. Anyway, I created another hardware profile and it looks like it speeded up even more! Thanks, ppl. :D
Its the DHCP thing that causes the Boot Delay.

Now - if you use a cable modem through your network card or somthing, then dont do this as chances are it will break your machine. However, if you are on dialup or Cable Modem thru USB then do the following :

Right click on Network Neighbourhood and go to properties. Find 'TCP-IP' that is bound to your network adaptor (i.e. 'TCP-IP on Realtek 8139')

Double click on that, and you should be shown a screen that lets you pick either 'Obtain IP Address Automatically' or 'Specifiy IP Address'.

Click on the Specifiy option and put in the following details :

IP :
Subnet :

Apply that and reboot. Your boot times should be a lot better.

P.S. If this breaks your machine or anything (which it shouldnt) I am not to blame... I know that doing this should work :)