help with remote wonder plus


New member
I read all the tray disappearing solutions, but none worked. I think it is because i cannot complete the installation

for some reason, when i install the software, version 3.02, the only version for remote wonder plus, there is always a error of x10net.dll not being registered, it's always this msg, I tried downloading the x10 driver and install it, but that doesnt seem to fixed it. and i still cannot get the remote to work. Anyone with remote wonder plus can help out? thanks
I have exactly the same error message on remote install (Remote Wonder Plus that was included with the ATI TV Wonder Elite). Although I was able to download and install the x10drivers and this did allow the installation to complete without error message, I have no remote icon in the quicklaunch area and I have no indication that the remote works (other than flashing a light when I press a button).

The devices looked to be configured correctly in Device Manager and I've tried all manner of software version updates and different USB 2.0 ports.

I even tried the install on a different computer with totally different hardware. I got the same error message on install! Has anyone managed to install the Remote Wonder Plus without this error or do you all have prior X10 drivers installed?

Also is there supposed to be a light on the receiver that appears when a button is pressed? (I have no light on the receiver.)
I hope some one can help us, all the solution i've seen is either rw 1 or rw2, anyone here use the rw plus that came with hdtv wonder? and on the rw plus, there is no light on the reciever.
I'm starting to think that even if by some small miracle this remote can be made to work, it probably won't work for long. I've read far too many reports of a working Wonder remote that suddenly stops working and the complicated steps that need to be taken to maybe get it working again. Based on their lack of response to me and useless responses to others, ATI doesn't seem to care either. Although I like the TV Wonder Elite card, mine is going back to the store.
I had nothing, but prob. with 3.02, same as you people.

So I went back to 3.0, from the disk, that came with the remote.

No disapearing act or anything. On my main mach. or the HTPC.

x10net.dll errors figured out (NOT for the faint of heart!!!!!)

x10net.dll errors figured out (NOT for the faint of heart!!!!!)

My dad bought a new computer over the summer and we put an HDTV Wonder in it. He loves his remote so I figured the Remote Wonder Plus would be a great addition. WRONG -- he had the "could not register x10net.dll" error from the beginning and I could never fix it.

Well, I am home for the holidays and figured I'd sit down and really try it. I manually tried to register the x10net.dll file (regsvr32 x10net.dll) and got an error 0x80070005 which is access denied. Following the advice from I downloaded Regmon and saw that indeed, there were "Access denied" errors when trying to register it.

So, I did the following: (Warning: This is NOT for the faint of heart. BE SURE YOU BACKUP YOUR SYSTEM!!! This is heavy system tweaking and if you do the wrong thing you will probably mess up your computer) [Note: This is for the latest RW 3.02 drivers, not sure if its the same for other ones]

1. Cleaned out ALL the old crud -- uninstalled all RW software, all X10 drivers, uninstalled from the Device Manager, deleted the REMOTE WONDER OR X10 ONLY !!!! OEMxx.inf files in C:\Windows\inf\

2. Reboot and install the latest RW drivers. It's fine if it errors out on x10net.dll.

3. try to manually register the x10net.dll file. Do a search for it, then open a command window (cmd, then cd c:\program files\ATI Multimedia\remctrl or something like that) and navigate to that folder.

4. Type "regsvr32 x10net.dll". If you get an error, you will have to keep going. If you for some reason don't, you're actually going to be ok, skip to step 6

5. using regedt32 (NOT the normal regedit!!), go to 'HKEY_CLASSES_ROOT' and look for the x10 entries. Check the permissions on each registry key that contains it ** but use your head -- be sure it looks related to drivers or the like**. All of them should have administrator given full control. It was about 11 of them on my dad's computer. I gave 'system' full control as well, not sure if that was needed but I was sick of it. ;)

They looked like the following (this is not a comprehensive list -- as I am not sure if they all exist or all machines -- but to give you a general idea of what you are looking for)

Many of them had the ".1" entries along with the normal ones. I reset all of the permissions.

6. Go to Control Panel - Add/Remove Programs - ATI Remote Wonder. Do a repair install. Cross your fingers -- if you got the right registry keys, it will now successfully install!

7. Plug in the remote dongle to a USB port. It should properly recognize it.

8. Launch the Remote Wonder software (and/or reboot, and it should launch automatically). You should have remote control now!

** I am not 100% sure this is everyone's problems with the x10net.dll problem but I am pretty sure it might be. I'm sorry if these directions aren't clear, I am writing from memory as I was trying so much I wasn't going to waste my time documenting every step. PLEASE be careful tweaking permissions in the registry as that is not a step that many people have ever done, and I'm sure you could really toast something bad if you aren't careful.

Good luck!