HDMI HD Audio does not detect TV

Ed Rios

New member
Running Windows 7 RC with ATI 4650 with HDMI out to a Sharp LCD.

I am using extended desktop; the moment I turn the TV "on" the extended display shows up. But the HDMI Audio does not play unless the TV was on while booting the Computer or the HDMI plug is pulled off and on from the back of the card.

When you go to Sound Manager the Realtek HDMI Output states that it is not plugged in, which it is. Would be nice not to have to turn the TV while starting the computer or have to unplug/plug the HDMI cable.

Using Realtek 2.39

I can't explain why but, just for fun...:
Shut down the computer
Turn on the TV
Boot the computer
Start whatever application should interact with TV
Open Sound Manager
Apply some tweaks (anything)
Close Sound Manager
Close the application feeding the TV
Shut down the computer

I bet one dollar (Cdn.) that clears up the problem.

Suggestion based on similar problems using Realtek Sound Manager with various AV and VOIP applications on various XP systems with connected TV.

Probably can't hurt to try.
Thanks for the responses, Tv in use right now but I will try both suggestions and report.

BTW if I have the TV "on" while rebooting the ATI HDMI Audio can be selected but no sound will come out of the TV until the HDMI cable is disconnected from the Computer and reinserted.

Video is always available on extended display


Here is a sumary of what I did:

Shut down the computer Done
Turn on the TV Done
Boot the computer Done
Start whatever application should interact with TV Started DVBViewer
Open Sound Manager Done
Apply some tweaks (anything) Selected Realtek HDMI Output

Close Sound Manager Done
Close the application feeding the TV Done
Shut down the computer Done

Next I did the following:
Turn TV Off
Boot Computer
Turn TV ON after booting
Open sound manager Message reads ATI HDMI Audio Not plugged in

Next I unplug the HDMI from the back of the Computer (while TV is ON) and wait about 5 seconds then I plug the HDMI cable in and it says Ready.

Hmmm.... Might be worth trying to get some feedback from Realtek. The only other thing that comes to mind right now is using a switch. That *might* fool the computer into thinking it's an "always on" connection. If you don't have a switch, a stereo or DVD player may work -- if it can handle the input/output.
New Driver

New Driver

I was experiencing exaclty the same problem, I phoned ATI who said it was a known bug and it was fixed in the new version of the driver.

After upgrading the driver to v10.1, the problem has completly gone.

I hope this helps