Fire GL 8800 drivers for linux (w/8500)


New member
I know there has been some posts on this--I did do a search, but they seemed to turn into 'windows vs. linux flame wars.' It get's old to wade through, so I figured it would just be best to start a new thread. For those who have tried out the recently released linux drivers for the fire gl 8800 with their radeon 8500--how are things working out in 3D? Do 3D games seem to run great and look great? What games do you run? What are you basic systems specs? (CPU speed, RAM).

Thanks for any feedback, and I have really been wanting some good linux drivers for the 8500 so I can dual boot and play some the ID engine based games that I used to enjoy playing in linux back when i just had a radeon 32MB ddr (no, don't have linux installed anymore, but on the verge of redoing my system, and am seriously looking at dual booting).

And PLEASE!!! just don't come in here w/some linux flame--please! :D


Most are good. Wolf has a slowdown if you dont' change one of the texture settings. For the id games mostly good. But I find games will just crash at certain points returning me to the desktop. X is all good but certain things will bomb out. Tribes 2 likes doing this. I was playing Unreal last night, same thing. There's a clipping problem I would say that show's up in things. Generally they're ok. Pre beta I would say . The only good thing is that they have the Xtra Proprietary ATI OpenGL extensions. I find when I start doing some things I usually do with the opensource drivers these ones won't handle it and my machines either reboots or I have to reboot. Not all of xvideo seems to be working. Xawtv no longer works and xine goes all screwy. These are just a temporary thing.
Same here, but without the lockups. Had a lot of trouble getting my mouse to work again, (usb logitech mouseman cordless optical) Finally got it to work by connecting a simple ps/2 mouse and configuring it with fglrxconfig, for some unkown reason, after a reboot the ps/2 mouse doesn't respond to anything but the usb mouse suddenly works?! Anyways there are some graphic glitches in RTCW, And indeed one of the texture settings tend to make it a slide show :) but i haven't found any other problems yet. UT runs great, except for some messed up fonds, Some of the SuSe Yast menus in KDE 3.0 have some pretty messed up fonds to, and I to have the problem with xmms and mpeg files. Solved it by downloading MPlayer for linux.... great program u should try it, works with divx and DVD as well.

Hope I could be of any help.... is there anyone who could give me a small list of 3d games that have been ported to Linux? I'm stil rather new with it all.

Are there any other radeon 8500 compatible drivers out there that don't cost a small fortune?! It's a open (resd free) source community afterall.
Same here too,...different symptoms of the same sickness.

I'll go with terracon on the "pre-beta" rating, but it's still nice to finally see the ball starting to roll.

If you really wanna try it this soon, my advice is to run it with libpng2 based DE/apps.
"Anyways there are some graphic glitches in RTCW, And indeed one of the texture settings tend to make it a slide show "

Phew! So it wasn't just my system. lol. Other than that UT and Q3 run fine for me. Mandrake 8.2 BTW.