DVD-ROM does not work right in DMA mode


New member
I bought a Pioneer DVD-114 10x DVD-Rom late last year, and since I installed it, have been trying to get it to run right in DMA mode. When DMA mode is enabled, the ATI DVD player will play a movie for roughly 30 minutes, then my computer locks up. The only way out is to hit the reset button on my system. It does the same thing, when trying to install games distributed by Interplay. Whatever recording/copy protection method they are using causes my computer to lock up randomly during installation, or any other time I have to access an Interplay CD for an extended period of time (such as playing a movie).

I have tried updating the drive's firmware, and upgrading the VIA busmaster drivers. I have tried both the VIA miniport, and the Vendor Support Drivers, to no avail. I am at my wit's end on this. Any help on this will be appreciated.
is there a bios update for you motherboard? i had similar problems.. the only way i could fix it was to move dvd rom to another channel.
A long long time ago, I was also experiencing DMA problems and lost drives - My CD-RW would not come up in 2K sometimes and my DVD would do odd things....


Go into the Bios, and make sure that the IDE channels are set to auto rather than none for detection. This essentially means that all the IDE channels are active even if they are not used.

Not sure why this helped, but it did. Termination should not really be a problem, and each drive uses an ATA/33 cable and has its own IDE port rather than sharing.

I even noticed that the latest Abit KT7 BIOS update sets everything to auto by default for a change.

I hope this helps some of you.