Driver software de-evolving?


New member
Warning, long rant incoming. I am calling this the dark ages of driver software....

There has definitely been a shift in how driver software is developed these days: from allowing hardware to communicate with the OS, to providing some basic functionality in software, to much of the features and functions require the software to run. I don't really have much of a problem with this on its own, but dealing with driver software has become an increasing source frustration in recent years.

I suppose we could start at the beginning where problems started, with the change to "DCH" based drivers, requiring the UWP platform in Windows 10. Well, we could easily go back to the early-mid-2000s, with the transition of many computers running on the x64 architecture, but that's another era :lol:

I want to say my first issues came from iCUE being buggy and slow, but its tolerable - the UWP didn't really have much effect there thankfully. Where things really started, for me anyway, was Windows build 1903/1909 and the requirement for DCH nvidia drivers. Mind you, before DCH/UWP drivers, I rarely, if ever, had issues with GPU drivers. TBH nothing even really comes to mind, except the brief periodwhere pre-Dx8 stopped working, but nvidia took the reigns and got it working after some months, instead of breaking backward-compatibility, good on them!

nvidia drivers issue 1: gsync causing stuttering on multi-monitor setups. This went unfixed for a really long time and if we're being honest, I'm not particularly convinced its 100% fixed. You could be running along at 60+ FPS, everything is fine, then BAM, out of nowhere 20FPS. I have also found over the last couple of years that certain applications cause the desktop to be choppy. More specifically, if the window is active and has focus, mouse movement is choppy as well as desktop animations and such. Make the window inactive/lose focus and the choppiness goes way. I have also found strange "choppiness" behavior in some popular Electron based applications like Spotify and Slack. Even the new Windows Terminal app (which is great btw) caused this problem until a patch was made. Handbrake also caused this. Turn off gsync and all these issues disappear.

nvidia drivers issue 2: After DCH was introduced, NVCP had to be installed via windows store. It was a good 3-4 months before NVCP would even install and function properly. Installation failed because I "didn't own" nvidia control panel (wtf)? If it did install, it would just crash.

Now let's move on to Asus. I bought a ROG spatha. Yes, it's a ridiculously overpriced mouse. It was the only mouse I could find with 4-6 thumb buttons that didn't have a bad/uncomfortable layout. This thing was a bad experience from the get go. The installation process was.... well it was just bad. This thing installed all kinds of seemingly random applications and executables, and it just seemed like the entire application was written by a high schooler, who stole the lab's Visual basic CD form the lab at school, took it home, and installed it on his virus infested emachine running Windows Vista - proceeding to look up snippets online to hack together an application... Showed it to Asus HR, and was promptly hired on the spot.

ROG Armoury: Could not read the mouse profiles properly, literally everything would show up blank. Lots of forum posts with people complaining about similar problems. If you wanted to adjust anything on mouse, like something as simple changing the DPI, you would have to reconfigure everything for that profile. This includes the button assignments, lighting, DPI, power settings, etc. Every. Single. Time. If you opened the app to change just one thing, without reconfiguring all the other settings, the mouse would reset its default settings for everything except the one thing you changed. Custom button assignments, lighting, DPI, all wiped out and you would have to start over. Reinstalling the application didn't help. If you wanted to setup multiple profiles, have fun. If you so much as looked at the app funny, it would kill your customizations, laugh, and make you start all over from scratch.

Reinstalling ROG Armoury: If you think using the uninstaller would do the job, think again. If you were unfortunate enough for the uninstaller to crash or not find it's own manifest, have fun manually deleting everything, because there's a good chance the installer will crash if certain remnants of a previous installation are still present.

Other problems of note:

1. Some ROG exe's would prevent windows from shutting down.
2. Blank ROG window with no title wouid sometimes show up, also showing up up alt-tab as empty.
3. Saving profiles is slow, if it didn't wipe out all your other profiles.

Positive notes:

1. One day out of the blue, Armoury was able to read profiles from the mouse properly, somewhere between 6 and 10 months after purchase.

I like the mouse itself, but not a huge fan of the thumb button layout. I got used to it after a while, but I am still waiting on something better. I did eventually move on and got a G604 (it has it's own entry further down).

MSI software. Let's just say it's worse than Asus, this is probably a surprise to no one :lol:. I bought this laptop not long after it came out. I wanted something that had the power of a workstation, but with a gaming GPU, but also not "look" like a gaming laptop. I use it for work.

In any case, aside from the 4k 15" screen (would've much preferred QHD), I like the laptop itself. It's thin, has a nice build quality, minimalist look, the touchpad doesn't suck, great battery life, and the fingerprint reader is fast and accurate enough; not to mention the hardware is quite beefy.

Problem 1, Intel vs MSI: Well we now have three separate applications that each want to set their own screen brightness... facepalm.jpg

Problem 2, MSI creator center (aka dragon center with less "features"): 99% of the crap in this software is useless. All I want is custom fan control! Nearly every time I open this program, it bugs me to buy their shady looking online backup service. You have to enable "high performance" mode to get access to the "fan curves", if you want to call it that. It's a series of sliders with no markers indicating temperature targets, and doesn't seem to adhere to any settings with any consistency. It seems more like the problem just f**** off and does whatever it wants, aka fan settings don't do ****. In addition, when the program updates through windows store. It doesn't actually update. Instead, after its finished, you have to manually run it as administrator (it tells you to do this instead of having a UAC prompt), and you have to restart every time.

Problem 2a, MSI creator center: it doesn't respect per-monitor scaling. At my desk, I'm hooked up to my main monitor, which doesn't use scaling. The laptop display is basically the "slack screen". When I open this application, it's huge and blurry, fun!

Problem 3, not sure who to blame: If I leave the room and the computer sits idle for a while, the fans just kick up to 100% (read: loudly) for no reason. One time before I I got up to use the bathroom, I opened up task manager. Sure enough, after a few minutes, the fans went into turbo mode. Looking at task manager, the computer is sitting idle.... why?

Problem 4, wtf is nahimic and why does it keep crashing?! Apparently, MSI told microsoft that owners of this MSI other MSI laptops, that this garbage software that doesn't work should be installed. Uninstalled.

Problem 5, MSI, realtek and headset microphones: For whatever reason, the gain on the mic port is basically non-existent. So much so that if I need to do high quality audio, I have to use some third party software hack to boost the input gain like 400%. I thought that my headset mic was busted until I tried another headset, and a friends headset with the same results. Apparently, this is a common issue and the only workaround is the third part software. It's 100% realtek driver related too. When doing research, there was mention that a certain version of the driver doesn't have this problem, but it breaks the webcam mic. doublefacepalm.jpg

Problem 6, **** webcam. Not much else to say that I expected something better than a generic grainy ass webcam on a $2900 laptop

And now for the most recent problem I came across, yay Logitech!

A few days ago, something weird happened on my desktop. Afterburner and DLSS said it couldn't hook into the GPU driver. Okay fine, I don't really use DLSS that much these days, so I just uninstalled it. If I need it again, I'll reinstall.

Then I noticed something else weird happening. All my Steam games were taking a really long time to launch. They would hang for like 30-90 seconds for every game I tried. Once launched in window or full screen, they would hang for another 10 seconds or so. I tried a couple of games on GOG and they seemed to be fine, but they're also all old games. I only have one game installed with Origin, so I didn't bother checking.

The mind was racing. I built this computer in 2012, maybe a sign of something failing? I ran chkdsk on everything, all okay except for a bad entry on my storage drive but windows was able to fix it. Check smart status, all good there. If RAM/PSU were bad, I might be seeing some other stability issues like programs freezing/crashing, but I'm not. Steam itself runs fine. I reinstalled steam anyway, no change. It could be a virus, but that it highly doubtful, I would be seeing other issues. DPC latency was fine as well. Reboot and full shutdown had no effect.

I decided to launch a game, while having ProcMon monitor what the process was doing. I did notice something didn't seem right, during the app hanging interval, I'm seeing lots of queries/calls to USB/HID related devices and registry entries, xinput, direct input, etc. A couple in particular seemed to be looping way more than the other, or something. so I went through the list, looking at the hardware Ids to see what they were. It came down to three devices: my logitech F710, corsair K95, and logitech G604.

I googled each of these relating to application hanging and nothing relevant came up, except an icue bug that was fixed years ago. I just decided to unplug each one individually to see if anything changed...

- Unplugged controller, no change
- Unplugged keyboard, no change
- Unplugged mouse, games working normally again! Plugged mouse back in, everything still normal!

JFC really?! (╯°□°)╯︵ ┻━┻. It's funny, I was concerned about this mouse when I bought it. While reading reading reviews, there were lots of complaints about how buggy the drivers were, or people having problems with the mouse failing. I thought that was strange as I've rarely had issues with the "G" software in the past, though my MX revolution did eventually develop a double-click problem, after 5 years :lol:. It was on heavy discount this last black friday, and I was tired of Asus's s***, so I figured why not give it a go. Then this happens.

TLDR, driver software quality has really gone down in the last couple years.