Data-corruption bug hits VIA chipsets

Yeah VIA should be releasing a new BIOS here in the next week but... there's a fix for this problem now.. more like a work around.. check it out here...

"Well, already we have a work-around for you guys. This is truly a testament to the ingenuity of you, the readers, as this problem has been discovered and solved completely by VIA users at this point. VIA will supposedly have a BIOS patch later next week, but we are proud to bring you George's PCI latency patch now.

Keep in mind that it has only been tested on a limited number of configurations, but it should work under both NT/2K and 9X. Also, please treat it as BETA, and install at your own risk. Read the included readme for more information."

Get The Patch Here! Towards the bottom at George's patches....
Actually, a couple months late. There's a really long thread in the HardOCP mainboard forums about reconsidering buying a KT133A board. There is no definite workaround yet, and we dont know if the problem is the VIA chipset, SB Live, or DMA settings. Though my cheapass way of working around it is to use the RAID controller and bypassing IDE 1 and 2 completely :D
Is this related?

Is this related?

Could this be related to the VIA problem?

I have a KT133A board (EPoX 8KT3) with two HDDs on IDE1 and a CDRW and DVD player on IDE2. I've been using CD Clone without problems (keeping the image copy on the same HDD (first) as the executable). However, I recently moved the location for storing CD Clone's temporary image files to the second HDD. Now, I can't get CD Clone to successfully write a CD from an image file. When I tried to move the image file back to the first HDD (same location as the executable), I couldn't copy it using COPY/PASTE; I just got a Windows error message. ScanDisk shows no drive errors. I'm going to try storing an image on the same HDD as the executable and see how that works.

It's just flaky. EPoX doesn't have a VIA fix listed on their website. Any ideas or opinions?

Thanks in advance.
EPOX has released a beta BIOS that addresses the infamous bug for the ep-8kta3 and ep-8kta3+ motherboards.

The BIOS can be found in the EPOX news group (don't know if it is available from the website):

News server:
News group: epox.english.motherboard.ep-8kta3

The readme for bios update:

README.TXT File for BIOS Flash Updating

* BETA Evaluation BIOS. Use at your own risk. *

Bios filename: 8kt31411.bin
Bios date: 04/11/2001
Bios size: 256 KB (For 2Mb BIOS EEPROM)
Bios checksum: n/a
Model support: EP-8KTA3, EP-8KTA3+

Files included in this download:
README.TXT Text file with BIOS Release & Application Notes.
UPDATE.BAT Batch file for the Flash BIOS update process.
RESTORE.BAT Batch file for the Flash BIOS restore process.
xxxxxxxx.BIN BIOS binary file used by UPDATE.BAT.
AWDFLASH.EXE Program used to Flash BIOS code to the EEPROM.

Enhancements & Fixes for this BIOS release:
Fixed KT133/A + 686B IDE "overrun" error transfering large files.
VIA chipsets have had problems with data corruption since the MVP3 days, and they haven't admitted it until now!! :(
via bug

via bug

Ive had a kx board for a year and its fine, and my other board is an amd 750(slot a 900mhz t-bird no less) never had an kt board, and never will..go amd there...
new beta's for a-bit are out..

seems to be a bit of confusion over their usage tho..
might just be the A boards, maybe not..
but prob. include the E boards, but again maybe not..
still waiting for more info on them..

there is a version of the Zh (originally E bios) that has come out tho with the 110 hpt's that are working fine on my kt7R..