Catalyst software will not install - Tried a few solutions

Not open for further replies.


New member
Hello. I'm the new guy here.

For several decades I've been involved with electronics and computing. I've got three
Desktops at home, built by me. The monitors were getting old, so I selected ViewSonic
as replacements.

I had an old copy of Catalyst Control Center that stopped working. Didn't need it with my
old monitors, so it was removed with Revo Uninstaller. My new ViewSonic monitors need
Catalyst to function properly.

I've got two dozen system backups and I try everything with a disposable (virtual) operating

I wanted to start with a clean slate, so I used DDU (Display Driver Uninstaller) from Safe Mode.
After launching the Catalyst installer, I selected "uninstall" to make sure all files from the old
version of Catalyst were gone. The uninstaller found nothing from the old version.

The contents of the SFX is extracted to C:\AMD and C:\Program Files. Why this redundancy I don't
know. The installer runs normally, from beginning to end. It seems to be installing the Catalyst
apps, but nothing happens!

I downloaded new, not so new, and older versions of Catalyst. In each case, the installer does
not install anything. I extracted the contents of the SFX packages manually with 7-Zip, and ran the
Setup.exe file. Again, nothing is installed.

If I cannot resolve this problem, my only option is the replace the AMD graphics cards with Nvidia
  1. Which graphics cards do you have?
  2. Which model of ViewSonic monitors are they?
  3. Why do you need CCC for the monitors to function properly?
  4. Is your testing being done within a virtual environment?
  5. Which VM software are you using?
  6. On which version of Windows are you running the VM software?

The answers to the above questions will help members search for solutions more thoroughly.
Thanks for your reply, EYE4LYFE.

I'm a partner in an electronics design company. My Desktops are kind of unique. They are custom
designed and built in my shop.

Each Desktop has five internal drives. They are all optically switched by a circuit board I designed.
By switching each drive in or out of the system, I can create any possible RAID configuration, or they
can function as isolated drives.

I use words like "disposable" or "virtual" because everyone understands those terms. My "virtual
system" is just a clone of the "real" system, but it's completely isolated by optical switching.

EYE4LYFE, I have reservations about Catalyst software. I refrained from googling about problems
with Catalyst, because I didn't want to read negative comments. Well, last night I did perform a few
Google searches. On another forum there is a fifteen page thread about Catalyst not installing and
CCC suddenly not working. A good summary of posts on that other forum is "try this, it worked for
me!" When I read that sort of thing, my brain shuts down.

The question is, should I devote many hours trying to figure out why Catalyst won't install? I have
to think about this for a couple of days.
It's curious... what is the series of Radeon cards in use and which version of the drivers are giving you a headache?
disposable (virtual) operating
Possibly upset a vpn configuration when you deleted the old drivers and may be easier to start from a fresh configuration, no matter what brand of gpu?
Last edited:
Not open for further replies.