Catalyst Media Center Update

Thanks for the correction!

I just applied the update and my sound is hooped. I should have left well enough alone...
I have a Sapphire Theatrix HD 650 PCI card on Vista 32. I did a clean install of the Cat 9-1 Theater Driver, along with the 1.0.4210 CMC I downloaded from Diamond MM. (Thanks, MrDave) Sound was borked when changing channels using that configuration. Downloaded and installed the ATI 1.0.4310 update, and now it works perfectly. Go figure.
Be thankful it works and let's not jinx it!!

I've been struggling with mine since I "updated" it. The audio and video stutter/skip while watching live tv but it's fine when you record.

Not a huge deal since I mostly record anyway, but still something I'd like to rectify.
I have an ATI TV Wonder 650 PCI card but I’m not sure I want to try this since I’m using Vista Media Center.

However, I noticed that the earlier implementations of Catalyst Media Center AKA Cyberlink PowerCinema installed much like Cyberlink PowerCinema in that it didn’t care if you had actual ATI hardware or not (or supported ATI hardware).

I guess I’m just curious if just anyone can download this update and use it. I’m guessing that ATI was waiting for Cyberlink to update the software and implement some kind of protection mechanism so everyone and their grandmother can’t use it, just those with supported ATI hardware. Actually, knowing Cyberlink, you probably have to have an earlier version of Catalyst Media Center installed before the update will install.
for me, the version on the CD is 3202, dated back in 2007, is it possble to download 4310 version in a complete package? or do I have to install 3202 from CD first and then update?

I actually tried powercinema 6.0.2221, tv works fine, but radio doesn't work, it says something like no supporting hardware.

edit: 650 PCI
Last edited:
The update worked fine for me. However using Vista 64 the UAC now asks for permission every time I launch the application.

Nope. The correct url is:

Upgrades all existing CMC's to version 1.0.4310

Happy hunting.

Neither of these links takes me to a download, for me. Cliffs? Anyone got it that can rehost it or post a torrent?

edit - :lol: as soon as I posted it that, I did a search for CMC 1.0.4310 and found this:
Did they delete it from their site?
Cause I searched their whole site, could not find the update.....:cry:

Did they just remove that CMC 1.0.4310 update from their site?
I searched their whole site, couldn't find it anywhere....
No, it's still there. Try going to their main site:
Then select " SUPPORT & DRIVERS" from the main choices that run HORIZONTALLY near the top of the page
On the bottom left (currently as they have changed the site) you see the Green Subtopic SEARCH BY PRODUCT...under that colum list find " TV TUNERS " and click it.
Then fill in your TV Tuner Card you have and in the SEARCH FIELD TYPE: " Catalyst Media Center Update 1.0.4310 "
The only result I get back is the 1.0.4310 update. Click it:
And that should take you to the page...Click download at the bottom of the page.

... I included the links from the pages HOWEVER, as you all know that's usually not possible with ATI's website. I HOPE EVERYONE has been filling out complaint forms that there site doesn't allow you to bookmark. They time out or ??? it's just an insane way for them to continue to organize their site. I'm NOT sure but it looks like they may have fixed that. Won't know until others try the links but... cross my fingers.
ALSO TRY SEARCHING for " 41344 " or " Article 41344 " (that's the title of the 1.0.4310 Patch).

BTW thank you X-tech for posting this information. Or I might not have otherwise found it.
-FURTHER, after someone pointed it out to me, the Latest Net 3.5 update causes CMC to not load.
Last edited:

You're very welcome! I hope it's working out for you. was until I downloaded the Microsoft Net 3.5 Update.... now it won't start. I don't really use it as anything but a back up...and I was informed there maybe some sort of work-around....
Anyone have see a list of what it's actually supposed to be doing?

EDIT: IDK what happened or what changed but Without me doing anything I tried starting CMC again & it does not start up but it takes longer and when it does it stalls more frequently/often and when it happens it lasts longer
Last edited: