Can't get 1080p from computer to Sony HDTV

Idle Wild

New member

I've just picked up a Sony 40" KDL-40W3000 which supports 1080p, I'm trying to get some 1080p output from a 9600pro, I'm using the DVI -> HDMI adaptor which I got with a 3870, and while the option for 1080p is available in the CCC, the TV complains 'Video mode unsupported' as soon as I switch to 1080p output.

1080i @ 30Hz over the DVI -> HDMI connection seems to work albeit it's pretty blocky.

I can get the full 1080 resolution over a VGA link but really wanna get the HDMI working, can anyone offer some advice, am I doing something wrong?

Thank you
Still having problems, I came across a similar thread where the guy seemed to be having the exact same issues, only for the muppet to later realise his TV is only capable of doing 720p.

Well this TV does support full 1080p, I have an HDD/DVD recorder which is upscaling to 1080p and working beautifully, the PC however is a nightmare.

I went out and bought a Powercolor 3650 AGP card to try with it just incase the 9600pro had developed some sort of issue or didn't support HDMI 1.x or perhaps even because of HDCP causing conflicts, I'm still pretty new to this stuff.

Still no change, I've obviously read about the overscanning problem in the above thread and have checked that the TV is rendering in 'Full Pixel' mode, but all I can achieve over the HDMI is a shrunken blocky super-bright display which isn't taking up the full area of the screen even though it claims to be 1920x1080.

VGA output @ 1920x1080 works fine...I WANT HDMI!

Also, pay attention ATi, I just tried to install drivers for the 3600 series only to be told 'no supported hardware available'!

Damn, blast and buggery, someone help me!
Last edited:
the ATI HDMI device driver are installed and ok in windows device manager ?

are you using the DVI-HDMI adaptor that you got with your 3650 ?

Because the Gray DVI-HDMI adaptor you got with your 3870 will only work on HD 38XX series .... the adaptor was black for the HD 2000 Series ...
Last edited:
Well here's the thing, here's a picture of the friggen box:


On the bottom left corner it clearly says built in HDMI, but it's bull****, there's no built in HDMI, it's twin DVI, you don't even get a DVI -> HDMI adaptor, talk about misdescriptions.

The weird thing is when you enable standard 1080p @ 60Hz in the CCC I get black borders and major underscanning. But if you select the 'Add' button, to add a custom resolution profile, it pops up at 1920 x 1080 there's no underscanning at all, it fits perfectly to the screen -- like a glove.

Course it won't add the custom profile cos it ends up being identical to the standard 1080p profile -- which is ****ed -- could this be a refresh rate issue?.

I actually managed to get 1080p last night, by clearing everything off the system relating to ATi and then using the drivers off the CD. It's all connected by a DVI -> HDMI cable which I had to buy separately. I had major underscanning again though, but luckily the TV was detected correctly as a Flat Panel in the CCC and the underscan sub-tree appeared, once I moved the underscan slider all the way to the right it filled the screen.

It's not very good though, it's hard to read text in the menus and dialogues, even with ClearType enabled. VGA actually looks a whole lot better, so something is obviously configured wrong or the underscanning is having an effect.
Last edited:
Speaking of that 'HDMI driver' you mentioned earlier, I actually downloaded and tried to install that last night, only to be told -- similarly to the cat drivers from the official ATi website -- no supported hardware detected.

But the HD3650 does have onboard HD audio, the installer for it on the CD comes up as AMD HD Audio, I've not had a look at the card itself to see if it's realtek or not, but I would have imagined they're all the same.

Shoddy support in general I think though, is this because it's a brand new product line, or the fact that it's AGP? I remember having similar problems with an HIS X800XL card when they were brand new, lack of/poor driver support for that particular vendor. Bit disappointed to be experiencing this again.
Last edited: