Another possible fix for disappearing icon w/ RW1


New member
The 3.02 drivers stopped working for me a fews weeks ago. Everytime I tried reinstalling them I got the error "x10net.dll failed to register".
I tried pretty much every fix online till the following worked for me.

1) Uninstall the 3.02 driver. You can keep your old plugins, EXCEPT THE ITUNES PLUGIN! That plugin has some problems that prevent the remote wonder software from working, took me hours to find this out! To be safe you can try renaming your Plugins folder until you get the remote working.
2) Install the 2.5 driver. You can get it from
3) Reboot. Or just go to Device manager, right click on "Universal Serial Bus Controllers" then select "Scan for Hardware Changes". Saves having to reboot, but might not work for everyone.
4) If the Remote Wonder program still doesnt work then go to Device manager, then "Universal Serial Bus Controllers", then uninstall every device related to the remote (there might be 1 or 2). Then do a "Scan for Hardware Changes". This should now find only one device. Then right click on the new device then Update Driver. Then select "Install from a list..." then "Don't Search..." then find and select "ATI Wireless Remote Reciever V2.36".
5) Do a Ctrl-Alt-Del and kill ATIRW.exe
6) Try the Remote Wonder program again. You'll see the icon in your system tray if it works.

The above method worked for me, but then I decided to give 3.02 another shot. Same no icon crap happened again. Looks like 3.02 definately has a problem.
So I repeated the steps above, except for step 2), I used the 3.01 driver instead, which doesn't seem to have to same problems as 3.02. To find it do a search for "remote-wonder-3-01-0-0-english.exe". I found it from an open directory, I'm sure other places have it too.
You might need to "clean" out your C:\windows\Inf folder of all Remote Wonder files. I did this, but I'm not sure if its essential to the fix above. There's another post in this forum describing how to do it.

I hope this helps someone. ATI's crappy drivers really pissed me off for a while :)
I had the same problem (x10net.dll registration failed) while trying to install Remote Wonder 3.2. I had to upgrade from 2.5 because it was not compatible with MMC 9.08 (caused crash). I wasted 4 hours trying to get this stupid software to work. ATI I hate you! Your support website is pathetic. After much frustration I found a work-around, based on a posting from another website and my own tweaking. Here it is:

1. Install Remote Wonder 3.1 on your main computer running the ATI video card. This version can be found on the ATI website under Drivers/Remote Control/Older Versions. Reboot computer. After reboot, if you see the RW icon in the system tray and the remote control works with your version of ATI MMC or TV tuner, you are done. Else, proceed to #2.

Basically, there is some problem with the RW 3.2 install program. So we will use RW 3.1 software to do the install, and then manually copy the 3.2 version to this computer from another computer where we were able to successfully install it.

2. Install RW 3.2 on a second computer, one that does not have an ATI card or any other ATI software.

3. Rename the C:\Program Files\ATI Multimedia\RemCtrl folder on your main computer to C:\Program Files\ATI Multimedia\RemCtrl-31

3. Copy the contents of the 3.2 folder from the second computer (C:\Program Files\ATI Multimedia\RemCtrl) over to the main computer. Reboot main computer.

Hopefully now Remote Control 3.2 is working properly on your main computer.

If you do not have access to a second computer, then as an extreme measure, try uninstalling all ATI software from your computer, install RW software first, then the rest of the ATI software. I have not tried this so I can't prove it will work. I am theorizing that there is something in the rest of the ATI software suite that prevents RW 3.2 from installing. Good luck!
What are these versions 3.1, 3.2, 2.36?? The version that came with my CD-ROM is 3.01 and the version that I can download from ATI is 3.02. I can't download the 2.5 version mentioned above because I can't find it on ATI's garbage website. And I can't avoid the x10net.dll registration failed error message (I FIRST tried the install with 3.01 drivers) - unless I first install the x10drivers.exe I get from Even with the install complete, I do not have the remote icon in the quicklaunch area and I do not have any function from my Remote Wonder Plus.

I think ATI has hugely screwed up their remote install because I get the same "x10net.dll has failed to register" error regardless of which of 3 computers I try it on.
same problem

same problem

I'm having the same problem... please keep this alive... I will post any potential fix if I find it (or give credit to others whose fix works for me).

You aren't alone,


Here is a strange problem. The Remote Wonder Plus works great on my PII 400. But not on my amd xp3200? Any ideas?


Would somebody please e-mail around older drivers for the remote wonder plus that are getting these @)&)@&) remotes to work.
Last edited:
So I got the remote to work. But only for about 15 minutes. then it stops responding???
Has anyone else had this problem?
here's how to access the older versions of the remote software:

click on DRIVERS AND SOFTWARE grey button on the top right
scroll down the left and click the plus next to REMOTE CONTROLS
click REMOTE WONDER or whatever version you have
here you will find a link that says "REMOTE WONDER Previous version and earlier"
they have the old version of 1.4 up to 2.5

took me a while of poking around the website to find them :rolleyes:
This problem can be fixed.

Make sure the usb receiver is not plugged in to the computer.

You need to find mfc71.dll and msvcr71.dll and make sure they are placed in your C:\WINDOWS\system32 folder.

Install the remote wonder software ignoring any errors.

Restart the computer and after the computer restarts, control>alt>del and when the windows task Manager opens click on the processes tab and find ATIRW.EXE. Highlight it and then click on the end process tab.

Next go to the start menu and then to run and type regedt32.exe.
This will bring up the registry editor and what you need to do is go to 'HKEY_CLASSES_ROOT' from there you need to click on the '+' and scroll down until you see folders with X10 in their name.

Next you have to click on the folder and then go up the top to edit and then Permissions. When the permissions screen opens make sure Allow is selected and then click Apply and OK. Repeat this for all the x10 folders and then reinstall the remote wonder software and hit repair.

Do a restart and you should have the remote icon in the task bar and everything working fine.

Last edited: