View Single Post
Old Mar 13, 2021, 06:25 AM   #15
LordHawkwind
Harbinger of Doom
 
Join Date: Jun 2003
Location: England Manchester
Posts: 3,118
LordHawkwind can beat 'Minesweeper' on any difficultyLordHawkwind can beat 'Minesweeper' on any difficultyLordHawkwind can beat 'Minesweeper' on any difficulty


ATI Technologies

So I gave my son my old Acer 27" 1440p 144hz monitor to run my old 5700XT on. Having installed it on the Display port I clicked on the AMD settings and ..nothing. Tried a few times still no luck. So I installed these drivers and when complete restarted and clicked on AMD settings again and..nothing. Curious I now decided to uninstall the AMD graphics software and start again. It duly uninstalled everything and I rebooted.

I then looked at Windows update and he hadn't done any since August last year and there were quite a few to install. So I installed all the updates which took ages to complete but finally it was up to date.

I then ran these drivers and clicked on clean install and it set off by uninstalling old drivers even though I thought I had already done that. Anyway this took a while and it flashed black a few times so I presume was actually uninstalling things that I thought the uninstall programme should already have done. So once it did that it installed the new drivers and I restarted.

I clicked on AMD settings and...it appeared immediately with everything as it should be so happy times. Freesync was enabled and the frame counter worked on the monitor. Ran the Rise of the Tomb Raider demo and it ran at over 144fps as the frame counter never moved. The average at the end was about 180fps which was higher than I used to get with the 5700XT and a Zen 2700. My son has my old 7700K at stock so was a bit surprised at that but obviously an old game that was more single threaded IPC dependent.

First thing he did was ask me to get rid of the frame counter on the monitor (heathen) which I wish I had on my new monitor. So far so good with these drivers they seem fine and he's had no BSOD's or issues and is happily gaming away at 1440p instead of 1080p.

I think the issue was probably a combination of him not keeping windows up to date and maybe a borked installation of the AMD drivers but updating windows and uninstalling old drivers and clean install of new drivers sorted it out. Unfortunately a simple 5 minute job took me an hour and a half.
__________________
Ryzen 7 3800X, ASUS Prime X470 Pro, KFA2 RTX 3090 SG, 16GB Crucial DDR4 LPX 3000 Ram, iiyama G-Master GB3466WQSU 3440x1440 freesync 144hz, 250gb Samsung SSD, 750mb Seagate SSHD, 2TB Seagate Barracuda H/D, 1 TB Samsung H/D, 850w PSU, Windows 10
LordHawkwind is offline   Reply With Quote