Rage3D Discussion Area

Rage3D Discussion Area (http://www.rage3d.com/board/index.php)
-   Legacy ATI Discussion and Technical Support (http://www.rage3d.com/board/forumdisplay.php?f=28)
-   -   Driver no go. (http://www.rage3d.com/board/showthread.php?t=34035188)

BaronVonBalsac Mar 18, 2017 10:30 PM

Driver no go.
 
My HTPC had a Radeon HD 4870, big card with two extra power plugs. It started to screw up so I bought a HD 6450, doesnt even need a fan its so efficient.

Problem is I cant get it to work. Windows installs a generic vga driver for which doesnt even get 1080p resolution. If I manage to get a radeon driver installed after the windows splash screen it turns black and freezes. Ive tried old legacy drivers and the newest drivers its always the same thing.

When I have a Radeon driver I can start it in safe mode but then back to under 1080p for available resolutions. Its not that much different then the card it replaced it even uses a hell of a lot less power. I have no idea how to get this card to work.:confused:

ShaidarHaran Mar 19, 2017 12:46 PM

Did you select the correct driver download? Looking at AMD's site they have the driver downloads split up into categories of cards, with the 6000 series being a legacy product. You have to select the correct O.S. under this header for your driver:
Quote:

Radeon™ R5 235X, R5 230, R5 220, HD 8470, HD 8350, HD 8000 (D/G variants), HD 7000 – HD 7600, HD 6000, and HD 5000 Series
Hope this helps


All times are GMT -5. The time now is 09:56 AM.

Powered by vBulletin® Version 3.6.5
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All trademarks used are properties of their respective owners. Copyright 1998-2011 Rage3D.com