No announcement yet.

Poor FPS in CS - advice appreciated

  • Filter
  • Time
  • Show
Clear All
new posts

    Poor FPS in CS - advice appreciated

    Right, I have a Radeon 9000 (non-pro) 128MB. When playing CS i get a steady 99fps untill I go into an open area with a few people in (4 or more). My FPS drops to about 40, somtimes lower but 40 is an average. If i go into an open area, ie u can see further, see more shapes or whatever is in the map fps drops to about 70 and fluctautes quite a bit.

    I'm pretty sure when i first got this I got a steady 99fps (certainly it didnt drop to 40 odd). I have antistropic and aliasing on max but changing them dosnt make *that* much diffrence, but fps is slightly higher, although textures look like **** as a result.

    I know I cant overclock this card (even by a small amount grahpics currupt a bit). But I'm wondering if this is likely to be some kind of driver issue, or is it just that my card is too ****?

    I also heard about the radeon tweak proggies that have hidden settings not in the Drivers. Is there likely to be a setting in there that could benifit me?

    Other info that might help:

    Runnin CS in open GL 800x600 @ 100hz
    XP2100 Processor @1.7Ghz
    K7S5A Mobo
    And the usual malarky.
    Also reinstalled a few days ago with the latest drivers but I still get nasty fps drop-age.


    Which CS? Steam 1.6? I personally find that although the features in 1.6 are nice the bugs kill it. Im gonna take some time tonight and see if I experience these drops.
    Gigabyte GA-P35-DS3L
    Radeon X800GTO2 w/16 pipelines
    Intel Core 2 Duo E8400
    2GB OCZ XTC PC2-8500 RAM
    750GB WD SATAII 16MB Cache
    120GB WD SATA 8MB Cache
    Samsung SH-S203B
    Antec Trupower 450w PSU


      Your problem will never be solved. And I don't think there is such thing as a 128mb Radeon 9000 that is non-pro.


        Originally posted by Deadpool
        Your problem will never be solved. And I don't think there is such thing as a 128mb Radeon 9000 that is non-pro.
        You can get the Radeon 9000 non-Pro with either 64MB or 128MB of onboard memory.
        Intel C2D E8400 @ 3.6Ghz
        Asus P5E X38
        4GB OCZ PC2-6400
        Radeon 4850s in Crossfire


          turn off v-sync for opengl. set it to 'always off'


            Also make sure Trueform is disabled.

            Even on my 9700 Pro it kills FPS in that game.

            Desktop 1
            Athlon XP 2000 :: 512 MB PC2100 :: 8K3A+ :: 9800 Pro :: Windows XP

            Desktop 2
            Barton 2500 :: 1024 MB PC3500 :: 8RDA3+ :: 9700 Pro :: Windows XP


              Yeah, CS 1.5

              I tried it with v-sync off, its a bit better, but it looks crap with the image tearing. I got truform off as well..

              Any other ideas?



                got your agp driver installed?
                Athlon XP-M 2600+@(200x11.5) | Abit AN7 | 2x512 Corsair XMS PC-3200 | BFG 6800 GT OC (400/1100) w/ NV Silencer 5 | Promise Ultra133TX2 | WD Caviar SE 80GB 8 MB | Seagate Barracuda 7200.7 160GB | Maxtor DiamondMax 10 300GB | Sony 16x DVD-ROM | NEC 3520A | Antec SmartPower 2.0 500w | Koolance PC-601 | Samsung SyncMaster 997DF