No announcement yet.

Need some help with VIA + AGP

  • Filter
  • Time
  • Show
Clear All
new posts

    Need some help with VIA + AGP

    Got a kinda toughie to deal with.. it's got me stumped.

    Epox Socket-A motherboard, KT880/8237 chipset with a Sapphire 9600XT AGP.

    I built this system a while ago (Windows XP SP2 + all updates), .NET Framework 2.0, Cat's 6.9. Everything worked great. SmartGART had AGP 8x, AGP read/writes.. all stable.

    Device Manager listed the "VIA CPU to AGP Controller", 8/15/2001 drivers.

    Fast forward a few months, system is totally unstable.. locks up on just about anything with 3d graphics (but desktop/2d and streaming works great). Look in the SmartGART and AGP Writes are disabled.. stuck on 4x. User admits to monkeying around with VIA/Hyperion drivers.. and sure enough, the AGP device is now "VIA CPU to AGP 2.0/3.0" and had a newer/2004 date on it.

    So, I remove all ATI drivers.. run Driver Cleaner Pro in Safe mode then roll-back the AGP device driver. It comes back as "VIA CPU to AGP Controller" with the 2001 date on it. But yellow exclamation point.

    So I uninstall driver, reboot, Windows Add/Remove wizard.. click a couple times.. it comes back this time solid.. no exclamation points.. device manager is happy.

    Install the 6.9 Catalyst driver set (full + ccc). Drivers are up but SmartGART has NO AGP (0x/grey slider). AGP Read/Write, PCI Read/Write are all off. I can slide AGP to 8x and click AGP Read/Write, it wants to reboot.. then reboots with all disabled once more.

    I've tried various re-installs of the drivers.. 6.9 to 6.11... all will NOT allow agp mode. I've tried removing the CPU to AGP driver.. can re-add it but doesn't let ATI drivers install with SmartGART happy.

    Any suggestions? I'm about to reformat but they lost some of their cd's too (Office XP, Norton 2006, etc.etc.. have to slipstream an XP Home SP2 also since they lost this too).

    Looking for any insights to clear out the VIA junk without having to do a re-install (if possible). Thanks in advance!
    Asus P5K Deluxe/WiFi, Q9550, 4GB DDR2-1066, Windows 7 64-bit, Sapphire 6970.

    Don't spread my wealth, spread my work ethic.
    3/21/2010 - R.I.P. Freedom, Democracy, America

    Well, you're on the right track with driver cleaner. What I think you need to do is uninstall the devices, ati & via, and reboot into safe mode and run Driver Cleaner & CAB cleaner, for both ATI and VIA.
    Then reboot and install the chipset drivers, reboot as required, and then install ati drivers.

    While you're in safe mode look in the temp folders and the root of the C: drive, see if you see any other locations drivers might be cached.