Go Back   Rage3D » Rage3D Discussion Area » Graphics Technology Forums » CATALYST Drivers
Rage3D Subscribe Register FAQ Members List Calendar Mark Forums Read

CATALYST Drivers Discussion and Technical support forum for AMD's Catalyst Drivers. Please put Linux-specific driver posts and Remote Wonder discussion in their respective forums.

"
Reply
 
Thread Tools Display Modes
Old Mar 9, 2012, 05:28 PM   #1
Advertisement (Guests Only)

Login or Register to remove this ad
nanohead
Too many Radeons to list
 
Join Date: Jan 2007
Posts: 362
nanohead is still being judged by the masses


Default The AODDriver4.1 service failed .... Cat 12.2 megaproblems

I installed the latest 12.2 on both my daily desktops this morning. And boy, what a mess. There are errors being thrown up in the event logs left and right, there is a new AML Device Install process in the startup table that causes hangs on startup and other errors. I have no idea what the AODDriver 4.1 even is???

What the heck...

I'm pretty used to the driver packages having issues, as they are generally very complex and come out at a fast pace. But these are very messy, and are causing lags, slowdowns, errors and issues. This is today after installing the drivers. I changed nothing else.

Often, problems in the event log/viewer that are shown don't matter that much, more of a nuisance, but THIS is messy
__________________
Penetrator Gigabyte GA-MA970A-UD3, Phenom 960T Unlocked 6 Cores@4.0Ghz, 8GB GSKIL Ripjaws, Dell 20" Monitor@1600x1200, Kingston 120GB SSD boot, Seagate 7200.10 - 320Gx2 in RAID 0 data

Stormcrow ASUS Sabertooth 990FX, Phenom 960T Unlocked 6 Cores@4.1Ghz Corsair H60 Water Cooled, 2x XFX 7950 in Crossfire Water Cooled w Swiftech, 8GB GSKIL Ripjaws, 5x120GB SSD RAID 5 Array
nanohead is offline   Reply With Quote
Old Mar 9, 2012, 06:54 PM   #2
Lurk
Going Nowhere Fast
 
Join Date: Dec 2004
Location: Italy Torino
Posts: 3,425
Lurk is still being judged by the masses


Default

I posted regarding this at least a month ago. Nobody even had the decency to answer.

My post was detailed and described the problem pretty well. Since the last three driver releases the AODDriver4.1 and AODDriver4.0 keep overlapping each other and unless you get rid of 4.1 the system will keep both, the latter with an exclamation mark. I was able to get the 4.1 version properly installed only once after some voodoo stuff I did which I can't remember since i was in a trance.

99% of the times 4.1 refuses to install and you have to get rid of it in device manager by showing hidden devices. At this point the system will eventually revert to version 4.01, maybe after two or three times you run the CCC.
I've had my share of e-mails coming and going with AMD, I don't give much of a damn anymore about it, I'll stop using their hardware when it's time.

I've lost any hope and am not looking forward to bug fixes anymore, I take their software as it comes and one day will simply decide to stop being a customer.

From the little I know, AOD should take care of the Overdrive function in CCC.

Send a bug report if you have time on your hands or hope for someone knowledgeable to be kind enough to have a look into this.
I pretty much gave up myself.

AFAIK version 4.1 should be more recent than 4.01. if there's a logic that is, and obviously the latest driver sets are having a problem installing the newer version, so the system automatically rolls back.
This is all the info I can share.
__________________
No question is dumb if you do not know the answer.
Q: How can you move on in life if all you care about is pussy and videogames?
A: You don't.

Last edited by Lurk : Mar 9, 2012 at 07:01 PM.
Lurk is offline   Reply With Quote
Old Mar 9, 2012, 07:01 PM   #3
Burn
Radeon HD 7970
 
Join Date: Jun 2007
Location: Canada in my house
Posts: 857
Burn is still being judged by the masses


Default

same problem here , and what i found everywhere with google is the same question without answer.

annoying.
__________________
-Burn
see button on the left for system specs.


There's a fine line between fishing and just standing on the shore like an idiot.
Burn is offline   Reply With Quote
Advertisement (Guests Only)
Login or Register to remove this ad
Old Mar 10, 2012, 08:50 AM   #4
nanohead
Too many Radeons to list
 
Join Date: Jan 2007
Posts: 362
nanohead is still being judged by the masses


Default

OK, so at least I'm not going crazy. I just rolled back my main desktop, and all is well again. As far as my gamer, I left it there, cuz I just started playing Mass Effect 3, and its running fine. I'll hack away at the problem.

I think you're correct that its an Overdrive problem linked from CCC. Not sure why there's some kind of run time error. I tried doing all sorts of tricks, from disabling services, to shutting off scheduled jobs, to deleting all ATI software (using the old Driver Cleaner.Net), and nothing fixed the AOD error message, which caused boot up to become much longer.

I even searched the Registry for all AOD entries, and some were strange. I set all values to (0), which usually denotes "do not start" (but not always), and the message STILL shows up, which is simply bizarre.

Not sure what's next. As long as my system runs well, I really don't care for now. I only use CCC and AOD on my gamer, so thats fine, as its running great with ME3. As far as my daily desktop, I reverted back to some driver from last year (from Windows Update, looks like 11.8) and all is well.

I think this is an unintended consequence, obviously a mistake, and missed in QA at AMD. Definitely NOT the end of the world, but more of a silly issue that should have been caught.

@Lurk, if you think that the other guys are better, well, they make just as many strange mistakes. I have both AMD and Nvidia and they both have good days and bad days.
__________________
Penetrator Gigabyte GA-MA970A-UD3, Phenom 960T Unlocked 6 Cores@4.0Ghz, 8GB GSKIL Ripjaws, Dell 20" Monitor@1600x1200, Kingston 120GB SSD boot, Seagate 7200.10 - 320Gx2 in RAID 0 data

Stormcrow ASUS Sabertooth 990FX, Phenom 960T Unlocked 6 Cores@4.1Ghz Corsair H60 Water Cooled, 2x XFX 7950 in Crossfire Water Cooled w Swiftech, 8GB GSKIL Ripjaws, 5x120GB SSD RAID 5 Array
nanohead is offline   Reply With Quote
Old Mar 10, 2012, 01:01 PM   #5
Lurk
Going Nowhere Fast
 
Join Date: Dec 2004
Location: Italy Torino
Posts: 3,425
Lurk is still being judged by the masses


Default

Quote:
Originally Posted by nanohead
@Lurk, if you think that the other guys are better, well, they make just as many strange mistakes. I have both AMD and Nvidia and they both have good days and bad days.
thx, I appreciate you pointing this out.

btw, the misses in AMD QA which are not the end of the world seem to have been piling up pretty high in the past months, at least to my (limited) knowledge.
__________________
No question is dumb if you do not know the answer.
Q: How can you move on in life if all you care about is pussy and videogames?
A: You don't.
Lurk is offline   Reply With Quote
Old Mar 11, 2012, 01:57 PM   #6
Burn
Radeon HD 7970
 
Join Date: Jun 2007
Location: Canada in my house
Posts: 857
Burn is still being judged by the masses


Default

[QUOTEI think this is an unintended consequence, obviously a mistake, and missed in QA at AMD. Definitely NOT the end of the world, but more of a silly issue that should have been caught.][/quote]


well i do not have any problems and my system run ok but i don't really like having errors in my event manager
__________________
-Burn
see button on the left for system specs.


There's a fine line between fishing and just standing on the shore like an idiot.
Burn is offline   Reply With Quote
Old Mar 29, 2012, 07:02 AM   #7
Cartel
Radeon HD 6970 2GB
 
Join Date: Sep 2007
Location: Canada Chilliwack, BC
Posts: 347
Cartel is still being judged by the masses


Default

they didn't fix this for 12.3.
12.4....not gonna waste my time trying
__________________
ASUS Sabertooth 990FX AMD Phenom II X6 1090T Zalman 9900NT G.Skill F3-10666CL7-4GBXH 16GB Sapphire Radeon HD 6970 2GB GDDR5 HT Omega Claro Plus Windows 7 Ultimate 64bit SP1 DSL 25Mbps APC Back UPS XS1000 CPU validated GPU validated
Cartel is offline   Reply With Quote
Old Mar 29, 2012, 01:34 PM   #8
Burn
Radeon HD 7970
 
Join Date: Jun 2007
Location: Canada in my house
Posts: 857
Burn is still being judged by the masses


Default

i fixed it myself ....

Go in the devices manager , view , show hidden device

you should see two AODDriver item , delete the one with with a yellow exclamation mark if present.

don't reboot yet ...

go and download the Microsoft autorun tool

http://technet.microsoft.com/en-us/s...rnals/bb963902

run the program and select the '' everything'' tab , you should see in the list autorunEntry the AODDriver line in error with no file path. delete it.

now reboot and the Error is gone in the event manager. I have only one item in my device manager : AODDriver4.1 with no errors
__________________
-Burn
see button on the left for system specs.


There's a fine line between fishing and just standing on the shore like an idiot.

Last edited by Burn : Mar 30, 2012 at 12:32 AM.
Burn is offline   Reply With Quote
Old Mar 29, 2012, 09:18 PM   #9
Blín D'ñero
HD7970 crossfire
 
Join Date: Oct 2002
Location: Netherlands Netherlands
Posts: 1,812
Blín D'ñero is still being judged by the masses


Default

AOD is AMD's total system OverDrive: THIS, and not CCC's Overdrive for Radeon cards.
(Btw, that's also why it's not available for those with an Intel-based machine).
__________________
Intel i7 2700K @ 4.8 Ghz | Zalman CPNS9900LED | Asus Maximus IV Extreme-Z | 16 GB Corsair Dominator GT CMT16GX3M4X2133C9 DDR3 | 2 x (Sapphire) AMD Radeon HD7970 (crossfire) | Creative X-Fi Titanium Fatality Pro | Corsair AX 1200W | 4 x WDC WD1002FAEX | Optiarc AD 5240S | Dell U3011 @ 2560x1600 | Steelseries 7G | Razer Imperator 2012 | Coolermaster Stacker STC T01 | Logitech Z-5500 | Sennheiser HD598 | Windows 7 Ultimate x64 SP1 |
Blín D'ñero is offline   Reply With Quote
Old Mar 30, 2012, 05:35 PM   #10
Lurk
Going Nowhere Fast
 
Join Date: Dec 2004
Location: Italy Torino
Posts: 3,425
Lurk is still being judged by the masses


Default

at last two posts, guys.
__________________
No question is dumb if you do not know the answer.
Q: How can you move on in life if all you care about is pussy and videogames?
A: You don't.
Lurk is offline   Reply With Quote
Old Jun 29, 2012, 06:23 AM   #11
Cartel
Radeon HD 6970 2GB
 
Join Date: Sep 2007
Location: Canada Chilliwack, BC
Posts: 347
Cartel is still being judged by the masses


Thumbs down

Quote:
Originally Posted by Blín D'ñero View Post
AOD is AMD's total system OverDrive: THIS, and not CCC's Overdrive for Radeon cards.
(Btw, that's also why it's not available for those with an Intel-based machine).
AODDriver is included with CCC.

C:\Program Files\ATI Technologies\ATI.ACE\Fuel\amd64\aoddriver2.sys

I tried the 12.6 driver and AODDriver4.xx still f**k up.

And when I uninstall my 12.1 driver, it doesn't take 4.01 with it.
I just spent 3 frigging hours installing uninstalling, installing uninstalling 12.6, 12.1 deleting aoddrivers till I'm blue in the face, no go.
wtf!!
__________________
ASUS Sabertooth 990FX AMD Phenom II X6 1090T Zalman 9900NT G.Skill F3-10666CL7-4GBXH 16GB Sapphire Radeon HD 6970 2GB GDDR5 HT Omega Claro Plus Windows 7 Ultimate 64bit SP1 DSL 25Mbps APC Back UPS XS1000 CPU validated GPU validated
Cartel is offline   Reply With Quote
Old Jun 29, 2012, 12:32 PM   #12
Blín D'ñero
HD7970 crossfire
 
Join Date: Oct 2002
Location: Netherlands Netherlands
Posts: 1,812
Blín D'ñero is still being judged by the masses


Default

Make sure you have .Net Framework 4 Client installed and updated.
__________________
Intel i7 2700K @ 4.8 Ghz | Zalman CPNS9900LED | Asus Maximus IV Extreme-Z | 16 GB Corsair Dominator GT CMT16GX3M4X2133C9 DDR3 | 2 x (Sapphire) AMD Radeon HD7970 (crossfire) | Creative X-Fi Titanium Fatality Pro | Corsair AX 1200W | 4 x WDC WD1002FAEX | Optiarc AD 5240S | Dell U3011 @ 2560x1600 | Steelseries 7G | Razer Imperator 2012 | Coolermaster Stacker STC T01 | Logitech Z-5500 | Sennheiser HD598 | Windows 7 Ultimate x64 SP1 |
Blín D'ñero is offline   Reply With Quote
Old Jun 29, 2012, 05:51 PM   #13
Cartel
Radeon HD 6970 2GB
 
Join Date: Sep 2007
Location: Canada Chilliwack, BC
Posts: 347
Cartel is still being judged by the masses


Angry

Quote:
Originally Posted by Blín D'ñero View Post
Make sure you have .Net Framework 4 Client installed and updated.
i installed .net client 4 and all the updates and still get the error.

Faulting application name: Fuel.Service.exe, version: 1.0.0.0, time stamp: 0x4fd626ed
Faulting module name: Device.dll, version: 4.1.0.0, time stamp: 0x4f55e10b
Exception code: 0xc0000005
Fault offset: 0x00000000000033c1
Faulting process id: 0x5d8
Faulting application start time: 0x01cd5648bb25330b
Faulting application path: C:\Program Files\ATI Technologies\ATI.ACE\Fuel\Fuel.Service.exe
Faulting module path: C:\Program Files\ATI Technologies\ATI.ACE\Fuel\Device.dll
Report Id: 441ea290-c23c-11e1-af4a-f46d0458fdd3

The AMD FUEL Service service terminated unexpectedly. It has done this 1 time(s).
__________________
ASUS Sabertooth 990FX AMD Phenom II X6 1090T Zalman 9900NT G.Skill F3-10666CL7-4GBXH 16GB Sapphire Radeon HD 6970 2GB GDDR5 HT Omega Claro Plus Windows 7 Ultimate 64bit SP1 DSL 25Mbps APC Back UPS XS1000 CPU validated GPU validated
Cartel is offline   Reply With Quote
Old Aug 17, 2012, 04:23 PM   #14
Cartel
Radeon HD 6970 2GB
 
Join Date: Sep 2007
Location: Canada Chilliwack, BC
Posts: 347
Cartel is still being judged by the masses


Thumbs down

still dealing with it 12.8

event id 7000 the AODDriver4.1 service failed to start due to the following error. the system con not find the file specified
__________________
ASUS Sabertooth 990FX AMD Phenom II X6 1090T Zalman 9900NT G.Skill F3-10666CL7-4GBXH 16GB Sapphire Radeon HD 6970 2GB GDDR5 HT Omega Claro Plus Windows 7 Ultimate 64bit SP1 DSL 25Mbps APC Back UPS XS1000 CPU validated GPU validated
Cartel is offline   Reply With Quote
Old Oct 3, 2012, 05:57 PM   #15
Cartel
Radeon HD 6970 2GB
 
Join Date: Sep 2007
Location: Canada Chilliwack, BC
Posts: 347
Cartel is still being judged by the masses


Default

12.9 has a new version of aoddriver, version AODDriver4.2.0 that fixes all issues I had.
Works perfect, looking forward to 12.9WHQL
make sure you manually remove AODDriver from device manager before you install 12.9, dont forget .net 4 first.
__________________
ASUS Sabertooth 990FX AMD Phenom II X6 1090T Zalman 9900NT G.Skill F3-10666CL7-4GBXH 16GB Sapphire Radeon HD 6970 2GB GDDR5 HT Omega Claro Plus Windows 7 Ultimate 64bit SP1 DSL 25Mbps APC Back UPS XS1000 CPU validated GPU validated
Cartel is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI WDM TV tuner service failed to start pondlily Multimedia Discussion and Technical Support 1 Mar 30, 2011 09:04 PM
Vista Service Pack 2 new feature - Service Pack Cleanup tool caveman-jim Operating Systems 5 Jun 4, 2009 03:54 PM
Anyone know anything about getting DSL service but no phone service? Stilgar1973 Off Topic Lounge 12 Jul 9, 2005 11:20 AM
AtiSserv failed to provide required interfaces; MFC1.dll failed register/install RW xycury Multimedia Discussion and Technical Support 3 Mar 19, 2005 01:01 PM
Windows XP Service Pack 1 and Internet Explorer 6.0 Service Pack 1 links Uriel Operating Systems 17 Feb 12, 2002 11:47 PM


All times are GMT -5. The time now is 02:02 AM.



Powered by vBulletin® Version 3.6.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
All trademarks used are properties of their respective owners. Copyright ©1998-2011 Rage3D.com
Links monetized by VigLink