Go Back   Rage3D » Rage3D Discussion Area » Archived Discussions » Linux
Rage3D Subscribe Register FAQ Members List Calendar Mark Forums Read

Linux Forum to discuss the popular Open Source operating system, plus other *NIX derivatives. Discussions about AMD Catalyst drivers can be had in the relevant subforum.

 
 
Thread Tools Display Modes
Old Feb 19, 2005, 04:49 PM   #1
Advertisement (Guests Only)

Login or Register to remove this ad
Komet
Newbie
 
Join Date: Jun 2004
Location: Penn State
Posts: 4
Komet is still being judged by the masses


Default New Linux Radeon driver problem

I have Slackware 10, kernel 2.6.6, and an ATI Radeon 9800. I was running x.org 6.7 up until a few hours ago.

Here's the deal. I was running one of the ATI drivers from the fall (like September or October) and that was working well. I heard the January drivers were pretty good, so I got the ATI drivers for XFREE86 4.3. I then was unable to play opengl games. For example, Quake 3 would load, but it would be very slow and Warcraft III would load (I could hear the sound in the background), but the screen would be blank. I'd have to kill X and restart it to get out of the games.

Today I decided to upgrade to x.org 6.8.2 and download the new xorg specific drivers that came out 3 days ago from ATI. I like how fglrxconfig finally outputs the xorg.conf file. But anyway, I'm still having the same problem with opengl games.

Here's a clip of the output from Warcraft III:

Code:
fglX11AllocateManagedSurface: __FGLTexMgrCreateObject failed!!
FGLTexMgr: open of shared memory object failed (Function not implemented)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!
fglX11AllocateManagedSurface: __FGLTexMgrCreateObject failed!!
FGLTexMgr: open of shared memory object failed (Function not implemented)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!
fglX11AllocateManagedSurface: __FGLTexMgrCreateObject failed!!
FGLTexMgr: open of shared memory object failed (Function not implemented)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!
fglX11AllocateManagedSurface: __FGLTexMgrCreateObject failed!!
It seems like my video memory isn't being utilized or something. I don't know what the deal is. Right now, I'm just looking for ATI drivers from the fall, but can't find them anywhere. I usually keep mine archived, but I don't have them for some reason.
Komet is offline  
Old Feb 19, 2005, 05:07 PM   #2
Komet
Newbie
 
Join Date: Jun 2004
Location: Penn State
Posts: 4
Komet is still being judged by the masses


Default

Actually, I found the solution.

http://www.ati.com/support/infobase/4687.html

How retarded. I just had to mount shm.
Komet is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing Linux ATI driver in RH 9.0 DrFever Linux 7 Nov 26, 2003 09:18 PM
Radeon Driver in Linux Help Immortal LuD Operating Systems 3 Aug 21, 2003 09:49 PM
Linux driver little problem KlaasBaas Linux 11 Dec 14, 2002 03:47 PM
Radeon 9700 Linux driver from ATI Ratchet AMD Radeon Software Discussion and Support 4 Aug 18, 2002 10:08 PM
Linux driver for Radeon 64 Jason Grant Radeon Technical Support 2 Sep 2, 2001 10:58 PM


All times are GMT -5. The time now is 01:57 AM.



Powered by vBulletin® Version 3.6.5
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
All trademarks used are properties of their respective owners. Copyright ©1998-2011 Rage3D.com
Links monetized by VigLink