Go Back   Rage3D » Rage3D Discussion Area » Graphics Technology Forums » AMD Radeon Software Discussion and Support
Rage3D Subscribe Register FAQ Members List Calendar Mark Forums Read

AMD Radeon Software Discussion and Support Discussion and Technical support forum for AMD's Radeon Software.

Reply
 
Thread Tools Display Modes
Old Sep 8, 2013, 02:36 PM   #1
Advertisement (Guests Only)

Login or Register to remove this ad
V1per
Radeon R200
 
Join Date: Aug 2013
Location: Canada Ontario, Canada
Posts: 75
V1per is still being judged by the masses


Default 13.10 beta "The AODDriver4.2.0 service failed to start"

I keep getting Event ID 7000 while running the 13.10 betas



I've disabled driver signing with bcdedit:
bcdedit.exe -set loadoptions DDISABLE_INTEGRITY_CHECKS

I've also made a group policy disabling driver signing checks (ignore), and uninstalled the KB2506014 Windows update and still AODDriver4.2.0 fails to install.



Is this problem going to impact performance? (or better yet) How do I fix it?

Thanks in advance
V1per is offline   Reply With Quote
Old Sep 8, 2013, 09:40 PM   #2
Blín D'ñero
HD7970 crossfire
 
Join Date: Oct 2002
Location: Netherlands Netherlands
Posts: 1,812
Blín D'ñero is still being judged by the masses


Default

Quote:
Originally Posted by V1per View Post
[...]

I've also made a group policy disabling driver signing checks (ignore), and uninstalled the KB2506014 Windows update and still AODDriver4.2.0 fails to install.

[...]
AMD Overdrive. Why are you looking in Device Manager?? You won't find it there. Your error doesn't say it fails to install; it fails to start.
Could happen if you use third party tools for overclock (for instance MSI Afterburner).

Undo what you did, use AMD uninstall tool to clean up (watch it if you have an AMD CPU!), disable any gpu overclocking tool, reinstall Catalyst.
__________________
Intel i7 2700K @ 4.8 Ghz | Zalman CPNS9900LED | Asus Maximus IV Extreme-Z | 16 GB Corsair Dominator GT CMT16GX3M4X2133C9 DDR3 | 2 x (Sapphire) AMD Radeon HD7970 (crossfire) | Creative X-Fi Titanium Fatality Pro | Corsair AX 1200W | 4 x WDC WD1002FAEX | Optiarc AD 5240S | Dell U3011 @ 2560x1600 | Steelseries 7G | Razer Imperator 2012 | Coolermaster Stacker STC T01 | Logitech Z-5500 | Sennheiser HD598 | Windows 7 Ultimate x64 SP1 |
Blín D'ñero is offline   Reply With Quote
Old Sep 9, 2013, 01:17 PM   #3
Lurk
Going Nowhere Fast
 
Join Date: Dec 2004
Location: Italy Torino
Posts: 4,356
Lurk can beat 'Minesweeper' on any difficultyLurk can beat 'Minesweeper' on any difficulty


Default

I have the AODDriver 4.2.0 listed in Device Manager under Non-Plug and Play Drivers. It's supposed to be there, if it isn't it means it's not installed, and that's the reason why it won't start.
__________________
No question is dumb if you do not know the answer.
Q: How can you move on in life if all you care about is pussy and videogames?
A: You don't.
Lurk is offline   Reply With Quote
Advertisement (Guests Only)
Login or Register to remove this ad
Old Sep 9, 2013, 02:17 PM   #4
Blín D'ñero
HD7970 crossfire
 
Join Date: Oct 2002
Location: Netherlands Netherlands
Posts: 1,812
Blín D'ñero is still being judged by the masses


Default

Oh then it is an Overdrive part for the AMD CPU i guess...? (if so, then my bad as i wouldn't know; i have an Intel)
__________________
Intel i7 2700K @ 4.8 Ghz | Zalman CPNS9900LED | Asus Maximus IV Extreme-Z | 16 GB Corsair Dominator GT CMT16GX3M4X2133C9 DDR3 | 2 x (Sapphire) AMD Radeon HD7970 (crossfire) | Creative X-Fi Titanium Fatality Pro | Corsair AX 1200W | 4 x WDC WD1002FAEX | Optiarc AD 5240S | Dell U3011 @ 2560x1600 | Steelseries 7G | Razer Imperator 2012 | Coolermaster Stacker STC T01 | Logitech Z-5500 | Sennheiser HD598 | Windows 7 Ultimate x64 SP1 |
Blín D'ñero is offline   Reply With Quote
Old Sep 9, 2013, 03:35 PM   #5
V1per
Radeon R200
 
Join Date: Aug 2013
Location: Canada Ontario, Canada
Posts: 75
V1per is still being judged by the masses


Default

Well I just tried again and AODDriver 4.2.0 is nowhere to be found in device manager so I'm going back to 13.8 beta2 and see what happens.
----------------------------------------

AODDriver 4.2.0 doesn't install with the 13.8 beta2's, going back to 13.8 beta
------------------------------------------------------------------------------------------

Some success. The AODDriver 4.2.0 does install with the 13.8 beta's

http://i215.photobucket.com/albums/c...ps18104702.jpg

Now to see if the Event ID 7000 will go away.
-------------------------------------------------------

Nope, Event ID 7000 is back with a new message

Description:
The AODDriver4.2.0 service failed to start due to the following error:
The system cannot find the file specified.

How can it not be found. It's right there in device manager. This is getting very frustrating !! I usually have no problems fixing stuff like this, wow.

Last edited by V1per : Sep 9, 2013 at 05:46 PM. Reason: added info
V1per is offline   Reply With Quote
Old Sep 10, 2013, 02:56 AM   #6
Dyre Straits
Radeon Caribbean Islands
 
Join Date: Apr 2001
Location: United States Atlanta, GA USA
Posts: 4,098
Dyre Straits is still being judged by the masses


Default

Quote:
Originally Posted by Lurk View Post
I have the AODDriver 4.2.0 listed in Device Manager under Non-Plug and Play Drivers. It's supposed to be there, if it isn't it means it's not installed, and that's the reason why it won't start.
It's not listed on my system at all under the Device Manager. And, Overdrive is definitely working on my 13.10 BETA install. ??? (And, yes, to see Non-plug n play devices, you have to select View/Show Hidden Devices.)
__________________
~Windows 10 x64 Professional~Gigabyte Z77X-UD5H~Intel I7-3770K~8x2 GB DDR3 Crucial Ballistic 1600 RAM (Dual Channel)~RealTek Onboard~XFX R9 390 8GB GDDR5~3 Acer 27 inch LCDs~SCEPTRE 505 4K UHD TVand one Sanyo 32 inch HDTV connected via Intel onboard GPU~SATA BluRay RW~1000 W PSU~And a Whole Lot More!~AND....1 TB XBOX ONE~1 PS4 with Uncharted Bundle~

Quote:
If you have an issue with what you said, please resolve it in private ;)
Dyre Straits is offline   Reply With Quote
Old Sep 10, 2013, 08:33 AM   #7
V1per
Radeon R200
 
Join Date: Aug 2013
Location: Canada Ontario, Canada
Posts: 75
V1per is still being judged by the masses


Default

Well I thought I'd try to install the 13.10 beta one last time and this is what I get after install



and Event ID 7000 is back with the same message as my first post.

Also, AODDriver 4.2.0 is nowhere to be found in Device Manager.

How AMD Overdrive can work properly with all these problems is beyond me. Anyway, I've wasted way too much time on this, going back to 13.4 again until they release the next beta, which will probably be the same **** different pile.

.....and thanks for the replies, much appreciated

V1per
V1per is offline   Reply With Quote
Old Sep 10, 2013, 08:55 AM   #8
Lurk
Going Nowhere Fast
 
Join Date: Dec 2004
Location: Italy Torino
Posts: 4,356
Lurk can beat 'Minesweeper' on any difficultyLurk can beat 'Minesweeper' on any difficulty


Default

well it seems like driver signing isn't disabled at all on your system! Also, do you have UAC disabled?
__________________
No question is dumb if you do not know the answer.
Q: How can you move on in life if all you care about is pussy and videogames?
A: You don't.
Lurk is offline   Reply With Quote
Old Sep 10, 2013, 09:47 AM   #9
Blín D'ñero
HD7970 crossfire
 
Join Date: Oct 2002
Location: Netherlands Netherlands
Posts: 1,812
Blín D'ñero is still being judged by the masses


Default

Quote:
Originally Posted by Dyre Straits View Post
It's not listed on my system at all under the Device Manager. And, Overdrive is definitely working on my 13.10 BETA install. ??? (And, yes, to see Non-plug n play devices, you have to select View/Show Hidden Devices.)
You have an Intel CPU system (like i have). That AOD they mention is the AMD CPU Overdrive (AMD Fusion), which we Intel CPU users of course don't have.
__________________
Intel i7 2700K @ 4.8 Ghz | Zalman CPNS9900LED | Asus Maximus IV Extreme-Z | 16 GB Corsair Dominator GT CMT16GX3M4X2133C9 DDR3 | 2 x (Sapphire) AMD Radeon HD7970 (crossfire) | Creative X-Fi Titanium Fatality Pro | Corsair AX 1200W | 4 x WDC WD1002FAEX | Optiarc AD 5240S | Dell U3011 @ 2560x1600 | Steelseries 7G | Razer Imperator 2012 | Coolermaster Stacker STC T01 | Logitech Z-5500 | Sennheiser HD598 | Windows 7 Ultimate x64 SP1 |
Blín D'ñero is offline   Reply With Quote
Old Sep 10, 2013, 10:21 AM   #10
Lurk
Going Nowhere Fast
 
Join Date: Dec 2004
Location: Italy Torino
Posts: 4,356
Lurk can beat 'Minesweeper' on any difficultyLurk can beat 'Minesweeper' on any difficulty


Default

Quote:
Originally Posted by Blín D'ñero View Post
You have an Intel CPU system (like i have). That AOD they mention is the AMD CPU Overdrive (AMD Fusion), which we Intel CPU users of course don't have.
this.
__________________
No question is dumb if you do not know the answer.
Q: How can you move on in life if all you care about is pussy and videogames?
A: You don't.
Lurk is offline   Reply With Quote
Old Sep 9, 2013, 03:32 PM   #11
V1per
Radeon R200
 
Join Date: Aug 2013
Location: Canada Ontario, Canada
Posts: 75
V1per is still being judged by the masses


Default

OK, I've undone everything I did. I've never used any third party overclocking tools, only the CCC Overdrive.

I've always used the "AMD clean up utility" after uninstalling from control panel (AMD Catalyst Install Manager)

I do have an AMD CPU (FX8350) and my motherboard has an AMD chipset (990FX)

I'm going to try again and install the 13.10 betas. This time I'm going to install them over top of themselves.

Last edited by V1per : Sep 9, 2013 at 05:47 PM.
V1per is offline   Reply With Quote
Old Sep 9, 2013, 05:43 PM   #12
Blín D'ñero
HD7970 crossfire
 
Join Date: Oct 2002
Location: Netherlands Netherlands
Posts: 1,812
Blín D'ñero is still being judged by the masses


Default

Quote:
Originally Posted by V1per View Post
[...]

I've always used the "AMD uninstall tool" after uninstalling from control panel (AMD Catalyst Install Manager)

I do have an AMD CPU (FX8350) and my motherboard has an AMD chipset (990FX)

[...]
May be therein lies the cause of your trouble: that AMD uninstall tool (aiming to be thorough) uninstalls more than you would like, when you're on an AMD system. There are several complaining posts about that on this forum.
You should check which chipset- and other motherboard / CPU related drivers it may have uninstalled.
__________________
Intel i7 2700K @ 4.8 Ghz | Zalman CPNS9900LED | Asus Maximus IV Extreme-Z | 16 GB Corsair Dominator GT CMT16GX3M4X2133C9 DDR3 | 2 x (Sapphire) AMD Radeon HD7970 (crossfire) | Creative X-Fi Titanium Fatality Pro | Corsair AX 1200W | 4 x WDC WD1002FAEX | Optiarc AD 5240S | Dell U3011 @ 2560x1600 | Steelseries 7G | Razer Imperator 2012 | Coolermaster Stacker STC T01 | Logitech Z-5500 | Sennheiser HD598 | Windows 7 Ultimate x64 SP1 |

Last edited by Blín D'ñero : Sep 9, 2013 at 05:45 PM.
Blín D'ñero is offline   Reply With Quote
Old Sep 9, 2013, 08:28 PM   #13
V1per
Radeon R200
 
Join Date: Aug 2013
Location: Canada Ontario, Canada
Posts: 75
V1per is still being judged by the masses


Default

Well, installing the Official WHQL 13.4 drivers (and the 13.5CAP1) solves the problem. No more Event ID 7000 , seems it's just the Betas that cause the problem for me.

The thing I noticed that was really weird is that even though event id 7000 said that AODDriver 4.2.0 failed to start, when looking at the driver properties it said it was started and working properly

This really sucks because the Frame Pacing feature in the betas made Skyrim, Fallout NV and Borderlands 2 (just to name a few) run much smoother.

Guess I'll just have to wait until the betas become official WHQL drivers.
V1per is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The AODDriver4.1 service failed .... Cat 12.2 megaproblems nanohead AMD Radeon Software Discussion and Support 14 Oct 3, 2012 05:57 PM
start service gives "not enough storage is available to process this command" message meerkat Radeon Tweaking, Modding, and Overclocking 1 Oct 17, 2002 12:07 PM
AIW Radeon. Can't Start TV. I get that "failed to initialize the video drivers" msg commando30 Radeon Technical Support 6 Apr 26, 2001 05:31 PM
Self service pls > latest official "beta" MR-G AMD Radeon Discussion and Support 5 Apr 24, 2001 08:57 AM
Self service pls > latest official "beta" MR-G Radeon Technical Support 0 Apr 24, 2001 08:01 AM


All times are GMT -5. The time now is 03:50 PM.



Powered by vBulletin® Version 3.6.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
All trademarks used are properties of their respective owners. Copyright ©1998-2011 Rage3D.com
Links monetized by VigLink