Go Back   Rage3D » Rage3D Discussion Area » Gaming and Computing Forums » General Software
Rage3D Subscribe Register FAQ Members List Calendar Mark Forums Read

General Software Anything software that is not operating system related goes here. Talk about the latest applications or discuss betas of upcoming products.

Reply
 
Thread Tools Display Modes
Old Mar 7, 2010, 08:14 AM   #1
Advertisement (Guests Only)

Login or Register to remove this ad
Pirate Neilsouth
The undead have returned!
 
Join Date: Feb 2006
Location: England Here and there
Posts: 22,391
Pirate Neilsouth is not someone to be trifled withPirate Neilsouth is not someone to be trifled withPirate Neilsouth is not someone to be trifled withPirate Neilsouth is not someone to be trifled withPirate Neilsouth is not someone to be trifled withPirate Neilsouth is not someone to be trifled withPirate Neilsouth is not someone to be trifled with


Default “Pax PCI X-Fi All OS Creative Software Suite 2010” - XP/Vista/Win7 – 32/64Bit

“Pax PCI X-Fi All OS Creative Software Suite 2010”
- XP/Vista/Win7 – 32/64Bit - Read me

PAX
Performance Audio Xeleration
-
Tweaked Drivers for Creative Soundcards:
Better Performance. Better Audio. Better Xeleration.


Pax PCI X-Fi All OS Creative Software Suite 2010
CD is base from Creative Titanium Treiber Cd

“Tweaked Edition”

Supported cards:
Sound Blaster X-Fi XtremeGamer Fatal1ty® Professional Series
Sound Blaster X-Fi Platinum Fatal1ty Champion Series
Sound Blaster X-Fi XtremeMusic
Sound Blaster X-Fi XtremeGamer
Sound Blaster X-Fi Platinum
Sound Blaster X-Fi Fatal1ty
Sound Blaster X-Fi Elite Pro
Sound Blaster X-Fi
Soundblaster X-Fi OEM Cards: Dell, HP and Gateway
Setup should work with any XFI Card now!
UHAA FULL Support now.

Supported OS:
Fully working Suite for XP, Vista, Win7
32 and 64Bit

Based on:
SBXF_PCDRV_LB_2_18_0013


PAX Changes:
+ Updated tweaks
+ Creative Console Launcher 2.61.43
+ Volume Panel 2.20.65
+ Creative SoundFont Bank Manager 3.21.00
+ Vienna SoundFont Studio 2.40.60
+ 3DMidi 1.11.01
+ Alchemy 1.41.02
+ WAVESTUDIO_7 7.12.00
+ Diagnose 5.11.02
+ OALInst 2.1.0 I forget added the readme.
+ CTXInst It said error custom setup Just installed it's imporant.
+ Direct X Feb 2010 Full Edtion.
+ CEC 3.40.21 This can be launch by it self
+ CMS5 5.26.02 This can be launch by it self
+ THX Console 3.10.08
+ Updated Support ID setup support.
http://dl.technewshw.com/drivers/Pax...uite%202010.7z


CLEAN UNINSTALL make sure you run the setup.exe in one of the driver folders and select

Quote:

Driver Uninstallation
Tick -> Delete all Shared Creative Audio Driver Files

Then Click OK

Exit the setup

Go into your system hardware devices and uninstall Soundblaster XFI(soundcard) from hardware devices

Go into ADD/REMOVE and remove all creative software

Then do your usual driversweep , CCLEAN e.t.c

Reboot into Safe Mode , Again run Driversweep , CCLEAN

Reboot into normal windows , run the setup. Don't worry about the cab file failure it's just two languages people don't speak anymore
MY REVIEW

Quote:
I swapped my XFI XtremeGamer from the bottom pci slot to the second from the bottom slot as i read that the xfi prefers this slot. Thought i'd give it a try anyway

But back to the drivers , i was getting the odd latency spike into the mid yellows listening to music and horrible crackling with UT3 and decided to try different drivers. I tried dan's pack on the creative forums and although it improved matters on the dpc latency side of things the sound quality was pretty average. and just slight crackling. I then went to try the X-Fi Auzen 2.20.0002.10 RC4.2 pack from RanCor/Dan K i ended up with alot of crackling , low sound quality and far more spikes in dpc latency.

The dpc latency side of things isn't enough to worry about for most , but i prefer perfection even though i've only just read about it

I did a complete uninstall as i always do , making sure nothing remained. I then tried the “Pax PCI X-Fi All OS Creative Software Suite 2010”
- XP/Vista/Win7 – 32/64Bit. The ease of the install and being able to select the components when installing was a small bonus.

Whereas with the other packs it took me a little while to setup just to get average quality , i hardly did anything with this pax pack. Quality is high and no crackling , now maybe all Robert did was just a few tweaks or used other peoples drivers(so i heard) but as long as it works well for me that's all that matters!. My DPC Latency is constantly in the green aswell !
__________________
The undead Pirate Mod has returned to claim his victims!
Pirate Neilsouth is offline   Reply With Quote
Old Mar 15, 2010, 03:08 PM   #2
Redshirt_X
Radeon Arctic Islands
 
Join Date: Jul 2001
Location: United States Plano, TX
Posts: 5,479
Redshirt_X can beat 'Minesweeper' on any difficultyRedshirt_X can beat 'Minesweeper' on any difficultyRedshirt_X can beat 'Minesweeper' on any difficulty


Default

Hmm, interesting. I've been wanting to get my X-Fi Elite Pro back into my rig if I could (W7/x64 choked on it hard the one time I tried to install it)...
__________________
The three stages of [whatever] fandom:

1. "OMG IT'S COMING!!!"
2. "OMG IT'S HERE!!!!!"
3. "....wait a minute. This isn't the Second Coming! This sucks!"


Quote:
Originally Posted by Qb2k5 View Post
I like them tall and petite.
Redshirt_X is offline   Reply With Quote
Old Mar 15, 2010, 03:26 PM   #3
Pirate Neilsouth
The undead have returned!
 
Join Date: Feb 2006
Location: England Here and there
Posts: 22,391
Pirate Neilsouth is not someone to be trifled withPirate Neilsouth is not someone to be trifled withPirate Neilsouth is not someone to be trifled withPirate Neilsouth is not someone to be trifled withPirate Neilsouth is not someone to be trifled withPirate Neilsouth is not someone to be trifled withPirate Neilsouth is not someone to be trifled with


Default

I'm still using them , perfect sound quality
__________________
The undead Pirate Mod has returned to claim his victims!
Pirate Neilsouth is offline   Reply With Quote
Advertisement (Guests Only)
Login or Register to remove this ad
Old Mar 17, 2010, 08:12 PM   #4
Redshirt_X
Radeon Arctic Islands
 
Join Date: Jul 2001
Location: United States Plano, TX
Posts: 5,479
Redshirt_X can beat 'Minesweeper' on any difficultyRedshirt_X can beat 'Minesweeper' on any difficultyRedshirt_X can beat 'Minesweeper' on any difficulty


Default

I think I screwed up by installing the Creative app that's supposed to help with device detection under Windows 7 before the drivers, and after that it was basically nonstop errors, one system restore, a PCI slot move, and then nonstop errors again (mostly "You have previously installed drivers without rebooting...") while trying to install both the stock Creative drivers and the PAX driver-only set. But after finally going with the giant install package, yet more errors, and finally force-updating the damn thing, I've finally got the X-Fi Elite Pro up and providing sound...except that the mode switcher doesn't work ("There are no supported audio device available"). With my luck BF:BC2 will implode the minute I try to start it up too...
__________________
The three stages of [whatever] fandom:

1. "OMG IT'S COMING!!!"
2. "OMG IT'S HERE!!!!!"
3. "....wait a minute. This isn't the Second Coming! This sucks!"


Quote:
Originally Posted by Qb2k5 View Post
I like them tall and petite.
Redshirt_X is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Creative Announces Sound Blaster X-Fi MB2 Software Suite erek Front Page News 0 Jul 29, 2010 12:26 PM
Pax PCI X-Fi All OS Creative Software Suite 2010” Release Updated as 3/18/10 Pirate Neilsouth General Software 2 Mar 21, 2010 09:11 PM
8.70 RC1 Jan.5 2010 (Cat 10.x) Win7/Vista rflair AMD Radeon Software Discussion and Support 29 Jan 25, 2010 09:00 AM
PAX PCI CREATIVE XFI All-OS-Driver V1.35 - XP/Vista/Win7 – 32/64Bit Pirate Neilsouth General Software 1 Oct 26, 2009 12:26 PM
64bit Win7 installs drivers, but no compatible software? Mugsy323 Remote Wonder and Plug-In Discussion 1 May 24, 2009 01:27 PM


All times are GMT -5. The time now is 08:23 PM.



Powered by vBulletin® Version 3.6.5
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
All trademarks used are properties of their respective owners. Copyright ©1998-2011 Rage3D.com
Links monetized by VigLink