Go Back   Rage3D » Rage3D Discussion Area » Archived Discussions » Professional Graphics Discussion
Rage3D Subscribe Register FAQ Members List Calendar Mark Forums Read

Professional Graphics Discussion Discussion and technical support forum for ATIs lineup of professional level graphics cards

 
 
Thread Tools Display Modes
Old Sep 14, 2004, 08:05 PM   #1
Advertisement (Guests Only)

Login or Register to remove this ad
Shloppy
ATI FanBoi
 
Join Date: May 2003
Location: United Kingdom Scotland
Posts: 308
Shloppy is still being judged by the masses


ATI Technologies Force the Catalyst drivers to work on a FireGL

This is the simplest way to correctly install the Catalyst drivers on a FireGL X1-128 in Windows XP. For those with other FireGL models, merely amending the sections relating the cards DeviceID to your own models should also result in a success.

Code:
ATI FireGL Model		DeviceID	VendorID	SubSystemID

ATI FireGL V3100		0x5B64		1002
ATI FireGL V3200		0x3E54		1002
ATI FireGL V5100		0x5551		1002
ATI FireGL V7100                0x5550          1002
ATI FireGL X1-128		0x4E47		1002		0172
ATI FireGL X1-256		0x4E47		1002		0152
ATI FireGL X2-256/X2-256t	0x4E4B		1002		0152
ATI FireGL X3-256		0x4A4D		1002		
ATI FireGL Z1			0x4147		1002		0172
ATI FireGL T2  			0x4154		1002
For Windows 2000 users, alter the [WIN2K] headers instead of the [WINXP] sections and alter file "C2_17633.INI" instead of "CX_17633.INI" as shown in this guide. (Guide based on 4.9 Official Catalyst driver download, large package.)

Software to download

The latest Catalyst drivers from here.

RivaTuner from here.

RadLinker from here.

Getting Started

Double click the downloaded Catalyst package, wxp-w2k-catalyst-8-051-040825a-017633c.exe. You will get an error "Setup was unable to find components that can be installed ...". Click OK, which will cancel it.

Now browse to where the extracted files are located, which would be C:\ATI\SUPPORT\wxp-w2k-catalyst-8-051-040825a-017633C.

There are four things that need to be changed in order to make any Catalyst driver work with a FireGL X1-128.

Step One

With RivaTuner installed, double click "SoftR9x00 w2k.rts" located in C:\Program Files\RivaTuner\PatchScripts\ATI\SoftR9x00. The default is to force 9700 capabilites, which is fine as a FireGL X1-128 to all intent and purposes is a 9700 Pro.

For a FireGL X2-256, select to force 9800 capabilities

Click "Continue". Change the filetype to "ati2mtag.sy_" and browse to
C:\ATI\SUPPORT\wxp-w2k-catalyst-8-051-040825a-017633C\Driver\2KXP_INF\B_17656 and select "ati2mtag.sy_".
Another prompt will appear stating "This file is not certified to use with this patch script..", ignore it and click "Yes". It will then state "Patch script has been successfully executed". Click "Close".

Step Two

Browse to C:\ATI\SUPPORT\wxp-w2k-catalyst-8-051-040825a-017633C\Driver and edit file "CX_17633.INI".
Delete everything under the [WINXP] heading to just read the following:
Quote:
[WINXP]
Label=R6
R6=DriverPath_R6,0x4E47:0x01721002
DriverPath_R6=\2KXP_INF,CX_17633.INF

Looking at the table at top of page, we can see that "R6=DriverPath_R6,0x4E47:0x01721002" is based apon:
(0x4E47 is the DeviceID and 0x0172 the SubsystemID + 1002 the SubsytemVendorID)

Example: For a FireGL X2-256, change the DeviceID to read: R6=DriverPath_R6,0x4E4B:0x01521002
Save and exit.

Step Three

Still in C:\ATI\SUPPORT\wxp-w2k-catalyst-8-051-040825a-017633C\Driver, edit file "INSTALL.INI". Repeat the process of replacing everything under [WINXP] to:

Quote:
[WINXP]
Label=R6
R6=DriverPath_R6,0x4E47:0x01721002
DriverPath_R6=\2KXP_INF,CX_17633.INF

Example: Again, for a FireGL X2-256, we would change the DeviceID to read: R6=DriverPath_R6,0x4E4B:0x01521002
Save and exit.

Step Four

Lastly, browse to folder C:\ATI\SUPPORT\wxp-w2k-catalyst-8-051-040825a-017633C\Driver\2KXP_INF and edit file "CX_17633.inf".

Locate the following section:
Quote:
"RADEON 9700 PRO" = ati2mtag_R300, PCI\VEN_1002&DEV_4E44&SUBSYS_00021002
"RADEON 9700 PRO - Secondary" = ati2mtag_R300, PCI\VEN_1002&DEV_4E64&SUBSYS_00031002
and alter it to read:

Quote:
"RADEON 9700 PRO" = ati2mtag_R300, PCI\VEN_1002&DEV_4E47&SUBSYS_01721002
"RADEON 9700 PRO - Secondary" = ati2mtag_R300, PCI\VEN_1002&DEV_4E67&SUBSYS_01731002
Example for FireGL X2-256:

Locate the following section:

"RADEON 9800 PRO" = ati2mtag_R350, PCI\VEN_1002&DEV_4E48&SUBSYS_00021002
"RADEON 9800 PRO - Secondary" = ati2mtag_R350, PCI\VEN_1002&DEV_4E68&SUBSYS_00031002

and alter it to read:

"RADEON 9800 PRO" = ati2mtag_R350, PCI\VEN_1002&DEV_4E4B&SUBSYS_01521002
"RADEON 9800 PRO - Secondary" = ati2mtag_R350, PCI\VEN_1002&DEV_4E6B&SUBSYS_01531002



Save and exit.

Final Stage

Remove any currently installed drivers and reboot. Cancel any attempts by Windows to install a driver and browse into folder C:\ATI\SUPPORT\wxp-w2k-catalyst-8-051-040825a-017633C\Driver and run "setup.exe".

You will have no errors when installing, and effectively your FireGL X1-128 will be identified as a 9700 Pro. Complete the installation, but opt not to reboot just yet.

Next, browse to C:\ATI\SUPPORT\wxp-w2k-catalyst-8-051-040825a-017633C\CPanel and run "setup.exe" to install the Catalyst control panel.

Choose to reboot and start to enjoy the bugfixes/games performance improvements that the Catalyst drivers offer over the native FireGL's.
__________________
Wee, sleekit, cow’rin, tim’rous beastie, O, what a panic’s in thy breastie! -Robert Burns(1759–1796)

Last edited by Shloppy : Jan 22, 2005 at 05:28 PM.
Shloppy is offline  
Old Sep 15, 2004, 05:50 AM   #2
KingRoLo
Riddin Spinnaz
 
Join Date: Dec 2001
Location: United Kingdom London
Posts: 9,929
KingRoLo is still being judged by the masses


Default

Thanks for the guide Shloppy
__________________
Xeon E5-2650 | Asus GTX 1080 OC Strix | HyperX 32GB DDR4 | Corsair H60
KingRoLo is offline  
Old Sep 24, 2004, 03:26 AM   #3
Danka666
Radeon R200
 
Join Date: Oct 2003
Location: Greenock, paese di piogge
Posts: 62
Danka666 is still being judged by the masses


Default

I got a problem. You can call me stupid , but I'm unable to figure out what to change with whatelse in case someone uses a Fire Gl 8800.

__________________
Da{N}ka
Danka666 is offline  
Advertisement (Guests Only)
Login or Register to remove this ad
Old Sep 24, 2004, 04:50 AM   #4
Shloppy
ATI FanBoi
 
Join Date: May 2003
Location: United Kingdom Scotland
Posts: 308
Shloppy is still being judged by the masses


Default

A FireGL 8800 is, as far as I'm aware, a Radeon 8500 GPU. If that 's the case and with the knowledge that a FireGL 8800 ID's are:

DeviceID: 5148
VendorID: 1002
Subsystem ID:0152
Subsystem Vendor ID:1002

As you use Windows 2000, in files C2_17633.INI and INSTALL.INI, you would amend them to read:

[WIN2K]
Label=R6
R6=DriverPath_R6,0x5148:0x01521002
DriverPath_R6=\2KXP_INF,C2_17633.INF

As the Firegl 8800 has DeviceID 0x5148 whilst a Radeon 8500 DeviceID is 0x514C, we need to swap them.

Open up C2_17633.inf and edit it :

Replace:

"RADEON 8500 SERIES" = ati2mtag_R200, PCI\VEN_1002&DEV_514C&SUBSYS_013A1002
"RADEON 8500 SERIES " = ati2mtag_R200, PCI\VEN_1002&DEV_514C&SUBSYS_003A1002

With:

"RADEON 8500 SERIES" = ati2mtag_R200, PCI\VEN_1002&DEV_5148&SUBSYS_01521002
"RADEON 8500 SERIES " = ati2mtag_R200, PCI\VEN_1002&DEV_5148&SUBSYS_01531002

As I mentioned to you via PM, Direct3D will work fine but OpenGL will be broken. The reason being that Rivatuner's patch script doesn't support a pre-9500 graphics card. Only 9500, 9700 and 9800's are supported. Remember we had this conversation a while back concerning the patch bytes for the patchscript?

As a last resort, have you attempted to use the Omega drivers, or taken the pre-modded ati2mtag.sys from there?
__________________
Wee, sleekit, cow’rin, tim’rous beastie, O, what a panic’s in thy breastie! -Robert Burns(1759–1796)

Last edited by Shloppy : Sep 24, 2004 at 04:53 AM.
Shloppy is offline  
Old Sep 24, 2004, 07:40 AM   #5
Danka666
Radeon R200
 
Join Date: Oct 2003
Location: Greenock, paese di piogge
Posts: 62
Danka666 is still being judged by the masses


Default

Shloppy I have never received any PM from you unfortunately.

So you are telling me that rather than mod the ati2mtag.sys from the Catalyst with RivaTuner, it would be better to use directly the one contained in the Omega?

Or it would be better modding this one with RivaTuner ?

Just for your information, I use OpenGl for gaming like CounterStrike.
Would this...broken OpenGl affects me a lot?

Thanks again Shloppy... still I'd like to meet in Glasgow for a beer !!!
__________________
Da{N}ka
Danka666 is offline  
Old Sep 25, 2004, 05:59 PM   #6
Shloppy
ATI FanBoi
 
Join Date: May 2003
Location: United Kingdom Scotland
Posts: 308
Shloppy is still being judged by the masses


ATI Technologies

Sorry about that, I guess that PM got lost in the Royal Mail's postbags

There is no harm in trying Omega's or attempting a mod of ati2mtag.sys yourself using Rivatuner. But I doubt the latter would work as you attempted it in the past and it failed.

All things considered, your probably best to use the 8.043.1.1 FireGL drivers for now.
__________________
Wee, sleekit, cow’rin, tim’rous beastie, O, what a panic’s in thy breastie! -Robert Burns(1759–1796)
Shloppy is offline  
Old Oct 1, 2004, 08:39 AM   #7
Danka666
Radeon R200
 
Join Date: Oct 2003
Location: Greenock, paese di piogge
Posts: 62
Danka666 is still being judged by the masses


Default

Ehm...

I know I'm THE pain in the neck but... the Catalyst 4.6 and the 4.7 Beta... were supporting the Fire Gl 8800!
It looks like in the BETAs they were adding support for this FireGl, but then it disappears in the normal revision.

Am I saying bullsxxt ? Did you all know about this?
Will then be possible.. to... upgrade from them ?

Am I drunk and out of my mind?

no... I will try the Catalyst 4.7 Beta as soon as I will find the W2k version and as soon as I'm home

Cheers.
__________________
Da{N}ka
Danka666 is offline  
Old Oct 1, 2004, 08:59 AM   #8
Shloppy
ATI FanBoi
 
Join Date: May 2003
Location: United Kingdom Scotland
Posts: 308
Shloppy is still being judged by the masses


Default

No your quite correct in that the Catalyst 4.7 beta did indeed have support for FireGL's. Up until these latest hotfixed modded 4.9's thats what I had installed.

However, the jump from using said 4.7 beta's to the latest hotfixed Catalyst drivers in games such as FarCry or Doom 3 is considerable. The 4.7's for me had Doom 3 running poorly. But with latest hotfixed Catalyst, it runs super smooth

But I'm about to RMA my FireGL, yet again. I'm starting to get sick of the card truth be told. Still, let's hope the RMA process doesn't take 3 weeks like it did last time.
__________________
Wee, sleekit, cow’rin, tim’rous beastie, O, what a panic’s in thy breastie! -Robert Burns(1759–1796)
Shloppy is offline  
Old Oct 1, 2004, 08:59 AM   #9
Danka666
Radeon R200
 
Join Date: Oct 2003
Location: Greenock, paese di piogge
Posts: 62
Danka666 is still being judged by the masses


Default

AAAAA

problem.

The beta of the 4.7 contains only the XP driver.
Is anybody capable of finding the beta of the W2K one?

Pleeeeeeeese :P
__________________
Da{N}ka
Danka666 is offline  
Old Oct 1, 2004, 09:02 AM   #10
Danka666
Radeon R200
 
Join Date: Oct 2003
Location: Greenock, paese di piogge
Posts: 62
Danka666 is still being judged by the masses


Default

Shloppy I was thinking sooo many times to trash everything and get something proper..

But then you give a look at your account and you discover that food/rent and all those bloody expenses still have the priority!
__________________
Da{N}ka
Danka666 is offline  
Old Oct 8, 2004, 11:40 AM   #11
g45
Newbie
 
Join Date: Oct 2004
Posts: 2
g45 is still being judged by the masses


Default

hi, i did what is postet above, but there's still coming up this error: "Setup was unable to find components that can be installed ..."

i'm using a firegl x-1 256, what am i doing wrong? or do i have to change some thing??
g45 is offline  
Old Oct 17, 2004, 05:19 PM   #12
dgnzcn
Newbie
 
Join Date: Oct 2004
Posts: 6
dgnzcn is still being judged by the masses


Default

how to convert radeon 9800 pro > fireGL
(driver version is : ATI CATALYST 4.10 )
dgnzcn is offline  
Old Jan 5, 2005, 12:04 AM   #13
Zenith251
Newbie
 
Join Date: Jan 2005
Posts: 13
Zenith251 is still being judged by the masses


Default

So how are you supposed to get a Z1 to work? (256-Bit bus, 4x1 configuration) The only option in SoftRad seems to be forcing 8x1 as a Radeon 9500 Pro, which is unstable here.

(I sent a detailed PM to you Shloppy)
Zenith251 is offline  
Old Jan 5, 2005, 05:22 AM   #14
Shloppy
ATI FanBoi
 
Join Date: May 2003
Location: United Kingdom Scotland
Posts: 308
Shloppy is still being judged by the masses


Default

In reply to forum/PM points Zenith251:

The "Video not found" error is due to an incorrect setting in an .inf file. It cannot match the hardware ID of the card to any of the ID's listed in the .inf file(s).

Based on the previous RivaTuner build, I can't see patching "ati2mtag.sy_" to a 9500 would pose any problems. You could also try to force it as a 9700 and modify the subsequent .inf sections to unlock it to 8p. If you know what your doing, then:

Fire GL Z1 AGP Pro (128 MB)

ATI Fire GL Z1 Pro SECONDARY Video Accelerator=FGLRY,PCI\VEN_1002&DEV_4E67&SUBSYS_010B1002
ATI Fire GL Z1 Pro Video Accelerator=FGLRY,PCI\VEN_1002&DEV_4E47&SUBSYS_010a1002

Has all the info you'd need.


But back to the original query.

With Catalyst 4.9 as an example, you should modify CX_17633.INI and INSTALL.INI to read:

[WINXP]
Label=R6
R6=DriverPath_R6,0x4147:0x01721002

For a FireGL Pro Z1 you would amend the 9500 PRO / 9700 section and edit "CX_17633.inf" to replace:

"RADEON 9500 PRO / 9700" = ati2mtag_R300, PCI\VEN_1002&DEV_4E45&SUBSYS_00021002
"RADEON 9500 PRO / 9700 - Secondary" = ati2mtag_R300, PCI\VEN_1002&DEV_4E65&SUBSYS_00031002

With

"RADEON 9500 PRO / 9700" = ati2mtag_R300, PCI\VEN_1002&DEV_4147&SUBSYS_01721002
"RADEON 9500 PRO / 9700 - Secondary" = ati2mtag_R300, PCI\VEN_1002&DEV_4167&SUBSYS_01731002


If all else fails and you still can't modify the Catalyst drivers yourself, I'd suggest you grab the pre-modded 4.6/7 beta drivers from here.

These have native support for FireGL's and require no modification. From past experience, using modded Catalyst's results in the Dual DVI-I connectors of the FireGL line to no longer work correctly. Native FireGL drivers are the only solution as far as I'm aware.

You mentioned that your also experiencing corruption in movies when using the native FireGL drivers. Care to eloborate or post some screens?
__________________
Wee, sleekit, cow’rin, tim’rous beastie, O, what a panic’s in thy breastie! -Robert Burns(1759–1796)

Last edited by Shloppy : Jan 5, 2005 at 06:40 AM.
Shloppy is offline  
Old Jan 5, 2005, 06:43 AM   #15
Zenith251
Newbie
 
Join Date: Jan 2005
Posts: 13
Zenith251 is still being judged by the masses


Default

Ah! But you see good sir!

Thank you very much for such as hasty but detailed reply, I expected no such courtesy.

From my understanding, a FireGL Z1 is a 4x1 card (Radeon 9500 basd, not 9500 Pro/9700 Pro), so how would that affect this whole situation? Change the 9500 stock line instead of 9500 pro/ 9700? EDIT: What I mean to say is, the only difference between a X1 and a Z1 is the 4 extra pipes disabled, everything else is the same (At the base X1), including the clock speeds. So...I think you see where I'm going with this :EDIT

As for the video, WMP came back with overlay errors, and Media Player Classic, when expanded to full screen or even anything larger than the default video resolution, comes back much like a game running at 320x240. Broken edges, weird shite, basically. So limited are the drivers for FireGL's, also, I was amazed.

As for your reply, I shall retry what you proposed right away, hoping to find the error of my previous ways.

Final Edit: I've tried everything you've mentioned above, including slapping the device ID's onto the 9500 instead of 9500 Pro/9700 (Accordingly, of course) and am returned the same error. I swear to you, I've followed your guide to the letter, and yes, added the DriverPath_R6=\2KXP_INF,CX_17633.INF bellow each INI setting under WinXP.

I am stumped, and I've previously tried those beta 4.7's only to be given a most buggy experience. I refuse to surrender to ATi's driver games

Last edited by Zenith251 : Jan 5, 2005 at 07:00 AM.
Zenith251 is offline  
Old Jan 5, 2005, 07:22 AM   #16
Zenith251
Newbie
 
Join Date: Jan 2005
Posts: 13
Zenith251 is still being judged by the masses


Default

*Sigh*

Well I got some results from using self-modded drivers, but only by manually getting windows to look at the INF (Not the usual Update driver -> Point to directory, that didn't work either!). I had to tell it I had the disk, point to the INF.

1. Problem. It refuses to have a control panel of any sort. It's just...Not there, the tabs stop at windows stock "Color Management". I already installed the CPanel, but that just gives me the taskbar icon with the usual links and resolution control. I installed Radlinker next, but when I hit that tab, the whole thing just crashes with a Run.dll (Of all things!) error. It runs games fine, including HL2 and such...but I got no way to change global settings.
Zenith251 is offline  
Old Jan 5, 2005, 07:42 AM   #17
Shloppy
ATI FanBoi
 
Join Date: May 2003
Location: United Kingdom Scotland
Posts: 308
Shloppy is still being judged by the masses


Default

The fact that the card doesn't run well even with the correct FireGL drivers doesn't bode well.

A Z1/X1/X2 and so on should all work perfectly well with any movie playback or intense gamesplaying using just the native FireGL drivers.

Perhaps you could paste the info shown when you run RivaTuners Graphics subsystem diagnostic report?

I'm loath to suggest it, but perhaps there is something else causing your system to exhibit these problems? Sometimes solutions are best solved with a format
__________________
Wee, sleekit, cow’rin, tim’rous beastie, O, what a panic’s in thy breastie! -Robert Burns(1759–1796)

Last edited by Shloppy : Jan 5, 2005 at 07:45 AM.
Shloppy is offline  
Old Jan 6, 2005, 12:07 AM   #18
Zenith251
Newbie
 
Join Date: Jan 2005
Posts: 13
Zenith251 is still being judged by the masses


Default

Here we go.

Here's the rivatuner shot you request, completely original. I have DNA drivers installed because they're supposedly suppost to have updates for the FireGL's, and they act the same as the certified ATI ones did anyway. (Plus I get a cute HL2 themed taskbar )
http://www.nu11.org/gallery/zenith/FireGL?full=1

The card itself, two shots.
http://www.nu11.org/gallery/zenith/AUT_5206
http://www.nu11.org/gallery/zenith/AUT_5205

And finally, an example of the video problem. That's a widescreen (Though I cut it out wrong) video, consisting of Ghost In The Shell: Stand Alone Complex. Trust me when I say those jaggies aren't supposed to be there in either the subs, or video. Neither problem appears if I leave the video at it's default resolution. EDIT: The video, when like that, is too studdery to be tollerated.
http://www.nu11.org/gallery/zenith/Problem?full=1

Last edited by Zenith251 : Jan 6, 2005 at 12:13 AM.
Zenith251 is offline  
Old Jan 6, 2005, 02:27 AM   #19
Zenith251
Newbie
 
Join Date: Jan 2005
Posts: 13
Zenith251 is still being judged by the masses


Default

GOT IT!


I had to deviate from the guide, however.

I noticed something in the omega, DNA, and BETA cat's:

[WINXP]
Label=R6
R6=DriverPath_R6,0x4147
DriverPath_R6=\2KXP_INF,CX_17633.INF

Instead of :0x01721002 at the end, I just dropped it. I also dropped it from the INF file, I went to the /driver/setup.exe and away it went like it didn't see what all the fuss was about.

...Huh. Oh well, it works, and I thank you for putting up with my almost inexplicable issues.
Zenith251 is offline  
Old Jan 6, 2005, 03:44 AM   #20
Shloppy
ATI FanBoi
 
Join Date: May 2003
Location: United Kingdom Scotland
Posts: 308
Shloppy is still being judged by the masses


Default

Strange that removing the VendorID + SubSystemID strings that are correct made it work, but still, glad to hear it's working at last for you.

Have fun
__________________
Wee, sleekit, cow’rin, tim’rous beastie, O, what a panic’s in thy breastie! -Robert Burns(1759–1796)
Shloppy is offline  
Old Jan 17, 2005, 11:06 PM   #21
Kuz
Newbie
 
Join Date: Jan 2005
Posts: 1
Kuz is still being judged by the masses


Default Cat 5.1

Any tips for getting this to work on the Cat 5.1's that were just released? I have been playing around but unable to get it going completely. I think I may have got the drivers halfway working...the control center installs but will not launch
Kuz is offline  
Old Jan 23, 2005, 02:02 PM   #22
phoyoco
Radeon R100
 
Join Date: Jan 2005
Posts: 29
phoyoco is still being judged by the masses


Default

I've been having all sorts of issues getting the new 5.1's to work with my T2-128, if someone has already modified these drivers I'd be more than happy if you could share a copy.
phoyoco is offline  
Old Mar 9, 2005, 05:51 PM   #23
Zenith251
Newbie
 
Join Date: Jan 2005
Posts: 13
Zenith251 is still being judged by the masses


Default

Obviously we're going to run into problems depending on what ATI does...but jeez, I can't get the 5.1's to work on FireGL's at all. Maybe we need an update in the soft-rad mod for getting them to work as 9500/9700's?
Zenith251 is offline  
Old Mar 9, 2005, 07:51 PM   #24
phoyoco
Radeon R100
 
Join Date: Jan 2005
Posts: 29
phoyoco is still being judged by the masses


Default

It would be cool if someone could write a tool similar to Patje's mobility modder but to be used to get the FireGL cards to work with the Catalyst drivers. I've been having issues with all the 5.x drivers.
phoyoco is offline  
Old Mar 14, 2005, 09:12 AM   #25
StooMonster
FireGL V7100
 
Join Date: May 2003
Location: England
Posts: 20
StooMonster is still being judged by the masses


Default Patje's tool

Funny you posted that, in a totally seperate thread I've emailed Patje and asked him this very thing today!

StooMonster
StooMonster is offline  
Old Mar 14, 2005, 10:04 AM   #26
patje
Radeon R100
 
Join Date: Jan 2003
Posts: 25
patje is still being judged by the masses


Default

/plays eminems song
...
now this looks like a job for me
...


Well most interesting, and thanks for pointing this out to me StooMonster.
It appears that it won't be to hard to create a tool which alters the inf and ini files.

/puts on investigation hat and takes out the old sherlock holmes magnifying glass

Anyone that can provide me info is welcome to mail me at [email protected] with any luck I will see you email trough the spam so make sure you put Modding tool or something in the subject.
patje is offline  
Old Apr 16, 2005, 11:23 PM   #27
Zenith251
Newbie
 
Join Date: Jan 2005
Posts: 13
Zenith251 is still being judged by the masses


Default

Hrm, so has anyone made any progress in modding 5.x series Cats to run on FireGLs?

The modifications used for the <5.x series cats still load FireGL drivers (I guess, seems that way. Haven't tested it thoroughly) no matter what I do.

FireGL drivers are so passe. Quadro hardware with Quadro drivers still permit running games as you would on a GeForce, while FireGL drivers won't....

What gives ATI?
Zenith251 is offline  
Old Apr 17, 2005, 08:19 AM   #28
Shloppy
ATI FanBoi
 
Join Date: May 2003
Location: United Kingdom Scotland
Posts: 308
Shloppy is still being judged by the masses


Default

Just have to be patient and await Unwinders next release of RivaTuner to hopefully add support for updated patch scripts for 5.xx series of Catalyst drivers. Till then the 4.12 with 5.xx OpenGL .dll are more than suitable for all the latest games.

But your quite right, ATI should allow more options for their FireGL customers.
__________________
Wee, sleekit, cow’rin, tim’rous beastie, O, what a panic’s in thy breastie! -Robert Burns(1759–1796)

Last edited by Shloppy : Apr 17, 2005 at 09:53 AM.
Shloppy is offline  
Old Apr 17, 2005, 07:23 PM   #29
Zenith251
Newbie
 
Join Date: Jan 2005
Posts: 13
Zenith251 is still being judged by the masses


Default

5.x Cat series OpenGL .dll files?

How easy are they to swap for the older ones, and for that matter, which?
Zenith251 is offline  
Old Apr 17, 2005, 08:23 PM   #30
Shloppy
ATI FanBoi
 
Join Date: May 2003
Location: United Kingdom Scotland
Posts: 308
Shloppy is still being judged by the masses


Default

Extremely easy.

Backup your current OpenGL driver, then simply expand and place the new 5.xx atioglxx.dll OpenGL driver file into the “C:\WINDOWS\system32” folder to force system-wide use of the new driver.

If you don't want universal use of that library you can also just place the file in the desired games directory. When the games executable is launched this OpenGL library in games folder is utilised first and not the system wide library.
__________________
Wee, sleekit, cow’rin, tim’rous beastie, O, what a panic’s in thy breastie! -Robert Burns(1759–1796)
Shloppy is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FireGL T2 using catalyst drivers? seiko Professional Graphics Discussion 3 Aug 28, 2004 06:42 PM
AA Does not Work On Any Catalyst in 16-bit, Can I Force 32 Bit? mcq3000 AMD Radeon Software Discussion and Support 5 Jul 17, 2003 02:52 AM
New FireGL drivers out. Anyone able to make them work on an 8500? EdTheSped AMD Radeon Software Discussion and Support 151 Mar 12, 2003 10:08 PM
Using Catalyst Drivers with FireGL 8800? CaseMillennium AMD Radeon Software Discussion and Support 14 Sep 23, 2002 05:35 PM
ST: VOY Elite Force won't work with Catalyst thoennes AMD Radeon Software Discussion and Support 1 Jun 16, 2002 10:49 AM


All times are GMT -5. The time now is 05:18 PM.



Powered by vBulletin® Version 3.6.5
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All trademarks used are properties of their respective owners. Copyright ©1998-2011 Rage3D.com
Links monetized by VigLink