Go Back   Rage3D » Rage3D Discussion Area » Graphics Technology Forums » AMD Radeon Software Discussion and Support
Rage3D Subscribe Register FAQ Members List Calendar Mark Forums Read

AMD Radeon Software Discussion and Support Discussion and Technical support forum for AMD's Radeon Software.

Reply
 
Thread Tools Display Modes
Old Jan 11, 2008, 12:13 AM   #1
Advertisement (Guests Only)

Login or Register to remove this ad
CatalystOfFire
Newbie
 
Join Date: Jan 2008
Posts: 3
CatalystOfFire is still being judged by the masses


Default Crashes with catalyst update

Hey everybody, I'm getting a 100% consistent minimize-to-nothing problem with my Radeon 9600 card. When I installed it, catalyst control center was fairly new or so, and it worked fine, despite being an ATI product. (Back when I got it, it was a complete pain to install all those drivers with 56K)

Anyways, I'd been ignoring steam when it had been telling me to update my drivers, for QUITE some time. Last night I finally took it up on it's offer, and downloaded the new drivers with the provided link. I uninstalled all old drivers using the ATI uninstall program, and installed the new drivers. It was simple, easy, and completely doomed. If I try to run any type of 3D application, it simply minimizes, and is gone. no start bar icon. Every 3d app I've tried, without fail, has crashed this exact way.

It's odd because the drivers are working great, in every other aspect. My PC's speed has increased dramatically, for some odd reason, and it displays in hardware profiles as latest drivers. Everything had always worked fine before, albeit needlessly jumpy.


I've got an AGP ATI Radeon 9600 with whatever the newest drivers are,
AMD Sempron 2800+ 1.99GHZ,
2.0GB Ram,
Windows XP

...I just noticed that Steam lists my video drivers as 6.14.10.6755, and dates it as december 5th 2007... That doesn't make sense. How do I get steam and the rest of my software to realize that I've updated???
CatalystOfFire is offline   Reply With Quote
Old Jan 11, 2008, 01:56 AM   #2
Falcon1
Free Bird
 
Join Date: Sep 2002
Location: Germany Bergen (Near Munich)
Posts: 1,138
Falcon1 is still being judged by the masses


Default

Try cleaning your system with Driver Cleaner after uninstalling the new drivers. After cleaning your system, install the newest drivers again.

Download the newest drivers including CCC at http://game.amd.com/us-en/drivers_catalyst.aspx
__________________
Falcon1 is offline   Reply With Quote
Old Jan 11, 2008, 01:51 PM   #3
CatalystOfFire
Newbie
 
Join Date: Jan 2008
Posts: 3
CatalystOfFire is still being judged by the masses


Default

Didn't work. I used Driver cleaner, searched through my C drive and deleted just about every folder that so much as started with A, had already uninstalled everything in control panel... Still does the same thing.
I guess the drivers just don't work with my PC?
CatalystOfFire is offline   Reply With Quote
Advertisement (Guests Only)
Login or Register to remove this ad
Old Jan 11, 2008, 06:13 PM   #4
Sharkfood
Radeon Caribbean Islands
 
Join Date: Nov 2001
Location: United States Bay Area, California
Posts: 4,575
Sharkfood is still being judged by the masses


Default

Try the Catalyst 7.7 drivers as there is a regression issue with certain AGP chipset motherboards past the 7.8's -> current.

IF the 7.7's work, you'll need to wait until AMD/ATI gets this fixed-up.
__________________
Asus P5K Deluxe/WiFi, Q9550, 4GB DDR2-1066, Windows 7 64-bit, Sapphire 6970.

Don't spread my wealth, spread my work ethic.
3/21/2010 - R.I.P. Freedom, Democracy, America
Sharkfood is offline   Reply With Quote
Old Jan 13, 2008, 06:42 PM   #5
itsme2
Newbie
 
Join Date: Dec 2007
Posts: 22
itsme2 is still being judged by the masses


Default

Omega 7.10 drivers work great with my ATI 9800 PRO.
itsme2 is offline   Reply With Quote
Old Jan 15, 2008, 07:59 PM   #6
CatalystOfFire
Newbie
 
Join Date: Jan 2008
Posts: 3
CatalystOfFire is still being judged by the masses


Default

Thanks everyone for the advice and assistance! 7.7 drivers work! Not too wonderfully, but they work.

What I plan to do is just start at 7.10 and work my way down until I have the latest working drivers. I'll probably update when I know the highest working driver version.
CatalystOfFire is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox Update Brings Protection from Flash Crashes Android1 Front Page News 0 Jun 23, 2010 10:19 AM
mmc 9.08 + catalyst 5.6 crashes :/ cos AIW / Multimedia Discussion and Technical Support 2 Jul 21, 2005 09:16 AM
Driver update crashes carlekelly AMD Radeon Software Discussion and Support 0 Mar 21, 2003 08:47 PM
Crashes with Catalyst > 02.3 (2k & XP) HeavenY Radeon Technical Support 3 Feb 14, 2003 04:55 PM


All times are GMT -5. The time now is 11:21 AM.



Powered by vBulletin® Version 3.6.5
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
All trademarks used are properties of their respective owners. Copyright ©1998-2011 Rage3D.com
Links monetized by VigLink