Go Back   Rage3D » Rage3D Discussion Area » Archived Discussions » Linux » Drivers
Rage3D Subscribe Register FAQ Members List Calendar Mark Forums Read

Drivers Discussion forum for Linux drivers.

Reply
 
Thread Tools Display Modes
Old Dec 31, 2006, 11:58 AM   #1
Advertisement (Guests Only)

Login or Register to remove this ad
jinxjinx
Newbie
 
Join Date: Dec 2006
Posts: 4
jinxjinx is still being judged by the masses


Default Xlib: extension "XFree86-DRI" missing on display ":1.0".

WoW is not able to load 3d acceleration. However my 3d window manager compiz works fine.

when i type: fglrx info i get this
Error: unable to open display :0

when i type fgl_glxgears i get this:
Using GLX_SGIX_pbuffer
Xlib: extension "XFree86-DRI" missing on display ":1.0".
Error: couldn't get fbconfig

and i get a similar message when i try to start WoW

im running an ati 9800 pro

any help would be great thanks
jinxjinx is offline   Reply With Quote
Old Feb 8, 2007, 11:40 PM   #2
Suthern
Radeon R100
 
Join Date: Feb 2001
Posts: 32
Suthern is still being judged by the masses


Default

I've sort-of got the same issue.

I'm running Ubuntu, XGL with fglrx and ATI drivers. Beryl works great!

However, glxgears says
Code:
Xlib:  extension "XFree86-DRI" missing on display ":50.0".
and opens a gear window. The fps are really low. (400 range) Yea, I know 50 is a funny number, but that's what I'm running my special xgl session on. ;-)

If I try fgl_glxgears I get
Code:
Using GLX_SGIX_pbuffer
Xlib:  extension "XFree86-DRI" missing on display ":50.0".
Error: couldn't get fbconfig
And I'm curious... any native GL program works fine, but when I run a game with WINE, I get alot of the same XFree-86DRI error. Yes, GLX and DRI are in my xorg.conf file.

Just thought I'd drop in and say that you are not alone. If you've solved this issue, please show the solution! ;-)

Thanks!
-Suthern
Suthern is offline   Reply With Quote
Old Feb 9, 2007, 03:30 AM   #3
adamk75
Radeon R420
 
Join Date: Feb 2004
Posts: 315
adamk75 is still being judged by the masses


Default

The XGL server does not support Direct Rendering. You'll either have to stop using XGL when you want to use other 3D apps, start the 3D apps from the non-XGL server (probably :0) or run your apps without direct rendering.

Adam
adamk75 is offline   Reply With Quote
Advertisement (Guests Only)
Login or Register to remove this ad
Old Feb 22, 2007, 02:43 PM   #4
m0nt0
Newbie
 
Join Date: Feb 2007
Posts: 4
m0nt0 is still being judged by the masses


Default

There is a solution for that, its name is xgame and there is also a gtk frontend, xgamegtk. This little program "freeze" your current xsession and starts another xserver with the designed game or program.
m0nt0 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Xlib: extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0". harryc Linux 31 Nov 8, 2004 03:22 PM
Xlib: extension "XFree86-DRI" missing on display ":0.0" SoniC11 Linux 9 Aug 27, 2004 01:55 PM
Xlib: extension "XFree86-DRI" missing on display ":0.0" SoniC11 Radeon Technical Support 4 Aug 26, 2004 03:31 PM
Xlib: extension "XFree86-DRI" missing on display ":0.0". feend Linux 9 Feb 24, 2004 08:25 AM
Textures "dissapearing" and portions of display "flashing" when set to AGP4X Mandor Radeon Technical Support 49 May 6, 2001 07:55 PM


All times are GMT -5. The time now is 01:36 PM.



Powered by vBulletin® Version 3.6.5
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
All trademarks used are properties of their respective owners. Copyright ©1998-2011 Rage3D.com
Links monetized by VigLink