Go Back   Rage3D » Rage3D Discussion Area » Archived Discussions » Linux
Rage3D Subscribe Register FAQ Members List Calendar Mark Forums Read

Linux Forum to discuss the popular Open Source operating system, plus other *NIX derivatives. Discussions about AMD Catalyst drivers can be had in the relevant subforum.

 
 
Thread Tools Display Modes
Old Nov 23, 2003, 04:51 PM   #1
Advertisement (Guests Only)

Login or Register to remove this ad
feend
LinuxFeend
 
Join Date: Aug 2003
Location: Williamsburgland
Posts: 159
feend is still being judged by the masses


Default Xlib: extension "XFree86-DRI" missing on display ":0.0".

Xlib: extension "XFree86-DRI" missing on display ":0.0".
Using Slackware 9, X4.3
any ideas or fixxes?
Thanx,
Feend
__________________
Nothing to see here, move a long...
feend is offline  
Old Nov 23, 2003, 05:37 PM   #2
Mythos
Don't worry - Be happy!
 
Join Date: Oct 2003
Location: Crete, Hellas
Posts: 1,909
Mythos is still being judged by the masses


Default

Any more messages?
Have you copied all the files from the ATI driver in usr directory to /usr?
I guess you are missing either ATI's libGL.so.1.2 under /usr/X11R6/lib
or fglrx_dri.so under /usr/X11R6/lib/modules/dri or
fglrx_drv.o under /usr/X11R6/lib/modules/drivers
or you have erased by accident the /usr/X11R6/lib/modules/extensions/libdri.a which is installed with XFree.
Mythos is offline  
Old Nov 23, 2003, 08:40 PM   #3
feend
LinuxFeend
 
Join Date: Aug 2003
Location: Williamsburgland
Posts: 159
feend is still being judged by the masses


Default Sorry should have been more clear.

I am not using the fglx driver. I was trying to install DRI on my laptop. It has an 8M rage mobility. Do the fglx drivers suport this chip? That would rock! I have DRI installed now but I could only get X up when I used the vesa driver. (and comment out the oldDRI lib line in xfConfig.) My DVD playback is MUCH better now but I get no hardware accl.
Thanx for the info. I might try to hack on the fglx driver. I heard elseware that a few of the rage chips were really radeons. I think the hardest part of this is to identify my chip more exactly.
Thanx again,
Feend
__________________
Nothing to see here, move a long...
feend is offline  
Advertisement (Guests Only)
Login or Register to remove this ad
Old Nov 24, 2003, 12:29 AM   #4
Mythos
Don't worry - Be happy!
 
Join Date: Oct 2003
Location: Crete, Hellas
Posts: 1,909
Mythos is still being judged by the masses


Default Re: Sorry should have been more clear.

Quote:
Originally posted by feend
I am not using the fglx driver. I was trying to install DRI on my laptop. It has an 8M rage mobility. Do the fglx drivers suport this chip? That would rock! I have DRI installed now but I could only get X up when I used the vesa driver. (and comment out the oldDRI lib line in xfConfig.) My DVD playback is MUCH better now but I get no hardware accl.
Thanx for the info. I might try to hack on the fglx driver. I heard elseware that a few of the rage chips were really radeons. I think the hardest part of this is to identify my chip more exactly.
Thanx again,
Feend
No I think fglrx drivers do not support it.
Have you tried to load the r128 driver from dri?
You should have 3D acceleration with this as I have read from reports from other people.
I don't know about Xvideo. (I don't have such a chip so I can't test it)
But you should also be able to load the vidix drivers, which are supported by both xine and mplayer for a better DVD experience!
For Xine xine -V vidix and for Mplayer mplayer -vo xvidix.
Please report back!

P.S. Where did you find the oldDRI option?
Mythos is offline  
Old Nov 24, 2003, 06:52 PM   #5
feend
LinuxFeend
 
Join Date: Aug 2003
Location: Williamsburgland
Posts: 159
feend is still being judged by the masses


Default Cool!

I found the old DRI heading in my XFconfig file after I installed DRI. The r128 driver did not load properly. I did not investigate far as I got X back w/ the vesa driver and had DRI suport. Yes the xine DVD driver you mentioned works great!. I also gained 100 FPS in glxgears. But this is w/ mesa and glxinfo says I do not have direct rendering enabled. Do you think that the r128 driver will enable my 3D accel. ? It would be great if I could get the support as I hate to have a subsystem of my laptop not enabled in linux.
My desk top runs RH8.0 and my laptop is on Slack 9. I will be migrating to Slack on my next upgrade on my work station. This is because Slack has the kind of install I like. NO fluff and compleatly configureable. I wish I could get Gentoo to install properly as it craps out at random points in the install process. NO great loss as I love Slack. I used to use Debian and before that MDK, and before that RH 5.2....
Thanx,
Feend
__________________
Nothing to see here, move a long...
feend is offline  
Old Nov 25, 2003, 01:25 AM   #6
Mythos
Don't worry - Be happy!
 
Join Date: Oct 2003
Location: Crete, Hellas
Posts: 1,909
Mythos is still being judged by the masses


Default Re: Cool!

Quote:
Originally posted by feend
The r128 driver did not load properly. I did not investigate far as I got X back w/ the vesa driver and had DRI suport. Yes the xine DVD driver you mentioned works great!. I also gained 100 FPS in glxgears. But this is w/ mesa and glxinfo says I do not have direct rendering enabled. Do you think that the r128 driver will enable my 3D accel. ? It would be great if I could get the support as I hate to have a subsystem of my laptop not enabled in linux.
With vesa you do not have DRI support. It fallbacks to software acceleration.
With the r128 you should be able to get 3D hardware acceleration, but of course I can't guarantee anything!
Don't forget to load the appropriate r128.o module from /lib/modules/"your_linux_version"/kernel/drivers/char/drm.
If this doens't exist create it from your kernel source tree.
Mythos is offline  
Old Feb 24, 2004, 02:53 AM   #7
darktyco
Radeon R200
 
Join Date: Dec 2001
Posts: 98
darktyco is still being judged by the masses


Default

I'm running Slackware 9.1 with dropline Gnome. I updated a couple X packages the other day and now when I run fglrxinfo I get this error. It worked before the update, any idea what needs to be fixed?
darktyco is offline  
Old Feb 24, 2004, 03:43 AM   #8
Mythos
Don't worry - Be happy!
 
Join Date: Oct 2003
Location: Crete, Hellas
Posts: 1,909
Mythos is still being judged by the masses


Default

Propably you have to reinstall the fglrx driver!
__________________
Radeon 9500 PRO - Mobility Radeon X700 - fglrx Beta driver - Xorg head CVS
Linux Santorini 2.6.16-rc2
GCC-4.1 CVS Branch
In real life Papadakos Panagiotis
Mythos is offline  
Old Feb 24, 2004, 08:54 AM   #9
darktyco
Radeon R200
 
Join Date: Dec 2001
Posts: 98
darktyco is still being judged by the masses


Default

Hey, thanks for the reply.

I forgot to mention that I did try rebuilding the module with no luck. =/
darktyco is offline  
Old Feb 24, 2004, 09:25 AM   #10
Mythos
Don't worry - Be happy!
 
Join Date: Oct 2003
Location: Crete, Hellas
Posts: 1,909
Mythos is still being judged by the masses


Default

Can you post your /var/log/XFree86.0.log?
__________________
Radeon 9500 PRO - Mobility Radeon X700 - fglrx Beta driver - Xorg head CVS
Linux Santorini 2.6.16-rc2
GCC-4.1 CVS Branch
In real life Papadakos Panagiotis
Mythos is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Xlib: extension "XFree86-DRI" missing on display ":1.0". jinxjinx Drivers 3 Feb 22, 2007 03:43 PM
Xlib: extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0". harryc Linux 31 Nov 8, 2004 04:22 PM
Xlib: extension "XFree86-DRI" missing on display ":0.0" SoniC11 Linux 9 Aug 27, 2004 02:55 PM
Xlib: extension "XFree86-DRI" missing on display ":0.0" SoniC11 Radeon Technical Support 4 Aug 26, 2004 04:31 PM
Textures "dissapearing" and portions of display "flashing" when set to AGP4X Mandor Radeon Technical Support 49 May 6, 2001 08:55 PM


All times are GMT -5. The time now is 09:49 PM.



Powered by vBulletin® Version 3.6.5
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
All trademarks used are properties of their respective owners. Copyright ©1998-2011 Rage3D.com
Links monetized by VigLink