Go Back   Rage3D » Rage3D Discussion Area » Graphics Technology Forums » CATALYST Drivers
Rage3D Subscribe Register FAQ Members List Calendar Mark Forums Read

CATALYST Drivers Discussion and Technical support forum for AMD's Catalyst Drivers. Please put Linux-specific driver posts and Remote Wonder discussion in their respective forums.

"
Reply
 
Thread Tools Display Modes
Old Jul 31, 2011, 09:56 PM   #61
Advertisement (Guests Only)

Login or Register to remove this ad
kinney
old school ownage
 
Join Date: Dec 2001
Location: United States Chicago
Posts: 213
kinney is still being judged by the masses


Default

That's the thing, with that being the case, it has to be extremely easy to fix the problem which makes it even more ridiculous.
__________________
Intel C2Q 9450@3ghz | Intel X25-M G2 160GB + Seagate GoFlex 1.5TB USB 3.0 | MSI Radeon 5870 (on latest WHQL) | 8GB Mushkin XP2-6400 (4-4-4-12) | Lian Li PC-A05NB
Asus P5Q-E (P45 / ICH10R) | Asus VS278Q-P + 2x Dell 2210s / Samsung PN50B650 | Corsair HX650 | Asus U3S6 | Win7Pro64

Dell E6430 (i5 3320M) | Intel X25-V G2 40GB | Win7Pro64
kinney is offline   Reply With Quote
Old Aug 1, 2011, 04:41 PM   #62
kn00tcn
zero-zero
 
Join Date: Jun 2006
Location: Canada Toronto
Posts: 4,643
kn00tcn is still being judged by the masses


Default

did the dev ever acknowledge this issue existed? what if they code some sort of 'initialization' that the mouse over does so that it will never happen in game?
__________________
AMD/ATI Catalyst Driver Profiles
OpenGL startup crash fix #1 / fix #2 (for < radeon 6000 cards?)
better crossfire for Section8 Prejudice, Hydrophobia, UDK
kn00tcn is offline   Reply With Quote
Old Aug 2, 2011, 08:16 PM   #63
kinney
old school ownage
 
Join Date: Dec 2001
Location: United States Chicago
Posts: 213
kinney is still being judged by the masses


Default

I would hope this means they were aware of an issue of some sort-
http://support.amd.com/us/kbarticles...easeNotes.aspx
Quote:
Kings Bounty may display rendering issues.
and

http://support.amd.com/us/kbarticles...easeNotes.aspx
Quote:
The game Kings Bounty now renders correctly.
I've been on top of this issue for over a year now, and I haven't found one person who said the issue was resolved in 11.6+.

I'm on 11.7 because staying on 10.6 with all the other advancements they've made is crazy but is it really going to be broken forever for 6xxxx users and require 10.7 or older on 5xxxx/4xxxx cards?

I did a good amount of testing WHQLs and a ton of beta releases to narrow it down to a 10.8 and onward issue.. why can't they just do a comparison in what was changed between 10.7 and 10.8 that could cause this?

Considering it did work, and if the code was reverted or adjusted to act like 10.7 and prior, I don't know if a hack like you suggest is even necessary? They already knew how to make it work.
I'm assuming if it's not fixed correctly (10.7 and prior coding), it will pop up in other games, if it doesnt already and I simply haven't played those personally.
__________________
Intel C2Q 9450@3ghz | Intel X25-M G2 160GB + Seagate GoFlex 1.5TB USB 3.0 | MSI Radeon 5870 (on latest WHQL) | 8GB Mushkin XP2-6400 (4-4-4-12) | Lian Li PC-A05NB
Asus P5Q-E (P45 / ICH10R) | Asus VS278Q-P + 2x Dell 2210s / Samsung PN50B650 | Corsair HX650 | Asus U3S6 | Win7Pro64

Dell E6430 (i5 3320M) | Intel X25-V G2 40GB | Win7Pro64
kinney is offline   Reply With Quote
Advertisement (Guests Only)
Login or Register to remove this ad
Old Aug 2, 2011, 10:06 PM   #64
jannypan
Banned
 
Join Date: Aug 2011
Posts: 1
jannypan is still being judged by the masses


Default

If I reset the driver though it goes away. with 10.8's.
jannypan is offline   Reply With Quote
Old Aug 2, 2011, 10:42 PM   #65
kinney
old school ownage
 
Join Date: Dec 2001
Location: United States Chicago
Posts: 213
kinney is still being judged by the masses


Default

Quote:
Originally Posted by jannypan View Post
If I reset the driver though it goes away. with 10.8's.
Can you provide a little more information on 'resetting the driver'? Goes away forever? Goes away for your session?
__________________
Intel C2Q 9450@3ghz | Intel X25-M G2 160GB + Seagate GoFlex 1.5TB USB 3.0 | MSI Radeon 5870 (on latest WHQL) | 8GB Mushkin XP2-6400 (4-4-4-12) | Lian Li PC-A05NB
Asus P5Q-E (P45 / ICH10R) | Asus VS278Q-P + 2x Dell 2210s / Samsung PN50B650 | Corsair HX650 | Asus U3S6 | Win7Pro64

Dell E6430 (i5 3320M) | Intel X25-V G2 40GB | Win7Pro64
kinney is offline   Reply With Quote
Old Aug 9, 2011, 06:28 PM   #66
kinney
old school ownage
 
Join Date: Dec 2001
Location: United States Chicago
Posts: 213
kinney is still being judged by the masses


Default

Time for a fix.
__________________
Intel C2Q 9450@3ghz | Intel X25-M G2 160GB + Seagate GoFlex 1.5TB USB 3.0 | MSI Radeon 5870 (on latest WHQL) | 8GB Mushkin XP2-6400 (4-4-4-12) | Lian Li PC-A05NB
Asus P5Q-E (P45 / ICH10R) | Asus VS278Q-P + 2x Dell 2210s / Samsung PN50B650 | Corsair HX650 | Asus U3S6 | Win7Pro64

Dell E6430 (i5 3320M) | Intel X25-V G2 40GB | Win7Pro64
kinney is offline   Reply With Quote
Old Aug 10, 2011, 11:07 PM   #67
kn00tcn
zero-zero
 
Join Date: Jun 2006
Location: Canada Toronto
Posts: 4,643
kn00tcn is still being judged by the masses


Default

Quote:
Originally Posted by kinney View Post
I would hope this means they were aware of an issue of some sort-
no, the kings bounty dev, not the driver team
__________________
AMD/ATI Catalyst Driver Profiles
OpenGL startup crash fix #1 / fix #2 (for < radeon 6000 cards?)
better crossfire for Section8 Prejudice, Hydrophobia, UDK
kn00tcn is offline   Reply With Quote
Old Aug 11, 2011, 03:34 PM   #68
kinney
old school ownage
 
Join Date: Dec 2001
Location: United States Chicago
Posts: 213
kinney is still being judged by the masses


Default

Quote:
Originally Posted by kn00tcn View Post
no, the kings bounty dev, not the driver team
if it worked in 10.7 then it's a driver issue not an issue with the game
__________________
Intel C2Q 9450@3ghz | Intel X25-M G2 160GB + Seagate GoFlex 1.5TB USB 3.0 | MSI Radeon 5870 (on latest WHQL) | 8GB Mushkin XP2-6400 (4-4-4-12) | Lian Li PC-A05NB
Asus P5Q-E (P45 / ICH10R) | Asus VS278Q-P + 2x Dell 2210s / Samsung PN50B650 | Corsair HX650 | Asus U3S6 | Win7Pro64

Dell E6430 (i5 3320M) | Intel X25-V G2 40GB | Win7Pro64
kinney is offline   Reply With Quote
Old Sep 9, 2011, 12:26 AM   #69
kn00tcn
zero-zero
 
Join Date: Jun 2006
Location: Canada Toronto
Posts: 4,643
kn00tcn is still being judged by the masses


Default

i know, but if hovering over a button & getting a tooltip would fix it, that could mean the game can 'execute' the same 'code' that is happening for that tooltip & possibly fix it for good
__________________
AMD/ATI Catalyst Driver Profiles
OpenGL startup crash fix #1 / fix #2 (for < radeon 6000 cards?)
better crossfire for Section8 Prejudice, Hydrophobia, UDK
kn00tcn is offline   Reply With Quote
Old Sep 11, 2011, 09:41 PM   #70
kinney
old school ownage
 
Join Date: Dec 2001
Location: United States Chicago
Posts: 213
kinney is still being judged by the masses


Default

I'm sure either side could fix it, since the post 10.7 drivers broke it, and the game was designed for earlier drivers.. but it'd be nice if AMD were a little more pro-active and went ahead and took care of this. If any part of the community is asking for a fix, for something that was broken, I don't know why no one cares to fix it.

If a game patch broke it, then I'd be blaming the developers of the game. Since a driver release(s) broke it, I'm here instead.

This is just the way business is done anymore, "buyer beware".
__________________
Intel C2Q 9450@3ghz | Intel X25-M G2 160GB + Seagate GoFlex 1.5TB USB 3.0 | MSI Radeon 5870 (on latest WHQL) | 8GB Mushkin XP2-6400 (4-4-4-12) | Lian Li PC-A05NB
Asus P5Q-E (P45 / ICH10R) | Asus VS278Q-P + 2x Dell 2210s / Samsung PN50B650 | Corsair HX650 | Asus U3S6 | Win7Pro64

Dell E6430 (i5 3320M) | Intel X25-V G2 40GB | Win7Pro64
kinney is offline   Reply With Quote
Old Sep 13, 2011, 10:39 PM   #71
kn00tcn
zero-zero
 
Join Date: Jun 2006
Location: Canada Toronto
Posts: 4,643
kn00tcn is still being judged by the masses


Default

for sure, but it's the priority of what games get looked at (& if beta testers can replicate the issue & then if the driver team can as well)

so in this case, i'd pressure the devs more to try & create a little trick in the game
__________________
AMD/ATI Catalyst Driver Profiles
OpenGL startup crash fix #1 / fix #2 (for < radeon 6000 cards?)
better crossfire for Section8 Prejudice, Hydrophobia, UDK
kn00tcn is offline   Reply With Quote
Old Oct 8, 2011, 11:18 PM   #72
Max800xl
Radeon HD 6670
 
Join Date: Sep 2006
Posts: 36
Max800xl is still being judged by the masses


Default

It's fixed! I installed the Catalyst 11.10 Preview 2 (the BF3 + Rage driver) and the flickering in King's Bounty stopped!

I also added a second 6970 since I last tested the game so I'm not sure if the Crossfire configuration has anything to do with it.

Either way I'm happy now . Better late than never AMD
__________________
Case: Lian Li PC7FW CPU: Intel Core i7 2600k @ 4.4Ghz - CPU Cooler: Noctua NH-DH14 + Arctic Silver 5 - MB: Asus P8Z68-V Pro - RAM: 16GB (4x4GB) G.SKILL Ripjaws X F3-12800CL8D - VGA: 2x Sapphire 6970 in CrossfireX
PSU: Corsair HX750 - HD: WD Velociraptor 300GB + Crucial M4 64GB SSD (Intel SRT) + 2x WD Caviar Black 640GB (Raid 1) + WD Caviar Black 1TB - LCD: Asus PA246Q - Mouse: Gigabyte M8000X - OS: Windows 7 Ultimate x64
Max800xl is offline   Reply With Quote
Old Oct 9, 2011, 12:03 AM   #73
kinney
old school ownage
 
Join Date: Dec 2001
Location: United States Chicago
Posts: 213
kinney is still being judged by the masses


Default

I'll try this out in a bit.

You realize they probably spent 0 time trying to fix the Kings Bounty issue for 6xxx owners.. this was most likely fixed by a change made for Battlefield 3. Be interesting to see if the preview driver specifically BF3 also produced the same results you saw.
I'll never turn down a fix, but I'm not happy with AMD at this point. Just a preemptive response to anyone reading this (not you Max): I know, I know, I'm a meaningless customer that doesn't matter, don't let the door hit me on the way out, they don't need my business if I'm not happy with AMD.
__________________
Intel C2Q 9450@3ghz | Intel X25-M G2 160GB + Seagate GoFlex 1.5TB USB 3.0 | MSI Radeon 5870 (on latest WHQL) | 8GB Mushkin XP2-6400 (4-4-4-12) | Lian Li PC-A05NB
Asus P5Q-E (P45 / ICH10R) | Asus VS278Q-P + 2x Dell 2210s / Samsung PN50B650 | Corsair HX650 | Asus U3S6 | Win7Pro64

Dell E6430 (i5 3320M) | Intel X25-V G2 40GB | Win7Pro64

Last edited by kinney : Oct 10, 2011 at 11:16 PM.
kinney is offline   Reply With Quote
Old Oct 10, 2011, 11:12 PM   #74
kinney
old school ownage
 
Join Date: Dec 2001
Location: United States Chicago
Posts: 213
kinney is still being judged by the masses


Default

This issue isn't fixed in http://support.amd.com/us/kbarticles...eDriverV2.aspx, I think what you found was somehow the fix they put into 11.6 took effect on your system. Which doesn't make a lot of sense because it hasn't for anyone else. It might be your particular monitor configuration and video card config that the fix worked with.
I use dual monitors, with the secondary on the right (yes this sometimes matters, I've seen it with Citrix client software even), on a single 5870.


I gave up on a fix realistically at the 11.6 release, but have given up on sticking with the 10.6s as well. They are too old and missing too many features/optimizations to keep using at this point. Using the 11.10preview2 drivers at the moment and they seem OK..
As long as they don't break automatic switchover of the audio stream to HDMI like they did in 11.8, I'll be content as one can be.
__________________
Intel C2Q 9450@3ghz | Intel X25-M G2 160GB + Seagate GoFlex 1.5TB USB 3.0 | MSI Radeon 5870 (on latest WHQL) | 8GB Mushkin XP2-6400 (4-4-4-12) | Lian Li PC-A05NB
Asus P5Q-E (P45 / ICH10R) | Asus VS278Q-P + 2x Dell 2210s / Samsung PN50B650 | Corsair HX650 | Asus U3S6 | Win7Pro64

Dell E6430 (i5 3320M) | Intel X25-V G2 40GB | Win7Pro64

Last edited by kinney : Oct 10, 2011 at 11:16 PM.
kinney is offline   Reply With Quote
Old Oct 18, 2011, 09:37 AM   #75
Max800xl
Radeon HD 6670
 
Join Date: Sep 2006
Posts: 36
Max800xl is still being judged by the masses


Default

Sorry it didn't work for you.

I tried the 11.9 and it also works, so I can assume that the "fix" is more related to the fact I'm using crossfire now, rather than the drivers.
__________________
Case: Lian Li PC7FW CPU: Intel Core i7 2600k @ 4.4Ghz - CPU Cooler: Noctua NH-DH14 + Arctic Silver 5 - MB: Asus P8Z68-V Pro - RAM: 16GB (4x4GB) G.SKILL Ripjaws X F3-12800CL8D - VGA: 2x Sapphire 6970 in CrossfireX
PSU: Corsair HX750 - HD: WD Velociraptor 300GB + Crucial M4 64GB SSD (Intel SRT) + 2x WD Caviar Black 640GB (Raid 1) + WD Caviar Black 1TB - LCD: Asus PA246Q - Mouse: Gigabyte M8000X - OS: Windows 7 Ultimate x64
Max800xl is offline   Reply With Quote
Old Oct 18, 2011, 06:36 PM   #76
kinney
old school ownage
 
Join Date: Dec 2001
Location: United States Chicago
Posts: 213
kinney is still being judged by the masses


Default

Quote:
Originally Posted by Max800xl View Post
Sorry it didn't work for you.

I tried the 11.9 and it also works, so I can assume that the "fix" is more related to the fact I'm using crossfire now, rather than the drivers.
Sounds like it'd be an easy fix for AMD if it's working on 6series Xfire. There is not a single driver that fixes the issue for 6 series single GPU users. 5 series can use 10.6 (or 10.7 but I found other crippling bugs in that release).

Really discouraging if I spend money on a new card soon to go with a 6xxx, I'm afraid I couldn't justify it to remain annoyed with this bug in my favorite game.
__________________
Intel C2Q 9450@3ghz | Intel X25-M G2 160GB + Seagate GoFlex 1.5TB USB 3.0 | MSI Radeon 5870 (on latest WHQL) | 8GB Mushkin XP2-6400 (4-4-4-12) | Lian Li PC-A05NB
Asus P5Q-E (P45 / ICH10R) | Asus VS278Q-P + 2x Dell 2210s / Samsung PN50B650 | Corsair HX650 | Asus U3S6 | Win7Pro64

Dell E6430 (i5 3320M) | Intel X25-V G2 40GB | Win7Pro64
kinney is offline   Reply With Quote
Old Apr 27, 2012, 01:22 AM   #77
vadmajom
Newbie
 
Join Date: Apr 2012
Posts: 2
vadmajom is still being judged by the masses


Default

AMD finally solved the problem -with catalyst 12.4 driver no more flickering
vadmajom is offline   Reply With Quote
Old Apr 27, 2012, 01:46 AM   #78
kinney
old school ownage
 
Join Date: Dec 2001
Location: United States Chicago
Posts: 213
kinney is still being judged by the masses


Default

Quote:
Originally Posted by vadmajom View Post
AMD finally solved the problem -with catalyst 12.4 driver no more flickering
Your post prompted me to check 12.3whql which I'm still on... no more problem. Makes me wonder when it was fixed? I gave up on trying the drivers out on the game around 12.1 or so.
__________________
Intel C2Q 9450@3ghz | Intel X25-M G2 160GB + Seagate GoFlex 1.5TB USB 3.0 | MSI Radeon 5870 (on latest WHQL) | 8GB Mushkin XP2-6400 (4-4-4-12) | Lian Li PC-A05NB
Asus P5Q-E (P45 / ICH10R) | Asus VS278Q-P + 2x Dell 2210s / Samsung PN50B650 | Corsair HX650 | Asus U3S6 | Win7Pro64

Dell E6430 (i5 3320M) | Intel X25-V G2 40GB | Win7Pro64
kinney is offline   Reply With Quote
Old Apr 27, 2012, 08:56 AM   #79
Wagnard
Back to the Green Side!
 
Join Date: Aug 2007
Location: Canada Quebec
Posts: 597
Wagnard is still being judged by the masses


Default

Great !
Wagnard is offline   Reply With Quote
Old Apr 28, 2012, 01:47 AM   #80
kinney
old school ownage
 
Join Date: Dec 2001
Location: United States Chicago
Posts: 213
kinney is still being judged by the masses


Default

Before I run drivercleaner to install 12.4 I'm going to install over my current set with 12.2->12.1->11.12 until I find where it was fixed. I'm curious as I'm sure this was fixed through work on another game or engine.
I'm guessing it was fixed in 12.2, because for me that release was particularly solid and 12.3 has been as well. I'm sure 12.4 is more of the same.

And if you read this thread which now stems back to the problem that started TWO YEARS AGO, with the last good driver for KB being 10.7- you'll see stories and excuses range from "it's the games problem" to "works here!" :P
__________________
Intel C2Q 9450@3ghz | Intel X25-M G2 160GB + Seagate GoFlex 1.5TB USB 3.0 | MSI Radeon 5870 (on latest WHQL) | 8GB Mushkin XP2-6400 (4-4-4-12) | Lian Li PC-A05NB
Asus P5Q-E (P45 / ICH10R) | Asus VS278Q-P + 2x Dell 2210s / Samsung PN50B650 | Corsair HX650 | Asus U3S6 | Win7Pro64

Dell E6430 (i5 3320M) | Intel X25-V G2 40GB | Win7Pro64
kinney is offline   Reply With Quote
Old Apr 28, 2012, 01:49 AM   #81
AdamK47
Radeon HD 6970
 
Join Date: Dec 2001
Posts: 625
AdamK47 can beat 'Minesweeper' on any difficultyAdamK47 can beat 'Minesweeper' on any difficulty


Default

Excellent! It took them only 3 years to fix it.
AdamK47 is offline   Reply With Quote
Old May 2, 2012, 06:08 AM   #82
vadmajom
Newbie
 
Join Date: Apr 2012
Posts: 2
vadmajom is still being judged by the masses


Default

Quote:
Originally Posted by kinney View Post
Before I run drivercleaner to install 12.4 I'm going to install over my current set with 12.2->12.1->11.12 until I find where it was fixed. I'm curious as I'm sure this was fixed through work on another game or engine.
I'm guessing it was fixed in 12.2, because for me that release was particularly solid and 12.3 has been as well. I'm sure 12.4 is more of the same.

And if you read this thread which now stems back to the problem that started TWO YEARS AGO, with the last good driver for KB being 10.7- you'll see stories and excuses range from "it's the games problem" to "works here!" :P
It must be fixed in 12.2 or 12.3 because I had 12.1 before 12.4 and with that driver I still had the flickering "effect".
vadmajom is offline   Reply With Quote
Old May 2, 2012, 11:26 AM   #83
kinney
old school ownage
 
Join Date: Dec 2001
Location: United States Chicago
Posts: 213
kinney is still being judged by the masses


Default

12.2 fixed my multimonitor profile issue http://www.youtube.com/watch?v=aTBRt...&feature=g-upl
Which has been an issue for quite some time. Over a year, I'm not sure when that bug started- but it stopped in 12.2

That's why I thought 12.2 was such a good release, no obvious gamebugs that I came across and they fixed a long running issue. I haven't gotten to testing 12.2-prior but I will soon.
__________________
Intel C2Q 9450@3ghz | Intel X25-M G2 160GB + Seagate GoFlex 1.5TB USB 3.0 | MSI Radeon 5870 (on latest WHQL) | 8GB Mushkin XP2-6400 (4-4-4-12) | Lian Li PC-A05NB
Asus P5Q-E (P45 / ICH10R) | Asus VS278Q-P + 2x Dell 2210s / Samsung PN50B650 | Corsair HX650 | Asus U3S6 | Win7Pro64

Dell E6430 (i5 3320M) | Intel X25-V G2 40GB | Win7Pro64
kinney is offline   Reply With Quote
Old May 3, 2012, 01:12 AM   #84
kinney
old school ownage
 
Join Date: Dec 2001
Location: United States Chicago
Posts: 213
kinney is still being judged by the masses


Default

Confirmed.
12.1WHQL was the last driver to exhibit the KB flickering bug.

12.2WHQL was definitely a solid release- the multimonitor bug was fixed that I noted above and KB flickering. That's it for driver issues that I've come across. Same results with 12.3WHQL.
The only thing noteworthy about 12.2 WHQL is that it reports itself as 12.3, when it's not. This was a known issue that slipped by the Catalyst team according to their Twitter feeds.
I moved from 12.3->12.4 now, no flickering in KB. I haven't done extensive testing but I did notice 12.4WHQL reports itself in CCC as 12.1. We saw this in 12.2, I'm not sure this is even funny anymore. I've read accounts about HDMI audio problems with 12.4 but haven't tested that yet myself.

Overall though anything between 10.8-12.1 was no good for KB and while 5xxxx users could revert to 10.7 or earlier- we now have working drivers for 5, 6 and 7 series users.

edit- Uninstalled 12.4 and went back to 12.3. Had a number of issues that I don't encounter on 12.3, namely driver resets (crashes).

Looking over the 12.2WHQL release notes, the only thing in 12.2 release notes that might have inadvertently fixed the issue is-
"Battlefield – Bad Company 2: Random flickering when playing in DirectX 11 mode."

Either way nice to lay this to rest finally, now that I've got Diablo3 to replace KB. :-P
__________________
Intel C2Q 9450@3ghz | Intel X25-M G2 160GB + Seagate GoFlex 1.5TB USB 3.0 | MSI Radeon 5870 (on latest WHQL) | 8GB Mushkin XP2-6400 (4-4-4-12) | Lian Li PC-A05NB
Asus P5Q-E (P45 / ICH10R) | Asus VS278Q-P + 2x Dell 2210s / Samsung PN50B650 | Corsair HX650 | Asus U3S6 | Win7Pro64

Dell E6430 (i5 3320M) | Intel X25-V G2 40GB | Win7Pro64

Last edited by kinney : May 26, 2012 at 12:12 AM.
kinney is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
King's Bounty Sweetz PC Gaming 26 Jun 7, 2012 01:23 AM
King's Bounty: The Legend P1x44r PC Gaming 112 Nov 17, 2010 08:43 PM
Will King's Bounty: The Legend run on an ATI xpress 200? borat PC Gaming Support 2 Sep 15, 2010 09:08 PM
Need help with King's Bounty Melhisedek PC Gaming 4 Oct 1, 2009 09:15 AM
King's Bounty: the Legend demo is OUT! MadMartigan PC Gaming 5 Sep 16, 2008 03:38 PM


All times are GMT -5. The time now is 10:10 AM.



Powered by vBulletin® Version 3.6.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
All trademarks used are properties of their respective owners. Copyright ©1998-2011 Rage3D.com
Links monetized by VigLink