View Single Post
Old Jan 17, 2019, 09:14 PM   #3
CurrentlyPissed
Mad, not drunk.
 
Join Date: Jul 2004
Location: United States Missouri
Posts: 13,771
CurrentlyPissed is not someone to be trifled withCurrentlyPissed is not someone to be trifled withCurrentlyPissed is not someone to be trifled withCurrentlyPissed is not someone to be trifled withCurrentlyPissed is not someone to be trifled withCurrentlyPissed is not someone to be trifled withCurrentlyPissed is not someone to be trifled withCurrentlyPissed is not someone to be trifled with


Default

Quote:
Originally Posted by andino View Post
EVGA has usually been pretty spot on with their RMA's with me. If this is your 3rd RMA I'd ask to speak to a 2nd tier guy and complain to them. I'd also ask for free cross shipping since this is their multiple screw up.
They actually have cross shipped the last 2. They've been really cool about it honestly. It's just extremely freaking frustrating. I called into support and they did escalate. He did say they have been having some issues with QA management that they are working through and apologized.
__________________
Quote:
The reason I talk to myself is because I’m the only one whose answers I accept.
-George Carlin
Quote:
An arrow can only be shot by pulling it back. Remember when life is dragging you back, you are just moments away from springing forward.

So keep aiming.

-Interwebz
CurrentlyPissed is offline   Reply With Quote
Advertisement (Guests Only)
Login or Register to remove this ad