Rage3D Discussion Area

Rage3D Discussion Area (http://www.rage3d.com/board/index.php)
-   AMD Radeon Software Discussion and Support (http://www.rage3d.com/board/forumdisplay.php?f=59)
-   -   Gigacube R9600 pro Driver issue resolved (http://www.rage3d.com/board/showthread.php?t=33704819)

Bi0mic Aug 16, 2003 01:41 AM

Gigacube R9600 pro Driver issue resolved
hey all, after 1 1/2 hours of praying, the gigacube, with a flashed bios can now run with catalyst 3.5 and 3.6's no worries. After first making an equiry to gigacube themselves, i recieved AtiFlash and the new bios update.
The email had these attached along with a command to use - this command having a nice pattern of upside-down question marks among it - not a good sign, so taking matters into my own hands and enlisting the help of someone who knew what they were doing, we came up with the proper command to use. If anyone is having problems with their 9600pro gigacube with the newer drivers, reply here and il happily share the commands, even the batch files if required...


graham_h Aug 16, 2003 04:54 AM

hey man...me.........!!
Mines the 9600 Pro 256meg version.
I can't find any dam drivers apart from the ones it came with on the disk.
How the heck do you flash the bios on the card ?
oh how much better is the performance ?

Coruscant Aug 16, 2003 07:56 AM

My card is a gigacube 9600 128DDR, labeled in windows as a 9600 pro but in the box only puts 9600....

Anyway, i have the same problem you had, only drivers in the gigacube cd work.

How can I see the bios version of my card?? Could you send me that files??


[email protected]

Bi0mic Aug 16, 2003 04:09 PM

alright guys, first and foremost USE ANY OF THIS INFORMATION AT YOUR OWN RISK - I SUGGEST WRITING TO GIGACUBE TO SEE WHAT INSCRUCTIONS YOU RECIEVE - because the ones they sent me were screwed. Anyway i had the 128md ddr version of the card - ok lets begin, firstly you need to contact gigacube themselves and alarm them of the situation (www.gigacube.com.tw) they will send you out a utility called 'atiflash', which, as you may have guessed, flashed your vga card's bios. They will also send you out a copy of YOUR SPECIFIC CARDS vga bios, so you must specify exactlye what card you have to them. Once you have these files, what i did was fire up my Windows 98 machine to make a MSDOS boot disk - therefore when i had to flash them the video card drivers were not being affected (before procededing uninstall your previous drivers). Copy the 'atiflash' files that the guy from gigacube should send you onto your msdos bootable floppy, but modify them to allow them to run with the files you recieved. (Right mouse click on batch file. click edit)

Using atiflash scared the **** outta me because to be honest i was there for an hour and a half with a dead monitor - no output whatsoever. so please USE AT YOUR OWN RISK!! I SUGGEST LOOKING AT OTHER PEOPLE THAT FLASHED RADEON DRIVERS BEFORE TAKING THE PLUNGE AND DESTROYING THAT SHINY NEW CARD.
the command goes something like this - yet before doing this i suggest making a backup of your bios first. The flash command looks like this:

atiflash -f -p 0 yournewbios.bat
(extension doesnt have to be .bat)

yet the backup line looks like this:

atiflash -s 0 backup.bin

where backup.bin is a filename you want to call your bios backup. It really should be as simple as that - yet i had one more herdle, even with these commands it still didnt work - after remembering the error message i got before my screen cut - flashing the bios - i remembered it had a cry about a timing error. This is where i got the help of that computer proffessional that was around in the mainframe days - he tried all i did but the last attempt, because we werent getting a signal, he rediverted what the screen should say to a text file... for all you mainframers you know what im on about, for those who dont its something like this:

atiflash -s 0 backup.bin>filename

where filename is obviously your filename. Not sure if it needs an extension though.

After a reboot it worked.. catalyst 3.6's on now and running fine - it was a close shave and dont want to go through that again - do your homework first ppl because i didnt and thats why i nearly had to snap my 9600pro.


Bi0mic Aug 16, 2003 04:12 PM

Sorry for double post - but that timing error i was referring to about the dviverting, the divert obviously added some extra time to the process therefore getting around the issue of timing.. fluke some would say


Bi0mic Aug 16, 2003 04:15 PM

dam 3 posts in a row .. not a good sign ay - but to answer that first question, a sllight fps increase but not enough to warrant the panic i went through!! also with that flash command, yournewbios.bat is the bios they send out to you


graham_h Aug 16, 2003 10:54 PM

ok for a 'slight' increase I don't need the stress.
Now what about a volt Mod ?
Any suggestions from the Pros of the forums ?

spyre Aug 16, 2003 11:03 PM

You would be better off posting in the overclocking forum here


to get that question answered

graham_h Aug 17, 2003 03:24 PM

fair comment spyre....will do :)

Coruscant Aug 17, 2003 05:22 PM


How much time did you have to wait for a response from gigacube??

I've waited for 3 days and no response... :confused:

Bi0mic Aug 18, 2003 03:40 AM

about a week before i got my reply .. they should reply dw

Coruscant Aug 19, 2003 10:44 AM

Well, they finally sent me the bios file, i downloaded the flash utility from them web and voilá... Radeon working on catalyst 3.6!!

Yujuuu :)

graham_h Aug 19, 2003 03:56 PM

ok i've got the bios (thanks BiOmic)
but what the heck does this mean
Dear customer :
To resolve the incompatibility issue with latest update ATI Catalyst
revision(catalyst 3.6), users has to update the previous firmware (VGA BIOS) on
the Radeon 9600PRO 256MB card with the attached Flash utility (FLASHROM.EXE) and
the firmware (R96PD3.S3).
Before updating VGA card BIOS ,please un-install the previous ATI drivers and
re-boot your system in DOS mode then following below step :

step 1, save all [Jeff] five attached files to the floppy disk
step 2 , boot your computer in DOS mode and type "A :" and press Enter key
step 3. insert the floppy disk you made from step 1
step 4. pls type the command "FLASHROM -P 0 R96PD3.S3" and press Enter Key
step 5 . When BIOS flash complete , restart your computer and update catalist

if you don't have floppy , pls do below

Step 1 . Create a sub-directory and naming "BIOS"
Step 2. Extract the [Jeff] five attached files to the sub-directory "BIOS"
Step 3. Boot in DOS mode and type the command "cd\bios"
Step 4. Type the command ¡§FLASHROM -P 0 R96PD3.S3¡¨ and press Enter key
step 5 . When BIOS flash complete , restart your computer and update catalist

P.S. : On the command 0 = number Zero

O.k I don't have a floppy drive at all....
so i put it on a CD and ran from the command line.
Does not work....
Also the strange symbols are confusing.
Can anyone help me out :confused:

Coruscant Aug 19, 2003 06:23 PM

Ok... you have to have (juas) a fdd because you have to start in ms-dos mode.. otherwise, i don't know how to do it with a cd image....

Well, so you have the bios file, and let's suposse you've downloaded the bios utility from the web... ( flashrom.exe)...

You have to run this: ( sure yo have to be in ms-dos mode , otherwise dosgw won't work!!)

c:\flashrom -f -p 0 biosfilename

Where biosfilename is the bios you have.. ) be sure that it's suitable for your card!)

3 seconds later the flash will have finished....

Coruscant ( You have man.. :D )

jacks Aug 27, 2003 11:43 PM


I've got same card: Gigacube 9600 Pro 256MB and same problem - no driver above 3.4 will work.

Could you forward me the email you have received from Gigacube?

I want to flash my card :)

my email: [email protected]

Here is the info for my card:
Could you send me the info for your card?
SiSoftware Sandra

Video Adapter
Model : RADEON 9600 PRO
Chipset : Radeon 9600 Pro AGP (0x4150)
RAMDAC : Internal DAC(500MHz)
Video BIOS : BK-ATI VER008.015.005.000
VGA Compatible : No
Total Memory : 256MB (255MB Video) (56MB AGP)
Texture Memory : 311MB
Supports DIME Texturing : Yes

AGP Capabilities
Version : 3.00
Command Queue Length : 256
Fast-Writes Enabled : Yes
Isochronous Mode Enabled : No
Addressing Enabled : 32-bit
Data Transfer Modes Support : 4x 8x
Current Data Transfer Rate : 8x

Video BIOS
Date : 03/06/13
Version : 4A35.S1

Current Video Mode
Mode : 1280x1024 16M+ TrueColour (32-bit)
Current Refresh Rate : 75Hz
Virtual Desktop Size : 1280x1024

Video Driver
Model : ati2mtag.sys
Version :
Expected Windows Version : 4.00
Video Acceleration : Yes
Screen Saver Active : No
Low Power Saving Active : 20 minutes(s)
Power Off Saving Active : 20 minutes(s)

Pisi78 Aug 28, 2003 03:41 AM


Originally posted by graham_h

O.k I don't have a floppy drive at all....
so i put it on a CD and ran from the command line.
Does not work....
Also the strange symbols are confusing.
Can anyone help me out :confused: [/b]
you have to boot in a clean DOS mode, the commandline of XP doesn't work.

You have to find a DOS bootdisk image and burn it with nero, or if you have a Win98se cd, you can boot with that.

graham_h Aug 28, 2003 03:15 PM

ok all sorted, did it with a floppy drive.
I wouldn't bother though, cause now the card won't complete 3d '03 with the cat 3.6 drivers.
Locks up on the cpu test at the end. doesn't matter wether the cpu is overclocked or not.
I'm going to try a different bios if i can find one.
maybe from another 256 meg 9600 pro card.

Can we all e-mail Gigacube too to make them aware of the bios issue.
I really don't think the card is too bad, it just needs a decent bios to run it.

graham_h Aug 28, 2003 03:28 PM

Here's the e-mail I just sent
''We listen to our customers and understand their needs'

Hi guys,
I own the 256meg 9600 pro lite. I have flashed the rom with the latest bios from you so the card will run the
ATi 3.6 cat drivers. There are still issues with this card. It will not complete 3D Mark 2003 at all. Even with the card and the CPU
running a default speeds. It locks up on the CPU test at the end. It DID not do this before the Bios 'upgrade'.
Could you please take a look at the Bios file and run futher tests and fix the problem that all the owners of this card are having.
If you would like to give some input please go the this discussing area.
Also could you please update your website with the relevant driver issues and information.

Hopefully it'll get a result...:bleh: :confused: :hmm:

spyre Aug 28, 2003 07:32 PM

Maybe the standard 9600 bios would help (if you can find one) any card should be able to use any bios (in theory at least)

All times are GMT -5. The time now is 01:05 PM.

Powered by vBulletin® Version 3.6.5
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
All trademarks used are properties of their respective owners. Copyright ©1998-2011 Rage3D.com