View Full Version : How do i disable Control Panel for other users of my PC except Me?

Nov 19, 2003, 01:43 AM
I am running Windows Xp Professional Edition on my pc and More than one person uses my pc so i made them their own limited account.Now I understand that with a limited account that the user cannot change options on the control panel but I want to make it that they cant access the control panel or anything in "My computer" period,Like when they double click on "my computer" I want it to give them like a messagebox saying "access denied" or something.Is there anyway I can go about doing this? And also I want to know how i can disable acccess to my second hard drive because i have alot of stuff(porn,games,music,etc etc) that i do not want for it to be tanpered with. I want it so that the person doesnt even know that there is another hardrive or even if they know and can see it,I want to make it that they cant open it and view any directories and files at all. I know what im asking may or may not be simple but i spent hours looking through the control panel trying to find options that would allow me to have those restrictions on the "Limited Account" that i have on my pc and couldnt find anything and the one thing that i did find was greyed out(disabled).Can someone help?

P.S NO i am not on any kind of network,Its just one pc with 2 user accounts(Me with the Admin privelages and another limited account.

Nov 19, 2003, 04:18 AM
I'm going to empower you, but in now way take responsibility. Make sure you take the regular precautions when working in the refistry before doing this. It's not hard, and I do it all the time though.

Log in as the user you want to restrict.
Run regedit

Go to
You can add these DWORD values with an integer value of 0 or 1. 1 turns them on 0 is the same as them not even being there.
NoDeletePrinter : Disables printer deletion
NoAddPrinter : Disables printer adding
NoRun : Removes run from the start menu
NoSetFolders : Removes folders from the Settings option on Start Menu
NoSetTaskbar : Removes taskbar settings
NoFind : removes find from the start menu
NoDrives : Hides all drives in My Comuter
NoNetHood : Removes network neighborhood icon from the desktop
NoDesktop : Hides ALL items on the desktop
NoClose : Disables Shutdown
NoRecentDocHistory : Removes recent docs from start menu
ClearRecentDocsOnExit : Clears doc menu on exit
NoInternetIcon : Removes internet icon from desktop

Can also create key
NoDispCPL : Hides trhe control panel
NoDispBackgroundPage : Hides background change page
NoDispScrsavPage : Hides the screen saver page
NoDispAppearancePage: Hides appearance setting page
NoSecCPL : Hides secure control panel
NoPwdPage : Hides change password page
NoAdminPage : Hides remote admin page
NoProfilePage : Hides user profile page
NoDevMgrPage : Hides device manager page
NoConfigPage : Hides hardware profiles page
NoFileSysPage : Hides file system button
NoVirtMemPage : Hides Virtual Memory Button

Can also create key
Disabled : Disables MS-DOS prompt
NoRealMode : Disable Single-Mode MS-DOS

Can also create key
NoNetSetupSecurityPage : Hides network security page
NoNelSetup : Hides Network options in control panel
NoNetSetupIDPage : Hides ID page
NoNetSetupSecurityPage : Hides access control page
NoFileSharingControl : Disables file sharing controls
NoPrintSharing : Disables print share control

As for the drive. Login as Administrator, right-click on the drive in question.

If it's formatted NTFS(then you're in luck) click security. If it's not NTFS

you're sol. Remove all users except Administrator.

Nov 19, 2003, 10:38 AM
There is no way to completely hide them in your situation. You could use registry hacks or Group Policy, but they would apply to you as well as others, which I'm sure you don't want.

Just keep them as a restricted user and remove thier permission to view the contents of the other drive.

To change NTFS permissions, go to Tools > Folder Options in the Explorer menu. Click on the view tab, and in the list box, make sure that the Use simple file sharing checkboc is unchecked. Click OK, find your drive, right-click on it, and click on the security tab. Remove all acounts except your own and Administrators, click Apply (not OK). Then click on Advanced, check the checkbox that says something to the effect of resetting child permissions, and click OK.

Create a restricted User account (BTW, Computer Management is a much better way of managing users), and test out if your restrictions worked.

Nov 19, 2003, 01:21 PM
Thanks this helped a bunch