PDA

View Full Version : Vampire Bloodlines Performance Improvement


Dr. Zhivago
Mar 8, 2005, 12:41 PM
My GF plays VTMB on my main PC (see sig) and the performance has always left a bit to be desired. HL2 runs far superior to this game. I have been hunting for ways to improve the performance and have found nothing really that has been of any help. Seems a lot of people don't get the performance they expect out of this game. The latest patch is installed and the game doesn't crash or anything, but it bugged the hell out of me that I couldn't disable Vysnc or enable Triple Buffering to smooth out the rendering of frame rates.

Today, while hunting through the command variable list in the console, I came across this little gem:

mat_forcehardwaresync

By default, it's set to "1" which forces vsync on. And combined with double buffering, the only possible frame rates that can be rendered on my system are 85, 43, 22, 11, etc... Needless to say, the smoothness of the game isn't what it should be.

So, I entered the following string in the config.cfg file in the game's vampire\cfg directory:

mat_forcehardwaresync "0"

Loaded the game and lo and behold all possible frame rates are now rendered. The game is much, much smoother. Since the frame rates rarely exceed 85Hz, texture tearing isn't an issue.

Prior to finding this, I asked Activsion Support if a patch was going to be released which would add the Options to enable/disable Vsync and Triple Buffering. They told me they could not say whether or not this would ever be addressed. Only to watch the websites for further developments. I've since told Activision support about my findings. I'll update this post when/if I hear from them.

Hope this helps someone.

Peace.
Dr. Z

Pr()ZaC
Mar 8, 2005, 12:46 PM
Good job!

Guts
Mar 8, 2005, 01:10 PM
wow thanks for the info, i can run the game just fine, but i knew there was something going on, im gonna do this when i get the chance. :lol:

Dr. Zhivago
Mar 8, 2005, 01:21 PM
Thanks guys and let me know how it works out.

Peace!
Dr. Z

-=Antimatter=-
Mar 8, 2005, 03:33 PM
I know one of my friends was having a problem with this. I'll tell him about your fix and see if it works.

Skinner
Mar 8, 2005, 04:12 PM
Hmm, triple buffering was always on by default in my case, I have tested this with fraps...

btw, I'm stail waiting for HL2 to get TB

Nagorak
Mar 8, 2005, 09:25 PM
Wouldn't forcing VSync to off in the driver controls have forced it to be off anyway? How can a game override the graphics driver Vsync override?

Dr. Zhivago
Mar 8, 2005, 10:18 PM
Nothing I tried would put this game in vsync off. This was the only solution. the mat_forcehardwaresync overrides the drivers setting. There are similar commands in other game engines. The Q3A engine for instance...

And to Skinner's comment about Triple Buffering being enabled, I made SURE that it wasn't by running FRAPS and the cl_showfps command in game as well. I had 85 FPS or 43 or 22, etc. and NOTHING in between.

Peace.
Dr. Z